Author Topic: Games minimising themselves every 30 minutes. (Fixed on 4th January)  (Read 6839 times)

0 Members and 1 Guest are viewing this topic.

Offline MartinZ

  • Moderator
  • Advanced Poster
  • *
  • Posts: 1062
  • Product Manager
So the cause of this bug is discovered. We just released a hotfix for this issue, it should be distributed to all clients in next 24 hours. The bug appeared only on version 17.9

Offline avragorn

  • Full Member
  • ***
  • Posts: 139
Thank you very much Martin :)
My configuration : Windows 7 Premium - INTEL I5 2500K - NVIDIA/MSI GTX 1050 TI 4gb - AVAST FREE EDITION 22.5.6015

REDACTED

  • Guest
So the cause of this bug is discovered. We just released a hotfix for this issue, it should be distributed to all clients in next 24 hours. The bug appeared only on version 17.9

Amazing news! Well done to everyone who helped troubleshoot

Offline MartinZ

  • Moderator
  • Advanced Poster
  • *
  • Posts: 1062
  • Product Manager
We thank you for letting us know and for the logs ;-)

REDACTED

  • Guest
We thank you for letting us know and for the logs ;-)

If you can, can you tell us what happened? Curious to know what was causing it.

Offline avragorn

  • Full Member
  • ***
  • Posts: 139
The problem is fixed now, thank you very much :)
But an older problem occurs now, not really a problem, but I posted about it last february here : https://forum.avast.com/index.php?topic=197056.0
So now, when I stop playing games, and I come back to the windows desktop, there is a warning saying that Windows Update is deactivated and inviting me to check it in the action center, so I open the action center, and the warning goes away, because I think that Windows Update wasn't really deactivated.
So I already posted about this problem last february in the topic I linked at the beginning of this post. The problem got fixed after a few weeks, in march if I remember well. And since the hotfix of the problem of games minimising to the Windows desktop, the "problem" appears again, after 9 months.
My configuration : Windows 7 Premium - INTEL I5 2500K - NVIDIA/MSI GTX 1050 TI 4gb - AVAST FREE EDITION 22.5.6015

Offline Michal256

  • Jr. Member
  • **
  • Posts: 32
Isn't it the Avast Game Mode stopping the Windows Update service while you play a game? After leaving the game, it should automatically restart the service.

If this is an issue, you may turn off "Pause Windows Updates", in avast game mode options.

REDACTED

  • Guest
The problem is fixed now, thank you very much :)
But an older problem occurs now, not really a problem, but I posted about it last february here : https://forum.avast.com/index.php?topic=197056.0
So now, when I stop playing games, and I come back to the windows desktop, there is a warning saying that Windows Update is deactivated and inviting me to check it in the action center, so I open the action center, and the warning goes away, because I think that Windows Update wasn't really deactivated.
So I already posted about this problem last february in the topic I linked at the beginning of this post. The problem got fixed after a few weeks, in march if I remember well. And since the hotfix of the problem of games minimising to the Windows desktop, the "problem" appears again, after 9 months.

Avragorn. Like the other guy said. This is caused by a setting in game mode. It is the pausing of automatic Windows Updates. Nothing to worry about, not a bug. It’s a feature, and can be turned off within Game Mode settings.

Offline avragorn

  • Full Member
  • ***
  • Posts: 139
Re: Games minimising themselves every 30 minutes. (Fixed on 4th January)
« Reply #38 on: January 05, 2018, 01:41:36 AM »
No, it is caused by AVAST. It got fixed by an AVAST update last march. It appeared again exactly as soon as AVAST was updated with the hotfix update that fixes the minimising problem.
If it was caused by a setting in game mode, why did it disappear last march, and nothing until yesterday (thursday), until the hotfix update ? If it was caused by a setting in game mode, I would have had that all the time from last february until now.

My configuration : Windows 7 Premium - INTEL I5 2500K - NVIDIA/MSI GTX 1050 TI 4gb - AVAST FREE EDITION 22.5.6015

REDACTED

  • Guest
Re: Games minimising themselves every 30 minutes. (Fixed on 4th January)
« Reply #39 on: January 05, 2018, 02:20:42 AM »
No, it is caused by AVAST. It got fixed by an AVAST update last march. It appeared again exactly as soon as AVAST was updated with the hotfix update that fixes the minimising problem.
If it was caused by a setting in game mode, why did it disappear last march, and nothing until yesterday (thursday), until the hotfix update ? If it was caused by a setting in game mode, I would have had that all the time from last february until now.

Does it happen if you disabled it though?

Offline MartinZ

  • Moderator
  • Advanced Poster
  • *
  • Posts: 1062
  • Product Manager
Re: Games minimising themselves every 30 minutes. (Fixed on 4th January)
« Reply #40 on: January 05, 2018, 08:47:02 AM »
No, it is caused by AVAST. It got fixed by an AVAST update last march. It appeared again exactly as soon as AVAST was updated with the hotfix update that fixes the minimising problem.
If it was caused by a setting in game mode, why did it disappear last march, and nothing until yesterday (thursday), until the hotfix update ? If it was caused by a setting in game mode, I would have had that all the time from last february until now.

the hotfix wasn't related to Game mode. it's just coincidence..

Offline avragorn

  • Full Member
  • ***
  • Posts: 139
Re: Games minimising themselves every 30 minutes. (Fixed on 4th January)
« Reply #41 on: January 05, 2018, 09:44:06 AM »
@lgreg, if I disable the game mode on AVAST, when playing there are risks that the games get minimized or get slow.

@Martin, yes, but I don't say it is related to Game Mode, but I think there is something in the hotfix that causes that, because it is exactly like in last february 2017 right after I updated the program, I had AVAST 2016 version, and it updated to the 2017 version, I suddenly got this problem that is not really a problem since it is a wrong alert since Windows Update is actually not deactivated. It got fixed in march, I didn't do anything, so I guess it got fixed by an AVAST update in march. And so it is happening again since the hotfix.
Don't worry, I am not blaming you. I prefer to get this problem that is not really a problem rather than the problem of the games minimising themselves to the Windows desktop when playing.
I only say that it is happening again since the hotfix. I never got that wrong alert from march to yesterday.
And I thank you very much again for fixing that problem of games minimising themselves :)

My configuration : Windows 7 Premium - INTEL I5 2500K - NVIDIA/MSI GTX 1050 TI 4gb - AVAST FREE EDITION 22.5.6015

Offline dangeorgescu88

  • Newbie
  • *
  • Posts: 10
Re: Games minimising themselves every 30 minutes. (Fixed on 4th January)
« Reply #42 on: January 06, 2018, 01:08:18 PM »
I still have the problem, and I have the latest updates. Do I need to download the hotfix manually? I've re-attached the log file.

Offline Michal256

  • Jr. Member
  • **
  • Posts: 32
Re: Games minimising themselves every 30 minutes. (Fixed on 4th January)
« Reply #43 on: January 06, 2018, 01:12:04 PM »
If the update wasn't applied automatically, you might want to run it manually by starting the task Avast Emergency Update from Task Scheduler.

You might need to restart you computer after that, for the changes to take effect.

Offline dangeorgescu88

  • Newbie
  • *
  • Posts: 10
Re: Games minimising themselves every 30 minutes. (Fixed on 4th January)
« Reply #44 on: January 06, 2018, 02:15:08 PM »
I ran the Emergency Update. Don't know if it did anything. Were you guys asked to restart after the hotfix? How can I check if I have it?