Author Topic: Games minimising themselves every 30 minutes. (Fixed on 4th January)  (Read 6882 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Hi there,

I am experiencing a very annoying issue that I have narrowed down to being extremely likely to be Avast. This has taken me days to test as I have had to try many different things to work out what was going on. I recently started experiencing this around the time the new update came out I haven't had any issues previously with Avast.

Basically, the issue is that after 30 minutes of being in a game, the game minimises itself. The game remains open but hasn't crashed and opens normally again. (tested on multiple games, all the same result.)

I couldn't work out why this was happening so I decided to Reset my computer (keeping personal files) and work from the ground up, installing programs and logging down when I did it to try and narrow the issue. I thought it was the latest Windows update, but removing it didn't resolve so this wasn't the cause. So with a fresh PC in front of my I tried to following. This is from a clean slate and the first entry is where I started my testing.

In Windows before resetting I had tried adding exclusions for the game and also tried turning off the shields, both were separate tests and were not done at the same time, none worked.

Here is a copy of the log I kept after resetting my PC and because to attempt install stuff one by one:

25th December - installed KB4054517 again, no difference with it uninstalled (most recent update to when I started having this issue)- Rebooted and tested a game for 30 minutes (waited 40 minutes in total to verify it wouldn't happen) and the minimise didn't occur.

26th December - 14:18 - Plugged in Xbox Wireless Adapter - tested a game twice for 30 minutes (waited 40 minutes in total to verify it wouldn't happen) and the minimise didn't occur.

26th December - 15:40 - Installed Avast (Only installed File, Web and Email Shield, no other components. However turning off shields before I reset my machine, didn't help with this issue either. In the previous install before resetting, turning off shields solve the issue.

26th December - Test game... 30 minutes in, minimized to desktop.

26th December - 16:36 - Uninstall Avast and reboot.

26th December - 3 tests which lasted 40 minutes and with each the minimise didn't occur


I have since turned on my laptop and updated Avast to the same version I am having issues with, to make sure it wasn't just my machine. I tested the game multiple times with Avast installed, every single time the minimise occurred around the 30 minute mark. As mentioned above, I have tried both silent mode and disabling shields to attempt to work out if it was shields scanning or a notification taking focus. I decided to uninstall Avast, reboot and test the game again. 50 minutes later, I come back and my game is still in the foreground and not on the desktop. This is where I concluded Avast has to be the culprit in some form. The only times that I have not experienced this, is when Avast is installed.

In short, my testing for my laptop went as follows (only File, web and mail shields were on):

>update Avast to 17.9.2322
>Run game
>30 minutes later, minimise to desktop
>turned on Silent Mode
>30 minute later, minimise to desktop
>remove Avast
>run game
>50 minutes later, no minimising occured


Is anyone else experiencing this or is this known already? I was going to put a Support Ticket in but I couldn't find it and my only option was to set up a forum post. I would've reported this sooner but the testing has taken me a few days to do due to the Christmas period. Not virus related as I have scanned with both Avast and Malwarebytes.

I am happy to answer anymore questions regarding this matter.

ADDITIONAL INFO:
- Both machines run Windows 10 64-bit Creators Fall Update
- Games tested Rocket League and Assassin's Creed Origins
- Happens in Windowed and Fullscreen mode
- Avast Version tested: 17.9.2322 (latest at the time of posting)
- Each test had a reboot in-between
- No error logs in event viewer
- No Tasks scheduled to run every 30 minutes and no Task run during this time

Thanks,
Lewis
« Last Edit: January 04, 2018, 11:12:03 PM by lgreg »

Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 358
Caused by latest version of Avast 17.9.2322. Second AvastUI.exe is silently executed and popuped to front after some minutes from PC start which causes minimalize all fullscreen programs and all active windows is no loger active. I already reported this on forum. So we only need wait for fix or rollback to previous version.
« Last Edit: December 30, 2017, 12:36:55 AM by TheOwner »

REDACTED

  • Guest
Caused by latest version of Avast 17.9.2322. Second AvastUI.exe is silently executed and popuped to front after some minutes from PC start which causes minimalize all fullscreen programs and all active windows is no loger active. I already reported this on forum. So we only need wait for fix or rollback to previous version.

Hi, The Owner.

My problem doesn't exactly match yours, which is weird. I experience this pretty much at the 30 minute mark of every fullscreen game and windowed game. I don't get this when casually browsing or leaving my PC. This doesn't seem to randomly happen and is pretty consistent. It may be related though, I won't rule that out. Maybe the bug effects you more than others?

I also don't see the second UI pop up. I literally just see the desktop. No errors or anything.

I am hoping an Avast team member will weigh in on this.

Regards,
Lewis
« Last Edit: December 30, 2017, 12:55:06 AM by lgreg »

REDACTED

  • Guest
This was a problem I was having with my last build that I attributed to an old system (AMD FX 8350) about a year ago, until I decommissioned it this fall.  As it turns out, after installing Avast today - this popped up again (and several other issues that I figured were system-related - re: start menu won't open, etc).  I should've done more troubleshooting with Avast previously, but I was itching to upgrade to Ryzen.  OP, I'm interested - do you have an Intel or AMD system?

Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 358
Second AvastUI.exe is invisible, is just new proces automaticaly executed after some time from PC start, which causes minimalize all games, although this happens only once from PC start.
« Last Edit: December 30, 2017, 01:15:44 AM by TheOwner »

REDACTED

  • Guest
This was a problem I was having with my last build that I attributed to an old system (AMD FX 8350) about a year ago, until I decommissioned it this fall.  As it turns out, after installing Avast today - this popped up again (and several other issues that I figured were system-related - re: start menu won't open, etc).  I should've done more troubleshooting with Avast previously, but I was itching to upgrade to Ryzen.  OP, I'm interested - do you have an Intel or AMD system?

My gaming pc is an intel system and my laptop is just an AMD A6 APU I think. Runs rocket league on lowest so was good to test on. I actually think you should put up a post for  the start menu not opening. I noticed this but didn’t know it was Avast. I thought it was because I was doing Windows updates. The start menu issue  was on the A6 APU machine also couldn’t couldn’t access settings when the start menu worked.
« Last Edit: December 30, 2017, 12:47:43 PM by lgreg »

REDACTED

  • Guest
Second AvastUI.exe is invisible, is just new proces automaticaly executed after some time from PC start, which causes minimalize all games, although this happens only once from PC start.

That makes logical sense. If it was opening every 30 minutes that’d make sense. How do you know this may I ask? Did you test it?
« Last Edit: December 30, 2017, 12:31:55 PM by lgreg »

REDACTED

  • Guest
According to another persons post that was posted after I posted this, it seems to be the aswOfferTool and second AvastUI that interrupt full screen and windowed apps. Is there any way to officially report this?

Offline dangeorgescu88

  • Newbie
  • *
  • Posts: 10
Yes, it's true. Using Mike William's Process Logger Service, I noticed that the two processes are mentioned at the exact time the active program or game is minimized. It only seems to happen when running games on full screen. Programs like MS Office are not minimized.

Code: [Select]
12/30/2017 11:29:28
Process: [8648] C:\Program Files\AVAST Software\Avast\setup\aswOfferTool.exe
Username/Domain: [windows user folder]/DESKTOP-R9DF2R2
CommandLine: "C:\Program Files\AVAST Software\Avast\setup\aswOfferTool.exe" -checkChrome
MD5 Hash: F54FABEB4834EAA33E53E7EECD02383E
Bitness: 32-bit
Publisher: AVAST Software
Description: Avast Offer Installation Tool
Version: 17.9.3761.0
Integrity Level: High
Signer: AVAST Software s.r.o.
System Process: False
Protected Process: False
Metro Process: False
Parent: [2620] C:\Program Files\AVAST Software\Avast\AvastSvc.exe


[Process Creation]

12/30/2017 11:29:28
Process: [8912] C:\Program Files\AVAST Software\Avast\AvastUI.exe
Username/Domain: [windows user folder]/DESKTOP-R9DF2R2
CommandLine: "C:\Program Files\AVAST Software\Avast\AvastUI.exe" --type=renderer --disable-gpu-compositing --disable-pinch --no-sandbox --primordial-pipe-token=F5C53A62102BABC965FB8E684ABAF040 --lang=en-US --lang=en-US --log-file="C:\Users\[windows user folder]\AppData\Roaming\AVAST Software\Avast\log\cef_log.txt" --log-severity=error --user-agent="Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.3.2987.1601 Safari/537.36 Avastium (17.9.2322)" --proxy-auto-detect --disable-webaudio --mute-audio --force-wave-audio --disable-gpu --disable-software-rasterizer --no-sandbox --disable-webgl --blacklist-accelerated-compositing --disable-accelerated-2d-canvas --disable-accelerated-compositing --disable-accelerated-layers --disable-accelerated-video-decode --blacklist-webgl --disable-bundled-ppapi-flash --disable-flash-3d --enable-aggressive-domstorage-flushing --enable-media-stream --allow-file-access-from-files=1 --pack_loading_disabled=1 --device-scale-factor=1 --num-raster-threads=2 --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,3553;0,11,3553;0,12,3553;0,13,3553;0,14,3553;0,15,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,3553;1,11,3553;1,12,3553;1,13,3553;1,14,3553;1,15,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,3553;2,11,3553;2,12,3553;2,13,3553;2,14,3553;2,15,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,3553;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,3553;3,13,3553;3,14,3553;3,15,3553 --disable-webrtc-hw-vp8-encoding --disable-gpu-compositing --service-request-channel-token=F5C53A62102BABC965FB8E684ABAF040 --renderer-client-id=3 --mojo-platform-channel-handle=3268 /prefetch:1
MD5 Hash: 7891EA436E353768BAA279317A597CA1
Bitness: 32-bit
Publisher: AVAST Software
Description: Avast Antivirus
Version: 17.9.3761.0
Integrity Level: Medium
Signer: AVAST Software s.r.o.
System Process: False
Protected Process: False
Metro Process: False
Parent: [624] C:\Program Files\AVAST Software\Avast\AvastUI.exe
Parent CommandLine: AvastUI.exe /nogui

I have an Intel i5 4440 CPU, GeForce GTX 760, Windows 10 Home with Fall Creator's Update and using Avast Free Antivirus.

Latest edit: It happened again, just a few seconds ago, while browsing on Chrome, and the tabs became greyed out, just like it would happen when alt+tabbing to another window. I'm guessing this might be one of their periodical ads, and it gets stuck in a loop because it doesn't show anything. That's probably why this Avast Offer Installation Tool is called every time it happens.
« Last Edit: December 30, 2017, 08:24:19 PM by dangeorgescu88 »

REDACTED

  • Guest
It’s windowed games too. I’ve tried this already. Affects windows and full screen.

I also tried silent mode but not sure if that stops offers from popping up. If you haven’t read through my post.

Thanks for posting it in my thread also to back me up... I’ve read and replied to your post actually thanking you for posting this to the forum. I felt it was just me. It’s a relief really

Offline avragorn

  • Full Member
  • ***
  • Posts: 139
I already posted in a similar other thread ... so I am having the same problem since last tuesday december 26th. I hope it will get fixed very soon :)
Thank you very much :)
My configuration : Windows 7 Premium - INTEL I5 2500K - NVIDIA/MSI GTX 1050 TI 4gb - AVAST FREE EDITION 22.5.6015

Offline demetry842

  • Jr. Member
  • **
  • Posts: 52
Yep... i have a same problem. Well i'm not sure about all detail, but i see a same symptoms.

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9404
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
I think it's plausible actually. I remember avast! team was mentioning pre-loading of interface in the background so it opens up faster when user needs it. Looks like this preloading might be causing this.
Visit my webpage Angry Sheep Blog

REDACTED

  • Guest
I think it's plausible actually. I remember avast! team was mentioning pre-loading of interface in the background so it opens up faster when user needs it. Looks like this preloading might be causing this.

Hmmm it’s possible but only if the pre-loading happens after 30 minutes or so. Pre-loading would imply this is done early in and not 30 minutes in. If you could clarify, that’d be great. If you don’t know much about it then that’s okay.

Offline dangeorgescu88

  • Newbie
  • *
  • Posts: 10
Another user, Tentaurus, says he is popupped on every start to upgrade to the premium version. Might be related to this issue, being a glitch in their ad service.