Author Topic: (Solved) Scan attachments when attaching not work. Add-in disabled in 17.9  (Read 1758 times)

0 Members and 1 Guest are viewing this topic.

Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 371
Since last version of Avast (17.9) scanning attachments when attaching not work. (Tested in Outlook 2010, Win 7 64 bit, Avast Free).

Please check this.

1.Download eicar test file or other file detected by Avast.
2.Open your mail client and attach this file - there should Avast detect (in previous version it works).

It is detected when I hit "Send" button but not when attaching (enabled in mail shield by default).
« Last Edit: February 03, 2018, 09:40:06 AM by TheOwner »

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87286
  • No support PMs thanks
Re: Scan attachments when attaching not work
« Reply #1 on: February 02, 2018, 12:31:56 AM »
The Mail Shield is different to the Avast plug-in/add-in for MS Outlook. 

If you are using MS Outlook then it should use the Avast plug-in/add-in for MS Outlook, so the Mail Shield Settings wouldn't apply.

I don't use MS Outlook so I can't test to see if it has this function.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.12.6044 (build 22.12.7758.768) UI 1.0.741/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 371
Re: Scan attachments when attaching not work
« Reply #2 on: February 02, 2018, 12:42:34 AM »
The Mail Shield is different to the Avast plug-in/add-in for MS Outlook. 

If you are using MS Outlook then it should use the Avast plug-in/add-in for MS Outlook, so the Mail Shield Settings wouldn't apply.

I don't use MS Outlook so I can't test to see if it has this function.
So i am confused, for what is mail shield settings? Mail shied protect mail apllications.

Anyway scanning attachments when attaching is in "Outlook only" settings.
« Last Edit: February 02, 2018, 01:11:30 AM by TheOwner »

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87286
  • No support PMs thanks
Re: Scan attachments when attaching not work
« Reply #3 on: February 02, 2018, 01:26:51 AM »
The Mail Shield is different to the Avast plug-in/add-in for MS Outlook. 

If you are using MS Outlook then it should use the Avast plug-in/add-in for MS Outlook, so the Mail Shield Settings wouldn't apply.

I don't use MS Outlook so I can't test to see if it has this function.
1.  So i am confused, for what is mail shield settings? Mail shied protect mail apllications.

2.  Anyway scanning attachments when attaching is in "Outlook only" settings.

First as I said "I don't use MS Outlook so I can't test" so can't speak from personal experience.

1.  MS Outlook has its own Avast email Add-in, you have MS Outlook 2010, if the Avast MS Outlook Add-in is enabled (?) then it will use that, NOT the Mail Shield.  The Avast Mail Shield covers email clients using regular email (not webmail), the exclusion being MS Outlook which has its own Avast add-in.

2.  Yes it is an MS Outlook only option, but as far as I'm aware that still requires that you have the Avast add-in for MS Outlook enabled.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.12.6044 (build 22.12.7758.768) UI 1.0.741/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 371
Re: Scan attachments when attaching not work
« Reply #4 on: February 02, 2018, 01:55:28 AM »
Ok my addin was disabled, but even that send mail is scanned by Avast and blocked. Avast still protect me if i recieve infected mail? What is purpose of addin?

After I enabled addin, attachments are now detected. But i dont unrestand why was addin disabled? I didnt disable him and previous version was enabled. So strange.
« Last Edit: February 02, 2018, 02:10:11 AM by TheOwner »

Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 371
Re: Scan attachments when attaching not work
« Reply #5 on: February 03, 2018, 01:17:59 AM »
Also there is no way how check if my mail is protected by Avast because if i send eicar file to self is blocked by my mail provider. Do i need export ssl certificate somewhere to Outlook 2010 or it is not needed?

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37134
  • Not a avast user
Re: Scan attachments when attaching not work
« Reply #6 on: February 03, 2018, 01:42:15 AM »
Also there is no way how check if my mail is protected by Avast because if i send eicar file to self is blocked by my mail provider. Do i need export ssl certificate somewhere to Outlook 2010 or it is not needed?
That mean your mail is already protected, all mail providers have virus/spam filter protection on there mail servers protecting all mail accounts


Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 371
Re: Scan attachments when attaching not work
« Reply #7 on: February 03, 2018, 01:59:03 AM »
That is not answer. Nothing is 100% and what server not catch, Avast can. So there will be no reason installing Mail shield if server protect me. What is purpose of mail shied then?
« Last Edit: February 03, 2018, 02:00:41 AM by TheOwner »

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37134
  • Not a avast user
Re: Scan attachments when attaching not work
« Reply #8 on: February 03, 2018, 02:02:40 AM »
You have just as good protection as you would if using webmail


Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37134
  • Not a avast user
Re: Scan attachments when attaching not work
« Reply #9 on: February 03, 2018, 02:27:57 AM »
Since last version of Avast (17.9) scanning attachments when attaching not work. (Tested in Outlook 2010, Win 7 64 bit, Avast Free).

Please check this.

1.Download eicar test file or other file detected by Avast.
2.Open your mail client and attach this file - there should Avast detect (in previous version it works).

It is detected when I hit "Send" button but not when attaching (enabled in mail shield by default).
Are you using eicar.txt ?

If so, try renaming file to eicar.com or eicar.exe and try again

Any change?


Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 371
Re: Scan attachments when attaching not work
« Reply #10 on: February 03, 2018, 02:48:26 AM »
Since last version of Avast (17.9) scanning attachments when attaching not work. (Tested in Outlook 2010, Win 7 64 bit, Avast Free).

Please check this.

1.Download eicar test file or other file detected by Avast.
2.Open your mail client and attach this file - there should Avast detect (in previous version it works).

It is detected when I hit "Send" button but not when attaching (enabled in mail shield by default).
Are you using eicar.txt ?

If so, try renaming file to eicar.com or eicar.exe and try again

Any change?
Please learn read before you answer.
1. Problem solved by enabling add-in. (Avast keep it disabled by default in clean install 17.9).
2. I dont uderstand why u talk about web mail if i am talking whole time about Outlook 2010.
« Last Edit: February 03, 2018, 09:41:27 AM by TheOwner »