Author Topic: Avast and firewall issue  (Read 1991 times)

0 Members and 1 Guest are viewing this topic.

Offline noz

  • Newbie
  • *
  • Posts: 8
  • Dude!
Avast and firewall issue
« on: June 15, 2006, 03:56:12 PM »
Hi all,

I'm working on a security support and since a few days, many users reports us this issue on windows XP:

since avast deleted some trojans, they can't connect to web, firewall can't be activated.
an error about "newdot.dll" which doesn"t exist or an error "no tcp compatible protocol found"
If we try to activate the firewall service, an error 10047 appears.

This issue is resolved by simply doing a "netsh winsock reset", but is it a known bug?

Thank you.
« Last Edit: June 15, 2006, 04:06:27 PM by noz »
Reboot and pray.

Offline XMAS

  • Avast translator
  • Super Poster
  • ***
  • Posts: 1211
  • Santa is watching you ;)
    • avast! in Bulgarian
Re: Avast kills web connection and windows firewall
« Reply #1 on: June 15, 2006, 04:04:15 PM »
Hello and Welcome to the forums :)

I think that this could help you:
http://forum.avast.com/index.php?topic=21608.0 ;)
You've Got To Get Close To The Flame To See What It's Made Of...

Offline noz

  • Newbie
  • *
  • Posts: 8
  • Dude!
Re: Avast and firewall issue
« Reply #2 on: June 15, 2006, 04:08:13 PM »
Thx for the quick answer

I found this topic after posting mine, and you didn't let me enough time to edit my post :D

I'll post questions in the other topic....
Reboot and pray.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11764
    • AVAST Software
Re: Avast and firewall issue
« Reply #3 on: June 15, 2006, 04:10:45 PM »
Well, actually it is a bug.  >:(
When avast! removes an infected file, it also removes the corresponding registry references (at least the main ones) - similarly to what HijackThis does, for example. In this case, however, the removal of the LSP records failed (or rather, only 2 of them were removed, and 2 more were incorrectly left in registry). This causes any subsequent WinSock initialization to fail - thus blocking the network access.

The problem will be fixed in the next program update, of course.

Offline noz

  • Newbie
  • *
  • Posts: 8
  • Dude!
Re: Avast and firewall issue
« Reply #4 on: June 15, 2006, 04:36:14 PM »
Thanks you for the infos

Hopefully it is easy to fix!!
Reboot and pray.