Author Topic: Avast UI Fails after Windows 10 Update (Spring Update) 1803  (Read 56534 times)

0 Members and 1 Guest are viewing this topic.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47249
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #60 on: May 05, 2018, 11:09:17 PM »
I don't speak Russian. Sorry. So the screenshot s don't help me.
Let's hope the give Avast a clue as to your problem.
Here are my choices:
« Last Edit: May 05, 2018, 11:11:27 PM by bob3160 »
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

REDACTED

  • Guest
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #61 on: May 05, 2018, 11:42:24 PM »
I mean Restart

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1885
    • AVAST Software
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #62 on: May 06, 2018, 04:28:36 AM »
Guys,
thanks for reporting this. We are looking into this, currently, our hypothesis is that this is a problem caused by the Windows 10 Spring 2018 update itself, as other applications based on Chromium (AvastUI being one, Slack or Spotify are other examples) and also the Chrome browser itself seem to have issues after the upgrade.

Please see here: https://www.theregister.co.uk/2018/05/04/windows_update_chrome/

Hopefully, MS will release a fix soon (May8), in the meantime we trying to come up with some workaround.

Thanks again,
Lukas.


REDACTED

  • Guest
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #63 on: May 06, 2018, 12:26:46 PM »
Thank you, we will hope and wait!)

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #64 on: May 06, 2018, 07:34:52 PM »
Hello guys,
we have just released uupdate no. 353 which will update AvChrome.dll for users using Win10. It'll add "--disable-direct-composition" UI flag when AvastUI.exe process is launched (it will be present only for users using Spring Update 1803).

Petr

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86803
  • No support PMs thanks
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #65 on: May 06, 2018, 08:04:08 PM »
Hello guys,
we have just released uupdate no. 353 which will update AvChrome.dll for users using Win10. It'll add "--disable-direct-composition" UI flag when AvastUI.exe process is launched (it will be present only for users using Spring Update 1803).

Petr

Petr
Whilst I haven't experienced the Avast UI Fail error - How will this be deployed ?
- micro update as part of VPS,  emergency update or manual program update, etc.
I just tried a manual Avast program update on my win10 system, Windows 10 (Spring Update) 1803 build 17134.1 with avast free 18.3.2333 (build 18.3.3860.316) and reported up to date.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Patrick2

  • Poster
  • *
  • Posts: 489
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #66 on: May 06, 2018, 08:26:15 PM »
Ran Avast EMupdate file, then restarted, so far none of the household PC's using Avast Free have gotten .353 so far,  Behavior Shield won't activate on Laptop Machine now, so attempting Avast clean install, and hopefully works fine after that


Video shared via Onedrive for Behavior Shield Problem


Should I do a Fresh start type reset on that system, then reinstall Avast when that finishes?  wait for a fix from Avast or what

https://1drv.ms/v/s!AmF6yoUM2hihmLNeZiVJnOIk7xyKQg

« Last Edit: May 06, 2018, 08:49:56 PM by Patrick2 »
Windows 10 Pro 64bit 1909 18363.476, Intel I7 7700 Nvidia Geforce 1050 16gb DDR4, WD 250GBSSD, 1tb Storage, Avast Free 19.8.2393
HP Omen Laptop Intel I7 7700HQ, 8gb Of Ram Windows 10 Home x64 1909 18363.476 128GB SSD, 1tb Storage, Avast Free 19.8.2393

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47249
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #67 on: May 06, 2018, 08:53:44 PM »
Ran Avast EMupdate file, then restarted, so far none of the household PC's using Avast Free have gotten .353 so far,  Behavior Shield won't activate on Laptop Machine now, so attempting Avast clean install, and hopefully works fine after that


Video shared via Onedrive for Behavior Shield Problem


Should I do a Fresh start type reset on that system, then reinstall Avast when that finishes?  wait for a fix from Avast or what

https://1drv.ms/v/s!AmF6yoUM2hihmLNeZiVJnOIk7xyKQg
Repair Avast:
Control Panel> Program and Features (Add/remove program)>Select Avast> Select Repair. Reboot when completed
https://www.avast.com/faq.php?article=AVKB204

If Repair doesn't fix the problem, try the following:
Clean Install of Avast:
https://goo.gl/4Ptzkf
If you need additional help with the Clean Install, watch this:
https://youtu.be/p-h3myRD51A
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline Patrick2

  • Poster
  • *
  • Posts: 489
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #68 on: May 06, 2018, 08:54:45 PM »
Did the Repair already/restarted again,  then that didn't work, so removed it completely, and then followed clean install steps, and still does it, any other ideas welcome to hear them lol

This issue happened before, i reported it on forum i believe one other time, then it stopped doing it, well doing it again at least on that one system so far.   Can try Revo Uninstall Portable, and try a clean install again if that is advised to do, already did the standard uninstall, avast clear in safe mode,  restart, reinstall, restart, still didn't work

« Last Edit: May 06, 2018, 08:56:28 PM by Patrick2 »
Windows 10 Pro 64bit 1909 18363.476, Intel I7 7700 Nvidia Geforce 1050 16gb DDR4, WD 250GBSSD, 1tb Storage, Avast Free 19.8.2393
HP Omen Laptop Intel I7 7700HQ, 8gb Of Ram Windows 10 Home x64 1909 18363.476 128GB SSD, 1tb Storage, Avast Free 19.8.2393

REDACTED

  • Guest
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #69 on: May 06, 2018, 09:10:49 PM »
Hello guys,
we have just released uupdate no. 353 which will update AvChrome.dll for users using Win10. It'll add "--disable-direct-composition" UI flag when AvastUI.exe process is launched (it will be present only for users using Spring Update 1803).

Petr
When will this update be available to all users? I still have version 316

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #70 on: May 07, 2018, 03:14:21 AM »
353 is internal number of this uupdate (its number is written in Avast's registry key). You can check if AvChrome.dll.sum file is present in your Avast program folder (it probably means uupdate was delivered on your machine). You can also run AvEmUpdate.exe manually to check for all available uupdates.

REDACTED

  • Guest
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #71 on: May 07, 2018, 09:38:11 AM »
ty for help
« Last Edit: May 07, 2018, 05:28:10 PM by romanavast »

REDACTED

  • Guest
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #72 on: May 07, 2018, 01:15:16 PM »
353 is internal number of this uupdate (its number is written in Avast's registry key). You can check if AvChrome.dll.sum file is present in your Avast program folder (it probably means uupdate was delivered on your machine). You can also run AvEmUpdate.exe manually to check for all available uupdates.
Strangely, this file was present, but the avast after the reboot also crashed with an error. Apparently have to wait for the patch from Microsoft.
« Last Edit: May 07, 2018, 06:24:15 PM by Сергей367 »

Offline hectic-mmv

  • Moderator
  • Sr. Member
  • *
  • Posts: 240
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #73 on: May 07, 2018, 01:25:01 PM »
In general, the same thing, it works before the first reboot, and then the eternal Avast UI Fails, we are waiting for the corrected version for the spring update of Windows ...

During Sunday we released a patch fixing this issue.

If there are other circumstances and UI still fails to load, please could you help us to fix this.

1. Make sure avastui.exe process is running
- open task manager | details | AvastUI.exe - is there avastui.exe between running processes
2. If Avast UI is running, create a dump from it
- open task manager | details | AvastUI.exe | right click AvastUI.exe| create dump file
- wait couple seconds to create a dump file
- If there is multiple instances of AvastUI.exe running, please dump each instance one by one
- zip a dump file and upload it to ftp://ftp.avast.com/incoming or send me a personal message

thank you

REDACTED

  • Guest
Re: Avast UI Fails after Windows 10 Update (Spring Update) 1803
« Reply #74 on: May 07, 2018, 06:51:45 PM »
In general, the same thing, it works before the first reboot, and then the eternal Avast UI Fails, we are waiting for the corrected version for the spring update of Windows ...

During Sunday we released a patch fixing this issue.

If there are other circumstances and UI still fails to load, please could you help us to fix this.

1. Make sure avastui.exe process is running
- open task manager | details | AvastUI.exe - is there avastui.exe between running processes
2. If Avast UI is running, create a dump from it
- open task manager | details | AvastUI.exe | right click AvastUI.exe| create dump file
- wait couple seconds to create a dump file
- If there is multiple instances of AvastUI.exe running, please dump each instance one by one
- zip a dump file and upload it to ftp://ftp.avast.com/incoming or send me a personal message

thank you
I sent the dumps to you in pm