Author Topic: After repairing MacOS High Sierra, Avast File, Web & Mail Shields won't activate  (Read 174 times)

0 Members and 1 Guest are viewing this topic.

Offline TailEndCharlie27

  • Newbie
  • *
  • Posts: 2
As the title states, i just reinstalled the macOS following advice from Apple as i was having issues with my mac shutting down.

Upon this completing the only issue i'm having now is Avasts shields won't activate. The program itself runs fine and i can run scans etc.

I've uninstalled Avast twice and reinstalled but i'm still facing the same problem.
« Last Edit: May 16, 2018, 06:50:40 PM by TailEndCharlie27 »

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 747
  • Product manager of Mac AV and Cleanup
TailEndCharlie27, would you mind to send us Support package? https://support.avast.com/en-ww/article/Submit-Mac-Security-support-file
Quality is also a feature.

Offline TailEndCharlie27

  • Newbie
  • *
  • Posts: 2
No problem, i'll generate it now

Offline ondrej.kolacek

  • Avast team
  • Jr. Member
  • *
  • Posts: 54
Hello,

I have checked the support package and it seems that we are constantly failing to read status of our drivers. Please could you run the following 4 commands:

sudo /Library/Application\ Support/Avast/hub/modules/014_fileshield.sh check

sudo launchctl list | grep com.avast

kextstat | grep com.avast

sudo kextutil /Library/Application\ Support/Avast/components/fileshield/signed/AvastFileShield.kext; echo result$?

in terminal and send the output to ondrej.kolacek at avast.com ?

Kind regards
Ondrej Kolacek
« Last Edit: May 17, 2018, 03:55:20 PM by ondrej.kolacek »