Author Topic: Behavior Shield keeps turning off on startup  (Read 21575 times)

0 Members and 1 Guest are viewing this topic.

Offline terreaultguy

  • Newbie
  • *
  • Posts: 1
Re: Behavior Shield keeps turning off on startup
« Reply #45 on: December 24, 2018, 05:20:40 AM »
same problem, I have version 18.8.2356 (build 18.8.4084.4090)

Offline loungehake

  • Dummy Half
  • Full Member
  • ***
  • Posts: 155
  • Come on lad! You've only got 70 yards to go.
Re: Behavior Shield keeps turning off on startup
« Reply #46 on: January 03, 2019, 11:26:14 AM »
The issue of Behaviour Shield being an uncertain starter has existed as long as has Behaviour Shield. Since Avast know what shields are required by the user to run and what shields are actually running, why is there no mechanism to check on this and to automatically restart or start any shields which should be running but are detected not to be?

I guess that this must only require a fairly trivial bit of programming compared with the really awesome stuff inside Avast. It would better ensure protection if it could be ensured that shields are actually running. One shield not running is one shield providing less protection and Behaviour Shield does protect against zero-day hazards.  Behaviour Shield must have been a reason (among others) why Avast acquired AVG.

The yellow alert flag (with an exclamation mark?) on the Avast icon in the system tray is not the most conspicuous thing on the screen so it is easily missed and all the while Behaviour Shield is not protecting.
« Last Edit: January 03, 2019, 06:00:44 PM by loungehake »
Windows XP Pro SP3, Avast Free 10.4.2233, Outpost Firewall Pro 9.3, Malwarebytes Anti-Exploit, CryptoPrevent, OSArmor, Comodo Memory Firewall.
Windows 7 Ultimate 64bit, Avast Free 19.8.2393,  Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware, OSArmor.
Windows 10 Pro 1909 64bit, Avast Free 19.8.2393, Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware,  OSArmor.
Windows 10 Pro 1909 64bit, Avast Free 19.8.2393, Malwarebytes Premium, OSArmor.

Offline loungehake

  • Dummy Half
  • Full Member
  • ***
  • Posts: 155
  • Come on lad! You've only got 70 yards to go.
Re: Behavior Shield keeps turning off on startup
« Reply #47 on: January 04, 2019, 02:50:47 PM »
I have a hunch that Avast 19.1.2360 has cured this issue. The simplication of ceasing support of XP and Vista might be relevant?
Windows XP Pro SP3, Avast Free 10.4.2233, Outpost Firewall Pro 9.3, Malwarebytes Anti-Exploit, CryptoPrevent, OSArmor, Comodo Memory Firewall.
Windows 7 Ultimate 64bit, Avast Free 19.8.2393,  Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware, OSArmor.
Windows 10 Pro 1909 64bit, Avast Free 19.8.2393, Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware,  OSArmor.
Windows 10 Pro 1909 64bit, Avast Free 19.8.2393, Malwarebytes Premium, OSArmor.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 41903
  • 59 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Behavior Shield keeps turning off on startup
« Reply #48 on: January 04, 2019, 02:54:47 PM »
I have a hunch that Avast 19.1.2360 has cured this issue. The simplication of ceasing support of XP and Vista might be relevant?
A problem I have not experienced on Windows 10 in many, many months.
Free avast! Security Seminar: https://goo.gl/kh3cqR  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1903 64bit, 8 Gig Ram, AvastFree 19.6.xxxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline rocksteady

  • Sr. Member
  • ****
  • Posts: 385
Re: Behavior Shield keeps turning off on startup
« Reply #49 on: January 04, 2019, 04:11:53 PM »
I have not had this problem recently on either XPSP3 or Win10, both running 18.8.2356.
I realise v19 has been released today and that update will not apply to XP or Vista.
Ed

Offline loungehake

  • Dummy Half
  • Full Member
  • ***
  • Posts: 155
  • Come on lad! You've only got 70 yards to go.
Re: Behavior Shield keeps turning off on startup
« Reply #50 on: January 04, 2019, 11:23:32 PM »
bob3160, my hardware is almost pre-historic.  The new Avast 19 has made a huge difference to its responsiveness.  Avast is now without peer in the anti-malware field as far as I am concerned.

If it can make an ancient AMD Sempron 3000+ single core 1.8Gz powered Windows 7 (x64) system actually sprightly, it must be good.  I do like a gentler pace of web page loading.  It gives me time to think.
Windows XP Pro SP3, Avast Free 10.4.2233, Outpost Firewall Pro 9.3, Malwarebytes Anti-Exploit, CryptoPrevent, OSArmor, Comodo Memory Firewall.
Windows 7 Ultimate 64bit, Avast Free 19.8.2393,  Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware, OSArmor.
Windows 10 Pro 1909 64bit, Avast Free 19.8.2393, Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware,  OSArmor.
Windows 10 Pro 1909 64bit, Avast Free 19.8.2393, Malwarebytes Premium, OSArmor.