Author Topic: Reporting a minor bug with firefox, broken SSL connexions  (Read 6918 times)

0 Members and 1 Guest are viewing this topic.

Offline boombastik

  • Full Member
  • ***
  • Posts: 105
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #15 on: June 27, 2018, 10:28:19 AM »
Updated Firefox to version 61.0, no issues.

I gave links that have the problem do u tried them?

Offline Rowan Boatman

  • Jr. Member
  • **
  • Posts: 20
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #16 on: June 27, 2018, 12:38:35 PM »
I see here...
https://bugzilla.mozilla.org/show_bug.cgi?id=1468892#c31
There is someone claiming to be from Avast advising of a potential fix in a couple days time after testing.

If this is so we should be sweet :)

As a quick side note...interestingly, my mates machine which is basically identical to mine has no issue at all, I wonder why this is :o

Offline alanb

  • Poster
  • *
  • Posts: 558
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #17 on: June 27, 2018, 02:17:10 PM »
As a workaround in the interim, in about:config, set security.tls.version.max to 3.

Offline The Sniggler

  • Full Member
  • ***
  • Posts: 120
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #18 on: June 27, 2018, 02:57:59 PM »
Updated to Firefox 61 today, cannot usually get onto Google. When I can access Google, long delay in loading.
Sometimes, when clicking on a bookmarked site, I see that Firefox waits for Google?? and then no connection!
No problems in earlier versions of Firefox.
FYI
« Last Edit: June 27, 2018, 03:13:20 PM by The Sniggler »

Offline The Sniggler

  • Full Member
  • ***
  • Posts: 120
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #19 on: June 27, 2018, 03:54:36 PM »
As a workaround in the interim, in about:config, set security.tls.version.max to 3.

Works so far.. thanks!

Offline vianello_85

  • from Italy
  • Full Member
  • ***
  • Posts: 115
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #20 on: June 28, 2018, 08:52:15 AM »
I hope to release the fix as soon as possible, also considering what has been written before (1 or 2 days).
It would be interesting to know if this fix will be avast side, invisible to the end user, or it will be necessary to update the current version?

I am aware of the workaround, but with all the tests done, still find the word connection failed on sites (still few but very used) that use tls 1.3, the currently most secure version, and having to update the page every time until it detects tls 1.2 is not pleasant.

Offline The Sniggler

  • Full Member
  • ***
  • Posts: 120
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #21 on: June 28, 2018, 01:41:28 PM »
I hope to release the fix as soon as possible, also considering what has been written before (1 or 2 days). It would be interesting to know if this fix will be avast side, invisible to the end user, or it will be necessary to update the current version? I am aware of the workaround, but with all the tests done, still find the word connection failed on sites (still few but very used) that use tls 1.3, the currently most secure version, and having to update the page every time until it detects tls 1.2 is not pleasant.

Thanks for update. I used the fix on one machine so I can access Google, but left the other machine alone to monitor the status.

Offline suk

  • Avast team
  • Jr. Member
  • *
  • Posts: 30

Offline vianello_85

  • from Italy
  • Full Member
  • ***
  • Posts: 115
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #23 on: June 28, 2018, 06:49:27 PM »
I confirm, problem solved, support tls 1.3, there is no more error

Offline The Sniggler

  • Full Member
  • ***
  • Posts: 120
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #24 on: June 28, 2018, 07:57:15 PM »
I confirm, problem solved, support tls 1.3, there is no more error
Fixed here, too.

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5420
  • Spartan Warrior
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #25 on: June 28, 2018, 09:11:01 PM »
@ boombastik,

No, sorry no issues.  I did miss the two sites you posted tho and did not test them.
Windows 10 Home 64-bit 20H2 Avast Premier Security version 21.3.2459 (build 21.3.6164.652) UI version 1.0.612.

Offline Martin00

  • Jr. Member
  • **
  • Posts: 85
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #26 on: June 28, 2018, 10:40:42 PM »
Any idea when that will be fixed?

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #27 on: June 28, 2018, 11:09:34 PM »
Virus Definitions 180628-8 fixes the TLS 1.3 issue.  You should have it by now.
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

Offline Rowan Boatman

  • Jr. Member
  • **
  • Posts: 20
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #28 on: June 28, 2018, 11:13:54 PM »
Just test my machine and it now appears to be fixed, thank you very much :)

Offline Sab'

  • Newbie
  • *
  • Posts: 5
Re: Reporting a minor bug with firefox, broken SSL connexions
« Reply #29 on: June 30, 2018, 05:26:49 PM »
Ah, bummer, in the meantime I gave up (too many ssl breakages per day) and uninstalled Avast, switching to Windows Defender.