Author Topic: Messages Application on Mac  (Read 2665 times)

0 Members and 1 Guest are viewing this topic.

Offline F0urq

  • Newbie
  • *
  • Posts: 6
Messages Application on Mac
« on: July 04, 2018, 06:25:26 AM »
I sent this report in via email as well, but I will copy+paste the email I sent into this thread also:

Hello Avast Team,

I am a fellow IT Helpdesk Technician here with a bug to report to you guys regarding Avast Free Edition on Macintosh Systems. On my own personal computer, Avast at certain times will block the Message app from communicating with Apple Servers for authentication, thus not allowing the user to send/receive texts through Messages and presenting me with an “authentication failure” message. This issue has been replicated on several different Mac computers and will happen at random times.

The workaround currently for this issue is to disable all of the Avast shields, and log back in to the Messages App with your iCloud account which will then fix the issue in the Messages App. Once that is done, you can re-enable the shields on Avast until the problem presents itself again.

Somehow and sometimes the Avast shields are blocking communication between the Messages Application and Apple’s authentication servers for iCloud.

Please take a look at this bug and see what you can do.

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 267
Re: Messages Application on Mac
« Reply #1 on: July 04, 2018, 11:03:49 AM »
Hello,

thanks for reporting this issue. By default we only intercept HTTPS connections originating from browsers, so it is weird that this is happening.

-please check in GUI, Preferences, Shields, Settings in WebShield section, Scan secured connections from browsers only. Do you have the the option selected? Unselecting it breaks stuff; we will be getting rid of this option in the near future
-Have you tested that it is not enough to turn off web shield and you need to turn off all shields, or you are doing it "just in case"?
-Please could you send a support package (Help->Avast Technical Support -> Generate support package, note there that it is from you) after the issue happens?
-If you go to Messages' Preferences, Accounts, select your account with Apple ID, sign out, and log in to the account again, does it work correctly with Avast active?

We will try to reproduce this here, but if it fails, any information helps.

Kind regards,
Ondrej Kolacek
« Last Edit: July 04, 2018, 12:21:10 PM by ondrej.kolacek »

Offline F0urq

  • Newbie
  • *
  • Posts: 6
Re: Messages Application on Mac
« Reply #2 on: July 06, 2018, 02:08:23 AM »
Hello ondrej.kolacek,

Thanks for the reply! Here are some answers to your questions

1. The option for "Scan secured connections from browsers only" was not checked, only the "Scan secured connections" was. I have since checked both now. What exactly does this option do?
2. When fixing the problem, I have disabled all shields in order to rectify the issue. I have not tried disabling one shield at a time.
3. Since I have just replicated the issue, I have submitted a support package
4. This step where you had me sign out of my account on Messages replicated the issue. Once signed out, I am unable to sign back in to iMessage. After I received this error, I disabled all shields on Avast and was still unable to sign back in. Thus with all shields still disabled, I restarted my system and then after i launched messages again was I able to re-login. Once done, I re-enabled the shields in Avast.

Attached is a photo of the error message that comes up in Messages


Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 267
Re: Messages Application on Mac
« Reply #3 on: July 10, 2018, 09:26:58 AM »
Hello,

the problem will most likely be the unchecked option. The checkbox probably should not have been introduced at all and in our new not so soon to be released gui we have gotten rid of it. Basically many applications can not cope with us intercepting https traffic; because of that we have switched to default of intercepting https only originating from web browsers quite a long time ago. But to keep the legacy behavior, the checkbox has been introduced that time. Unfortunately over the time using the checkbox started to be worse and worse idea. We will get rid of the checkbox in next release which will be released quite soon, as a priority.

Thanks for informing us about the issue.

Kind regards,
Ondrej Kolacek
« Last Edit: July 10, 2018, 11:30:39 AM by ondrej.kolacek »

Offline F0urq

  • Newbie
  • *
  • Posts: 6
Re: Messages Application on Mac
« Reply #4 on: July 12, 2018, 03:37:17 AM »
Hello,

the problem will most likely be the unchecked option. The checkbox probably should not have been introduced at all and in our new not so soon to be released gui we have gotten rid of it. Basically many applications can not cope with us intercepting https traffic; because of that we have switched to default of intercepting https only originating from web browsers quite a long time ago. But to keep the legacy behavior, the checkbox has been introduced that time. Unfortunately over the time using the checkbox started to be worse and worse idea. We will get rid of the checkbox in next release which will be released quite soon, as a priority.

Thanks for informing us about the issue.

Kind regards,
Ondrej Kolacek

I actually attempted to see if the problem would still exist after unchecking both boxes and then re-checking both boxes. In both instances, the problem was still there hence I dont think they are related to the problem thats happening.

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 267
Re: Messages Application on Mac
« Reply #5 on: July 12, 2018, 12:13:53 PM »
The whole problem is weird. Every time “Next” button in Messages’s Preferences->Accounts/Enter apple id is pressed, https request to server gsa.apple.com is triggered by /System/Library/PrivateFrameworks/AuthKit.framework/Versions/A/Support/akd (at least for me on High Sierra). In case the “Scan secured connections from browsers only” is unchecked, this connection is intercepted and I get this authentication error (the app probably has additional requirements on the certificate than the fact that it verifies against system keychain; this is typical and a reason why the checkbox breaks stuff). But it does not cache anything, so ticking the checkbox or disabling web shield should cause next connect to succeed. From the support package I see that you have tried to change stuff before restarting, so I have no idea what could be wrong.

Please when the issue occurs again, go to terminal and run this command:

log stream --level debug >~/Documents/avast.log

the command will block. After that click on the Next in the Accounts to trigger login attempt; when it fails with authentication error, select the terminal window and press ctrl + c to terminate the log command. In file avast.log in your Documents folder, there should be some relevant information (eg. "Messages: (AuthKit) [com.apple.authkit:core] Remote authentication service returned an error:" ). Please mail me the log file to ondrej.kolacek at avast.com . Maybe there will be something worthwhile in the logs.

Offline F0urq

  • Newbie
  • *
  • Posts: 6
Re: Messages Application on Mac
« Reply #6 on: July 12, 2018, 02:51:53 PM »
The whole problem is weird. Every time “Next” button in Messages’s Preferences->Accounts/Enter apple id is pressed, https request to server gsa.apple.com is triggered by /System/Library/PrivateFrameworks/AuthKit.framework/Versions/A/Support/akd (at least for me on High Sierra). In case the “Scan secured connections from browsers only” is unchecked, this connection is intercepted and I get this authentication error (the app probably has additional requirements on the certificate than the fact that it verifies against system keychain; this is typical and a reason why the checkbox breaks stuff). But it does not cache anything, so ticking the checkbox or disabling web shield should cause next connect to succeed. From the support package I see that you have tried to change stuff before restarting, so I have no idea what could be wrong.

Please when the issue occurs again, go to terminal and run this command:

log stream --level debug >~/Documents/avast.log

the command will block. After that click on the Next in the Accounts to trigger login attempt; when it fails with authentication error, select the terminal window and press ctrl + c to terminate the log command. In file avast.log in your Documents folder, there should be some relevant information (eg. "Messages: (AuthKit) [com.apple.authkit:core] Remote authentication service returned an error:" ). Please mail me the log file to ondrej.kolacek at avast.com . Maybe there will be something worthwhile in the logs.

I must've jumped the gun too soon because I did find the workaround for now. Unchecking both options (Scan secured connections/Scan secured connections from browsers only) seemed to do the trick. I was able to login to Messages just fine after both of those options were unchecked. In the future, if you are able to elaborate on this, what are those 2 buttons being replaced with (if anything)?

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 267
Re: Messages Application on Mac
« Reply #7 on: July 16, 2018, 09:50:42 AM »
There will only be a checkbox which enables/disables https scanning, but the scanning will only ever be done for browsers.

Offline F0urq

  • Newbie
  • *
  • Posts: 6
Re: Messages Application on Mac
« Reply #8 on: July 26, 2018, 05:48:21 AM »
I sent this report in via email as well, but I will copy+paste the email I sent into this thread also:

Hello Avast Team,

I am a fellow IT Helpdesk Technician here with a bug to report to you guys regarding Avast Free Edition on Macintosh Systems. On my own personal computer, Avast at certain times will block the Message app from communicating with Apple Servers for authentication, thus not allowing the user to send/receive texts through Messages and presenting me with an “authentication failure” message. This issue has been replicated on several different Mac computers and will happen at random times.

The workaround currently for this issue is to disable all of the Avast shields, and log back in to the Messages App with your iCloud account which will then fix the issue in the Messages App. Once that is done, you can re-enable the shields on Avast until the problem presents itself again.

Somehow and sometimes the Avast shields are blocking communication between the Messages Application and Apple’s authentication servers for iCloud.

Please take a look at this bug and see what you can do.

With that checkbox being added, will the issue with messages not being able to communicate to apple servers be rectified?

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 267
Re: Messages Application on Mac
« Reply #9 on: July 27, 2018, 09:36:08 AM »
Hello,

I am sorry, I have misunderstood. I thought that with both checkboxed selected, the issue was fixed for you. With both unchecked no scanning of https traffic takes place, so while we now know that https traffic is an issue, disabling scanning of it makes web shield useless.

Please could you capture and send me logs as described in my July 12 post? For us, Messages work without issues, so I can not do anything without more information.

Kind regards,
Ondrej Kolacek


Offline .: Mac :.

  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5080
Re: Messages Application on Mac
« Reply #10 on: July 31, 2018, 11:45:34 AM »
Confirmed that messages works here on High Sierra with both boxes checked for HTTPS scanning
"People who are really serious about software should make their own hardware." - Alan Kay