Author Topic: Avast silently blocking Cloudflare.com  (Read 1953 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Avast silently blocking Cloudflare.com
« on: July 30, 2018, 09:09:40 AM »
We have been using Avast for Mac for several months, maybe more than a year without issues.

A couple of days ago Cloudflare.com stopped working in any browser on our Macs and simply says the connection was closed. No indication that Avast blocked it. Zero. Zilch. No indication whatsoever.

Smartphones without Avast access the site from the same network without issue.

Out of a multi-day troubleshooting frustration and perseverance to try every possible solution we added cloudflare.com to the Avast Webshield exclusion list and the site starts working again. What the frick?

I'm supremely disappointed that any site blocked by Avast does not say it was blocked by Avast. Three days of no desktop access and frustrating workarounds.

One more incident like this and I'm ditching Avast for Mac. 

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 394
Re: Avast silently blocking Cloudflare.com
« Reply #1 on: July 31, 2018, 10:52:22 AM »
Hello,
It is likely that web shield was not able to connect to the cloudfare server at all or there was an error establishing secure connection; in these cases we have no way how to signal the issue to the browser. These errors should be logged by Avast into syslog. Could you please send us support package (when Avast GUI is active, from menu Help -> Avast Technical Support -> Generate Support Package), ideally just after this error triggers? We will check the logs and try to find out why it does this while the servers are evidently working.
Kind regards,
Ondrej Kolacek