Author Topic: AVG/Avast Services are not running  (Read 1220 times)

0 Members and 1 Guest are viewing this topic.

Offline kedster

  • Newbie
  • *
  • Posts: 1
AVG/Avast Services are not running
« on: August 21, 2018, 08:08:36 PM »
So this will be lengthy and I can't guarantee i am going to say this in the best way bare with me English is my first language. skip to the bottom to avoid the rant

So First off can someone explain why when I do an install of avast as an update. instead of a new application, I get a Frankenstein app that barely functions?

I have services from avg and Avast running on the same machine. it's like someone is using the old engine from the go-cart in a new $30,000 sedan just to say they have a sedan. Seriously when I install a security product I expect it to be all there branded the same with new services named correctly and old services should be removed not reused.

Next, I ask why can I uninstall and instal avg/avast app at the same time or 2 installs on the same pc at the same time?

Basic programming in windows won't let you install 2 things at the same time. Cant, you just reference the PID from the running version of AVG/avast and then make it stop if it's running.

After that, I'm wondering why you have 3 separate branded AVG /avast removers and none of them work?

I have tried tirelessly to remove reg keys, services, and its even still sitting in the program apps location like it didn't even try. Yes, I have tried UAC, no UAC, local admin, procmon,  and none of them tell me what your "remover apps" are doing or remove anything that causes problems. I can run all 3 and still pop hot for an install on the 5th reboot. smh I digress

SO I went on a fact-finding mission and I found that several avg services were running when we updated all the systems to Avast. So I disable them and now every computer in our domain can access the internet unless I uninstall and reinstall the application. Sometimes I can do an internet connection enable/disable/reset and that will work but that's like 1 in 10. So I am now faced with the question 1) how do I really remove it and 2) Am I missing a fix (I've searched online)  to "avg /avast services not running"?