Author Topic: avast free failure to launch  (Read 5516 times)

0 Members and 1 Guest are viewing this topic.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 36730
Re: avast free failure to launch
« Reply #15 on: September 23, 2018, 10:28:51 PM »
Quote
  Im tired   
Follow @Asyns suggestion or find a AV that work ...


Offline avastUI bug

  • Newbie
  • *
  • Posts: 13
Re: avast free failure to launch
« Reply #16 on: September 25, 2018, 11:57:17 AM »
unlike the OP, i'm on xp sp2 [not sp3] and hence avast 10 [not 18] but having similar issues since rebooting after an update which may have been installed weeks ago since i use standby.
this seems wide spread, so i joined just to share my fix [took me days] which should work on
xp sp3/v18 too.

need [A or B]:
A] old avast offline installer
 or
B] use system restore/recovery image backup to extract old avastUI.exe before this update bug occurred [why it even gets updated on just a database update with no program update is beyond me]

steps for A]
1.install old avast version
2.backup avastUI.exe from programs folder [incase it gets updated in step 5-6]
3.do a manual database update or download/install it from:
https://www.avast.com/en-au/download-update
[untill this is fixed, steps 2-6 is how you will update from now on]
4.also turn auto updates OFF or it will freeze again after update/reboot!!!
5.reboot to safemode [to stop avastUI.exe from being updated]
6.reboot in normal mode: sweet - it works again! -if not go to steps 1-2 below.

steps for B]
1.extract old avastUI.exe from programs folder [compare version number to updated one]
2.reboot to safemode and overwrite newer avastUI.exe in programs folder with the old extracted one
3. do steps 4 & 6 above
4. for future updates, do steps 2-6 above
5. ....um, that's it i think? if any of this stuffs your pc it's not my fault!   ???:o ::) :P 8)







« Last Edit: September 26, 2018, 05:48:24 AM by avastUI bug »

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 43901
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: avast free failure to launch
« Reply #17 on: September 25, 2018, 06:39:51 PM »
@avastui bug.
Without a link to that older version, your help isn't much good.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.3.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline avastUI bug

  • Newbie
  • *
  • Posts: 13
Re: avast free failure to launch
« Reply #18 on: September 26, 2018, 05:43:50 AM »
avast does not store old versions publicly that i know of, any link would be unofficial and possibly insecure, it's the users responsibility to make archives of software they use in case things like this ever happen, if not, an old pc magazine dvd from a library might be another option.

...besides, option B does not even require the older installer   :P
« Last Edit: September 26, 2018, 09:18:11 AM by avastUI bug »

Offline avastUI bug

  • Newbie
  • *
  • Posts: 13
Re: avast free failure to launch
« Reply #19 on: September 28, 2018, 06:12:03 AM »
...just a heads up for anyone trying my fix above, you also need to block 'AvastEmUpdate.exe' in your firewall or it will still update a few days later even with auto updates off!
« Last Edit: September 28, 2018, 06:40:00 AM by avastUI bug »

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: avast free failure to launch
« Reply #20 on: September 28, 2018, 07:06:15 AM »
Note:  Blocking AvastEmUpdate.exe is not recommended as it is needed to fix issues with an avast installation behind the scenes.
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline avastUI bug

  • Newbie
  • *
  • Posts: 13
Re: avast free failure to launch
« Reply #21 on: September 28, 2018, 02:20:25 PM »
fix issues? in this case it CAUSES the issues, all it does obviously is download/install updates, which can be done manually when needed as i described.

also note this thread is about win XP, other versions may not have the issue.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83558
  • No support PMs thanks
Re: avast free failure to launch
« Reply #22 on: September 28, 2018, 04:28:39 PM »
fix issues? in this case it CAUSES the issues, all it does obviously is download/install updates, which can be done manually when needed as i described.

also note this thread is about win XP, other versions may not have the issue.

It (AvEmUpdate.exe) isn't causing any issues on this XP Pro SP3 system with the latest avast avast free version, see attached image.

I also have Program Updates set to Manual and the AvEmUpdate.exe is still enabled, it has never automatically done a program update.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.544/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: avast free failure to launch
« Reply #23 on: September 28, 2018, 08:13:43 PM »
One use for AvastEmUpdate is to fix a false positive detection causing many systems (home/business) to crash, with blue/screens, which does happen but rarely.   ::)

IMO turning off AvastEmUpdate is not something one should do.
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6461
  • When you think you know, Think Again
Re: avast free failure to launch
« Reply #24 on: September 28, 2018, 09:03:55 PM »
When running an Old XP with SP2 it will be increasingly difficult to secure the system effectively with many Security Programs.
***HP ENVY 15K LT W10 Pro 2004 64Bit/750GB HD/16GB Ram/Avast Premium 20.7.2421b/Secureline v.5.6.4982/ADU v.20.1b/VS 5.77/ASB v.84b/SANDBOXIE/Prey Project
**HP Compaq 8510p LT W10 Pro 2004 64Bit/1TB HD/8GB Ram/Avast Premium 20.7.2421b/ADU v.20.1b/ASB v.84b/SANDBOXIE/Prey Project/HotSpot Shield vpn
     
*Dell Inspiron XPsp4 PRO 32Bit/Avast(since 2002)18.8.2356/WP/Comodo FW 3.14/Secureline/Comodo IceDragon v.40
LAYERED SECURITY SOFTWARE PROTECTION

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 43901
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: avast free failure to launch
« Reply #25 on: September 28, 2018, 11:27:22 PM »
...just a heads up for anyone trying my fix above, you also need to block 'AvastEmUpdate.exe' in your firewall or it will still update a few days later even with auto updates off!
It's nice to offer help but, that help needs to actually be complete.
Suggesting the disabling of functions that need to be there isn't helping anyone.
Asking people to download older versions without supplying a safe link also isn't helpful.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.3.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline avastUI bug

  • Newbie
  • *
  • Posts: 13
Re: avast free failure to launch
« Reply #26 on: September 29, 2018, 07:21:34 AM »
I also have Program Updates set to Manual and the AvEmUpdate.exe is still enabled, it has never automatically done a program update.
if you read my post, avastUI.exe bug is not caused by program updates, but by database updates - strange huh?

1] It's nice to offer help but, that help needs to actually be complete.
2] Suggesting the disabling of functions that need to be there isn't helping anyone.
3] Asking people to download older versions without supplying a safe link also isn't helpful.
1] it's the only viable [and working] solution so far, so unless you or avast have a better one your comments are even less helpful.  :-X

2] the function is invalid if manual updates and maintenance are performed [such as when avast gets compromised by an attack]

3] i never once asked people to 'download older versions' as anyone still using XP should be keeping copies of old software that gets discontinued and unavailable frequently, those who don't should chuck their XP pc and buy win10 like everyone else who can't maintain old OS's confidently.
« Last Edit: September 29, 2018, 09:00:50 AM by avastUI bug »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83558
  • No support PMs thanks
Re: avast free failure to launch
« Reply #27 on: September 29, 2018, 10:10:54 AM »
I also have Program Updates set to Manual and the AvEmUpdate.exe is still enabled, it has never automatically done a program update.
if you read my post, avastUI.exe bug is not caused by program updates, but by database updates - strange huh?

<snip quote>
I did, I also read your other posts that imply a problem with AvEmUpdate.exe.

I'm reporting the condition and settings on my XP system and the fact that I haven't experienced the problem.  The major difference that I'm not using XP SP2 but SP3, Avast should detect that and not update the program to a version that requires XP SP3.  Why you haven't updated your OS to SP3 is the question.
« Last Edit: September 29, 2018, 10:14:45 AM by DavidR »
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.544/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline avastUI bug

  • Newbie
  • *
  • Posts: 13
Re: avast free failure to launch
« Reply #28 on: September 29, 2018, 10:43:42 AM »
sp3 slows my system if it's an upgrade install, a fresh sp3 slipstream install is not viable to me yet.

the OP also has sp3 and the same problems, so why him and not you? maybe he did an upgrade install so still has legacy sp2 files, or maybe as we use xp home while you have pro?
« Last Edit: September 29, 2018, 10:49:55 AM by avastUI bug »

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 43901
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: avast free failure to launch
« Reply #29 on: September 29, 2018, 04:22:21 PM »
@avastUI bug - this topic might be of help to you. :)
https://forum.avast.com/index.php?topic=164936.msg1322691#msg1322691
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.3.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq