Author Topic: Avast 4.7 problems [Win2K/NT4 access rights issue]  (Read 14737 times)

0 Members and 1 Guest are viewing this topic.

solstone

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #30 on: April 25, 2006, 07:35:55 PM »
Hi Forejt.  Ok, so I uninstalled my manually modified version of 4.7 (I had thought about reverting to 4.6 before, but hadn't gotten to it) and installed from the fix that you link to.  Installed fine on first try, although with the same permissions (set to Everyone - Full Control) as 4.6 had by default (at least on my machine). 

I went through and checked a number of other programs in my Program Files folder, and they all seem to be set to Administrators & SYSTEM - Full Control, with no mention of the 'Everyone' group, which is how the Program Files folder itself is defined.  Is Avast supposed to inherit the same permissions as 'Program Files'?

In any case, it is working on it's own now. 

Thanks for all the help, and the great software!
Sol

ps- Vlk, I am in Portland, and we are back to the cloudy skies it seems... (I will go and add a pin to the member map now.)  :)


Forejt

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #31 on: April 25, 2006, 07:57:59 PM »
Did you update on NT4 or Win2K? On Win2K all folders except 'DATA' should have Everyone access removed. If it stays set, send me file setup.log from avast4\setup folder.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11657
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #32 on: April 26, 2006, 08:35:35 PM »
solstone, this might also be relevant: http://forum.avast.com/index.php?topic=20819.0
This version should work OK.

BTW I'm going to Portland on Saturday. I hope the weather will be fine again ;)
If at first you don't succeed, then skydiving's not for you.

CharleyO

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #33 on: April 27, 2006, 01:30:34 AM »
***

Portland has fine weather?    :o    ;D


***

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11657
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #34 on: April 27, 2006, 02:54:44 AM »
Actually last weekend was sunny with highs well above 70 degrees. Yummy!
If at first you don't succeed, then skydiving's not for you.

Guepi

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #35 on: July 15, 2006, 01:48:47 AM »
Hi !

I've installed a fresh Win2k system (SP4). I've create 2 account : one administrator and one power user (for security reason : a power user for every thing I do, and an administrator for install).

I've installed avast 4 Home (free) edition when logged as administrator : it was ok.
I've rebooted and relogged as administrator : it was ok.
I've logged off and logged on power user account : I get an error message, during startup, with "ashDisp.exe"

(it a french error message, so I translate it !)

Quote
Application doesn't initialize correctly (0xc0000022). Click OK to stop application.

So I uninstalled Avast, and reinstalled it when logged on power user account, and the command "run as..."
When I restart computer, I've got the same message.

process that runs :
  • ashMaiSv.exe
  • ashServ.exe
  • ashWebSv.exe
  • aswUpdSv.exe

Services :
  • avast! Antivirus => automatic and running
  • avast! iAVS4 Control Service => automatic and running
  • avast! Mail Scanner => manual and running
  • avast! Web Scanner => manual and running

I think that full control is not necessary for ashDisp program, and I may be a security hole in the system, since a process can copy itself in the antivirus program.