Author Topic: Your connection is not secure...still!  (Read 6244 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
Your connection is not secure...still!
« on: October 11, 2018, 06:59:17 PM »
I'm running the free version of 13.11
MacOS 10.13.6 (High Sierra)
Firefox 62.0.3

I continue to get the security message as follows (see attached screen shot a101.png)

This is Mozilla, so I quite doubt their certificate is insecure. I've also gotten it on and other secure sites when using FireFox

I have followed the Firefox suggestions on how to remedy this, but as I am using the free version, I do not have the "menu" option. I'm unable to find any other option inside of avast to fix this (a103)

[b]Your connection is not secure

The owner of has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Learn more…

Report errors like this to help Mozilla identify and block malicious sites uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown.
The server might not be sending the appropriate intermediate certificates.
An additional root certificate may need to be imported.


I have uninstalled and reinstalled Avast several times.
I have also uninstalled and reinstalled Firefox
I even switched over to McAfee after uninstalling Avast and whatever Avast left behind is still in there and generating the same error message.

At one point I did have the Avast Browser Security add-on, but it has since been disabled (a102.png)I do not get this message in either Chrome or Safari.

I don't want to give up Firefox, since all my user id's and passwords are saved (with no way to export them beyond screen shots)

I'd rather give up Avast than Firefox, but right now all I want is to get this Avast bug out of my Mac

Is there a console command that I can use to dig the roots of this thing out?


Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 358
Re: Your connection is not secure...still!
« Reply #1 on: October 12, 2018, 06:58:37 PM »

please run the following commands in terminal, and send me the output to

/Applications/ check_app Firefox
/Applications/ add_app Firefox

Kind regards,
Ondrej Kolacek


  • Guest
Re: Your connection is not secure...still!
« Reply #2 on: October 12, 2018, 08:10:34 PM »
Last login: Thu Oct 11 13:30:03 on console
Mack:~ buzz$ /Applications/ check_app Firefox
-bash: /Applications/ No such file or directory

Mack:~ buzz$ /Applications/ add_app Firefox
-bash: /Applications/ No such file or directory
Mack:~ buzz$

As stated above, Avast is no longer installed, but still a problem.

Offline .: Mac :.

  • Avast √úberevangelist
  • Ultra Poster
  • *****
  • Posts: 5093
Re: Your connection is not secure...still!
« Reply #3 on: October 14, 2018, 03:49:30 PM »
If you have removed Avast, then its normal for those command to fail, as the .app bundle is no longer on the computer.

How did you uninstall Avast? Just deleting the app file is not the proper way in this case. You need to choose the uninstall option from the menu to do a proper uninstall (to remove other various files).
"People who are really serious about software should make their own hardware." - Alan Kay

Offline Bob255

  • Newbie
  • *
  • Posts: 1
Re: Your connection is not secure...still!
« Reply #4 on: June 16, 2019, 12:10:59 AM »
Here's what I found and hope others will benefit.  The firewall was part of the problem.  I had the Comodo Firewall along with the Avast Secure Browser.  One day, I tried to remove the Google Chrome browser to reduce overhead size but that took out the Chrome Secure Browser.  Avast Secure Browser is Chromium-based and seems to need Chrome to co-exist but Comodo Firewall tracked changes. 

This is what I did: removed the Comodo firewall and Avast browser then re-installed the Secure browser before re-installing the firewall.  (Just be careful when removing the Secure browser and leave alone existing bookmarks option or the bookmarks will be erased. ) There may be variations to the solution but this is what worked for me.