Author Topic: Avast Interrupting my Internet Connection  (Read 9568 times)

0 Members and 1 Guest are viewing this topic.

Offline StephyFace

  • Newbie
  • *
  • Posts: 1
Avast Interrupting my Internet Connection
« on: November 13, 2018, 10:48:47 AM »
So, I have been noticing lately, some unusual things happening with my internet connection. Sometimes it will just drop for no reason, but usually reconnects quickly, however, it's been happening more often also. It's extremely inconvenient when I am busy working on something important & suddenly there's no net. Yesterday, it lasted longer than usual, then just now, I couldn't get a connection. Even though my modem clearly seems to be working fine, the first thing I did was reset it and my router, and of course, they are both working fine. I just had a hunch, and thought to try and disabled Avast, & as soon as i did, tada, internet working fine. I have done some googling and found others have had this issue at some point as well.
What is causing this & how can I stop it without having to disable Avast completely?
I have used Avast for MANY MANY MANY years and I have NEVER had this problem before now. I do not ever mess with the Avast settings either, nor do I understand why it's causing this issue all of a sudden. Before I try what some of the old posts suggest to try & fix it (which seems basically to be just to restore to default settings????) I wanted some feedback first, because this just makes no sense to me.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 61105
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Interrupting my Internet Connection
« Reply #1 on: November 13, 2018, 11:23:15 AM »
- Which Avast..? (Free/Pro/IS/Premier)
- Which version..?
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?
Win 8.1 [x64] - Avast PremSec 19.9.2394.B1 - CC 5.63 - EEK - Firefox ESR 60.9 [NS/AOS/uBO] - TB 68.1.1 [EM] - ABS/ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline drksky1056

  • Newbie
  • *
  • Posts: 1
Re: Avast Interrupting my Internet Connection
« Reply #2 on: November 13, 2018, 02:11:21 PM »
I found this morning that Avast is blocking DNS traffic.  I cannot ping hosts by name, but IP address pings work fine.  Disabling shields allows DNS requests to go through.  I have been using Avast on the computer in question for months, so whatever update went out in the last 24 hours is breaking DNS.

I am using 8.8.8.8 and 8.8.4.4 as my DNS resolvers.

Oh, and you CAPTCHA images suck

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 61105
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Interrupting my Internet Connection
« Reply #3 on: November 13, 2018, 02:34:09 PM »
Start your own topic and provide details.

PS: Captcha is only needed for your first 3 posts. (Spam protection)
Win 8.1 [x64] - Avast PremSec 19.9.2394.B1 - CC 5.63 - EEK - Firefox ESR 60.9 [NS/AOS/uBO] - TB 68.1.1 [EM] - ABS/ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Nancy115

  • Newbie
  • *
  • Posts: 2
Re: Avast Interrupting my Internet Connection
« Reply #4 on: November 13, 2018, 03:07:40 PM »
Seeing the same issue.  Avast blocking DNS and the Avast service constantly using 40-50% CPU, even with the shields turned off.

Offline Matt343

  • Newbie
  • *
  • Posts: 3
Re: Avast Interrupting my Internet Connection
« Reply #5 on: November 13, 2018, 04:22:25 PM »
Our network is blowing up because of this.  Submitted a ticket.  No response from Avast yet.  All DNS traffic being blocked, processor through the roof.  C'mon Avast you're better than this, theres no excuse for suddenly bringing a company down.

Offline BWhit

  • Avast team
  • Sr. Member
  • *
  • Posts: 273
Re: Avast Interrupting my Internet Connection
« Reply #6 on: November 13, 2018, 04:32:43 PM »
Hi Everyone,

In order to trace what is causing this, can I ask anyone affected by this issue to help identify which Shield is causing the issue? To do this, please open the Avast application > click "Protection" on the left hand side > click on the "Core Shields" tile > turn the shields off one by one and test if the issue persists. Please confirm which shield needed to be disabled before the DNS requests go through.
« Last Edit: November 13, 2018, 04:37:12 PM by BWhit »

Offline Matt343

  • Newbie
  • *
  • Posts: 3
Re: Avast Interrupting my Internet Connection
« Reply #7 on: November 13, 2018, 04:51:28 PM »
Webshield

Offline plknicely

  • Newbie
  • *
  • Posts: 2
Re: Avast Interrupting my Internet Connection
« Reply #8 on: November 13, 2018, 05:01:13 PM »
Avast has killed any attemp to get on the Internet on both my laptop and desktop. I am running Windows 10 pro with the latest updates. I have uninstalled Avast on both computers and they are now working normally.

Offline wvrick1958

  • Jr. Member
  • **
  • Posts: 26
Re: Avast Interrupting my Internet Connection
« Reply #9 on: November 13, 2018, 05:14:29 PM »
I too am having the same problem with Premier. 

Blocked Facebook notification and messages, I run a virus scan and it says the problem with my network issue with router settings and suggests I buy an add-on.  After I can no longer access the internet, I disable Avast for 10 minutes and have full working access with greater load speeds.

I uninstalled Avast Prem then reinstall with the same problems. I have 200 days left in my sub and hate to lose what I've paid to switch AV.

AVAST is BLOCKING my internet!

Offline lilpav94

  • Newbie
  • *
  • Posts: 4
Re: Avast Interrupting my Internet Connection
« Reply #10 on: November 13, 2018, 05:21:58 PM »
I am dealing with the exact same issue. Internet dropping randomly and avast service constantly 30-70%cpu usage.

Offline 417paint

  • Newbie
  • *
  • Posts: 1
Re: Avast Interrupting my Internet Connection
« Reply #11 on: November 13, 2018, 05:36:52 PM »
Same here.  I have to completely disable shields to get anything on my internet connection.  I don't have time to disable one at a time, as I'm running a business.  That's your job.

Offline wvrick1958

  • Jr. Member
  • **
  • Posts: 26
Re: Avast Interrupting my Internet Connection
« Reply #12 on: November 13, 2018, 05:40:18 PM »
That's it for me, I'll change to something else.  I'm not using an AV that tries to force me to buy add-ons by blocking my router.

Offline HK

  • Avast team
  • Jr. Member
  • *
  • Posts: 76
Re: Avast Interrupting my Internet Connection
« Reply #13 on: November 13, 2018, 05:52:18 PM »
Hello,

Thank you all for the reports.
We are looking into the issue.

If possible, could you please provide more details like:
- Your Avast edition (Free, Internet Security, ...)
- Windows version
- The exact error message from the browser (ideally with info about browser version)
- Does the issue appear immediately after enabling Web Shield or is it working for some time and then breaks?
- Does ping of domain work or just ping of IP address?
- Generate support package with debug logging enabled (Menu > Settings > General > Maintenance > Enable debug logging) when the issue appears and send us the ID: https://support.avast.com/en-ww/article/Submit-support-file

Thank you,
HK
« Last Edit: November 13, 2018, 05:54:19 PM by HK »

Offline lilpav94

  • Newbie
  • *
  • Posts: 4
Re: Avast Interrupting my Internet Connection
« Reply #14 on: November 13, 2018, 06:03:44 PM »
Avast Free Antivirus
Program 18.7.2354 Build(18.7.4041.0)
Virus definitions 181113-8
number of definitions 5,133,906
Windows Version 10 Home with ALL updates installed up-to-date
Google chrome browser
My internet is back on normally even with the shields on.
Turning web shield off fixes everything. The cpu usage goes from idle 30-50% and with the web shield off it goes to under 0-5%

It seems it might have fixed itself? I can now have the web shield on and the cpu usage is normal 0-5%
I will generate a support package if the issue pops up again