Author Topic: avast webshield/siteblocking broken!!  (Read 1169 times)

0 Members and 1 Guest are viewing this topic.

Offline Darknessblade

  • Newbie
  • *
  • Posts: 14
avast webshield/siteblocking broken!!
« on: November 17, 2018, 11:14:27 AM »
hello,

after using avast "free" for over a long time is started to notice that the webshield/siteblocking is not working all of the time.
on sites where i blocked "add domains" so the site is addfree, it worked for a long time with the browser i use: "maxthon"

but now the siteblocking feature is not blocking those domains anymore.
if i use edge for example, the webshield/siteblocking is working properly like it should and there are no adds served/ the banners show a avast user inbut block message.

some of domain names i blocked are: {will not use the url so its only the domain names}
------------
cobalten
cpmstar
*mdnsys
serving-sys
bebi

--------------------
i have done multiple checks with both avast and malwarebytes and awdcleaner, a few days ago and they gave no results of any malware or virussus or adware.
----------------
currently running another round of scans


Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 56333
  • Happy Holidays..!!
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: avast webshield/siteblocking broken!!
« Reply #1 on: November 18, 2018, 08:09:45 AM »
- Which Avast..? (Free/Pro/IS/Premier)
- Which version..?
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
Win 8.1 [x64] - Avast Premier 19.1.2358.Beta2 - CC 5.50 - MCS - EEK - FF ESR 60.4 [NS/AOS/uBO] - TB 60.3.3 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Darknessblade

  • Newbie
  • *
  • Posts: 14
Re: avast webshield/siteblocking broken!!
« Reply #2 on: November 18, 2018, 10:43:35 AM »
1- Which Avast..? (Free/Pro/IS/Premier)
2- Which version..?
3- OS..? (32/64 Bit..? - which SP/Build..?)
4- Other security related software installed..?
5- Which AV(s) did you use before Avast..?


1 i use avast "FREE"
2 version: 18.7.2354
3 i use windows 10 sp64 {1803}
4 i only have malwarebytes installed besides avast {free version}
5 i never used any other antivirus due the system having a FULL clean install and i directly installed avast
{and i mean full clean install by removing all partitions and data, formatting the HDD then reinstalling it}
-----------------------
im not sure which version of avast did not have this issue, but i  at least know that it worked 4 months ago,
due the site not having the addware on their site during that period.


-----------------------------
the last 2 checks i did with avast and malwarebytes yielded no results or any false positives {false positive like cheat engine}

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 56333
  • Happy Holidays..!!
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: avast webshield/siteblocking broken!!
« Reply #3 on: November 18, 2018, 11:01:00 AM »
Win 8.1 [x64] - Avast Premier 19.1.2358.Beta2 - CC 5.50 - MCS - EEK - FF ESR 60.4 [NS/AOS/uBO] - TB 60.3.3 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Darknessblade

  • Newbie
  • *
  • Posts: 14
Re: avast webshield/siteblocking broken!!
« Reply #4 on: November 18, 2018, 02:07:10 PM »
Update to the latest version (18.8.2356): https://forum.avast.com/index.php?topic=223244.0

Regarding Avast & Malwarebytes, see: https://forums.malwarebytes.com/topic/200324-exclusions-for-avast-users/

i have updated to the latest version and virus definitions, but still the sites are still creating popups.
there is only 1 more thing i can try and that is to clean the web-filter list and rebuild it anew.
since there are over 200 entries in it there might be some conflicts

see the added exclusion for my definition list {remove the .log extension} {the forum does not allow the settings file to be uploaded}

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 56333
  • Happy Holidays..!!
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: avast webshield/siteblocking broken!!
« Reply #5 on: November 18, 2018, 02:16:12 PM »
there is only 1 more thing i can try and that is to clean the web-filter list and rebuild it anew.
since there are over 200 entries in it there might be some conflicts
Might be worth a try.
Win 8.1 [x64] - Avast Premier 19.1.2358.Beta2 - CC 5.50 - MCS - EEK - FF ESR 60.4 [NS/AOS/uBO] - TB 60.3.3 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 39304
  • 58 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: avast webshield/siteblocking broken!!
« Reply #6 on: November 18, 2018, 02:19:47 PM »
"i have updated to the latest version and virus definitions, but still the sites are still creating popups."
Are you trying to block websites or popups ???
Free avast! Security Seminar: https://goo.gl/kh3cqR  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1809 64bit, 8 Gig Ram, AvastFree 18.7.2354, WinPatrol, Unchecky How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Darknessblade

  • Newbie
  • *
  • Posts: 14
Re: avast webshield/siteblocking broken!!
« Reply #7 on: November 18, 2018, 02:39:20 PM »
"i have updated to the latest version and virus definitions, but still the sites are still creating popups."
Are you trying to block websites or popups ???

I am, trying to block the popups from the website itself. {including some ad-serving domains}
since the website has a ad-block filter,
i have also reset the web-filter list {removing EVERYTHING} and rebuild it only with the cobalten domains, {sub domains too}
it still does not work under maxthon. but it does under edge and IE11. {blocking the domain/preventing it from opening}

the cobalten "addware" is not installed on my pc the site uses it as a means of add revenue.
-----------------

but this did not work
for example (how i build the list)
site,com/*
site,com/redir=*
site,com/redir=*/zone=*
site,com/redir=*/zone=*/region=*
redir,sitecom/^^^
pop,site,com/^^^
-------------
the added list is only with the cobalten domains. {remove .log extension}





Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 39304
  • 58 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: avast webshield/siteblocking broken!!
« Reply #8 on: November 18, 2018, 03:32:31 PM »
Then you need to use something like uBlock Origin
or another Ad blocker Or, use the Avast Secure Browser which has ad blocker built in.
https://www.avast.com/en-us/secure-browser
Free avast! Security Seminar: https://goo.gl/kh3cqR  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1809 64bit, 8 Gig Ram, AvastFree 18.7.2354, WinPatrol, Unchecky How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Darknessblade

  • Newbie
  • *
  • Posts: 14
Re: avast webshield/siteblocking broken!!
« Reply #9 on: November 18, 2018, 03:36:48 PM »
Then you need to use something like uBlock Origin
or another Ad blocker Or, use the Avast Secure Browser which has ad blocker built in.
https://www.avast.com/en-us/secure-browser

sadly there is no ublock origin extension for the browser i use.
nor are there any other addblock extensions available.

as i said before it used to work like normal, but now it is not working anymore.
even add-domains are not being blocked anymore.
some popup domains are blocked for some reason {which is quite strange} {they have no domain name but a ip adress}

will keep updates to see if i can get it fixed. but it might be worth to look into this issue

Offline Darknessblade

  • Newbie
  • *
  • Posts: 14
Re: avast webshield/siteblocking broken!!
« Reply #10 on: November 18, 2018, 03:56:01 PM »
update about other add popup domain:
the other popup-domain is being blocked, but i dont understand why the cobalten domain is not being blocked.
----------
blocking the host IP/ip addresses had no effect:
http://whois.domaintools.com/cobalten.com
https://www.ultratools.com/whois/serverStats?selectedTab=serverStats

another  add/popup server that is being blocked by the firewall rules i set {and yes im aware that this is a domain of google, but its serving popups}
http://whois.domaintools.com/35.193.89.147

so its strange that cobalten is not being blocked
{see included image}

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 4720
  • Spartan Warrior
Re: avast webshield/siteblocking broken!!
« Reply #11 on: November 20, 2018, 03:49:28 AM »
What is obvious is that Avast WebShield is working properly.  It is blocking as it should, thus creating the popups.

You report maxthon does not support uBlock Origin. 

Using uBlock will help block but you've to use another browser.  Simplest workaround would be to follow bob3160's advice, and perhaps find another adblocker if you want to use maxthon.
Windows 10 Home 64-bit 1809 (OS Build 17763.134) Avast Internet Security version 18.8.2356 (build 18.8.4084.408)

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 39304
  • 58 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: avast webshield/siteblocking broken!!
« Reply #12 on: November 20, 2018, 01:24:44 PM »
According to their website, Ad Blocking is built in:


http://www.maxthon.com/mx5/features/ad-blocker/
I would still suggest giving the Avast Secure Browser a try.
https://youtu.be/hDOGrDExWqs
Free avast! Security Seminar: https://goo.gl/kh3cqR  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1809 64bit, 8 Gig Ram, AvastFree 18.7.2354, WinPatrol, Unchecky How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Darknessblade

  • Newbie
  • *
  • Posts: 14
Re: avast webshield/siteblocking broken!!
« Reply #13 on: November 20, 2018, 08:30:01 PM »
According to their website, Ad Blocking is built in:


http://www.maxthon.com/mx5/features/ad-blocker/
I would still suggest giving the Avast Secure Browser a try.
https://youtu.be/hDOGrDExWqs

yes im aware that the browser has build in adblock. and im already using it on many sites
but some sites also use "anti-adblock" meaning you cannot access the site till you disable adblocker.
{those sites are also the very same ones that have those popups/onsite-adware: cobalten}




Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 4720
  • Spartan Warrior
Re: avast webshield/siteblocking broken!!
« Reply #14 on: November 20, 2018, 08:49:35 PM »
Using FF and uBlock Origin I've never seen cobalten activity.  Plus, uBlock spoofs so you can view sites using anti-block techniques without worries or issue and then disabling your ad-blocker is not required. 

Since Avast is not owned or controlled by myself, I cannot force Avast to do what I require or want.  I can only ask.

Might help if you'd post a site you are having difficulty with cobalten so we can verify:
Windows 10 Home 64-bit 1809 (OS Build 17763.134) Avast Internet Security version 18.8.2356 (build 18.8.4084.408)