Author Topic: Avast Security (free) MacOS High Sierra 10.13.6 - You are not protected error  (Read 4513 times)

0 Members and 1 Guest are viewing this topic.

Offline Lorna12

  • Newbie
  • *
  • Posts: 1
I'm installing Avast Security on Macbook Pro running High Sierra and experiencing problems with the Shield.  I have status of "You are not protected Non-functional components: File Shield, Mail Sheild, Web Shield".   I found several items on the forum and on Avast website but non of them are addressing the issue I have.

I found  but it doesn't seem to be my issue.  On the first install I received and the "System software from developer "AVAST Software a.s." was blocked from loading." prompt and allowed.   I have tried uninstalling the software and reinstalling and this prompt does not return. 

I tried reaching out to Apple support they had me do some basic checks but have directed me back to Avast. 

Would really appreciate some guidance on this.  I don't see anyway to contact Avast directly.

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 905
  • Product manager for Secure Internet in Avast One
TL;DR - try to follow Jakub's guide at youtube -

Long story :
Apple introduced new security feature "User-Approved Kernel Extension Loading" in High Sierra release of macOSX (details at This feature requires user to manually allow any new kernel extension (aka kext). Avast antivirus is using these extensions for enabling real time protection of your mac. The real time protection covers any new files downloaded/copied or started from your hard drive (File shield), it checks any new emails coming to your Mail client (Mail shield) and verifies that any website content and URLs you've visited are safe (Web shield).
You'd need to go to Preferences > Security&Privacy and click ALLOW button. Unfortunately, we have noticed that there were some usability issues in particular High Sierra builds. According to Apple and our experience the issues that "user clicks the ALLOW button but nothing happens" significantly improved in macosx Mojave release. In some other cases the mentioned youtube guide helps. But neither of these workarounds works in 100%. I'd love to help you more but there is no way how we could workaround such bugs within the macosx.

There is one more trap in the "User-Approved Kernel Extension Loading" feature - the ALLOW button disappears after 30 minutes. Restarting of your macos should fix it -> restart the timer.
Quality is also a feature.

Offline Farse

  • Newbie
  • *
  • Posts: 1
I had this problem with "non-functioning components: File Shield" in Mac Mojave. Based on the advice above, I opened System Preferences>Security and Privacy, selected Privacy and assigned "Full Disk Access" to Avast. Problem solved.