Author Topic: Slow resolving host (fix)  (Read 1294 times)

0 Members and 1 Guest are viewing this topic.

Offline Simon234

  • Jr. Member
  • **
  • Posts: 20
Slow resolving host (fix)
« on: March 26, 2019, 01:03:32 PM »
It's windows being an a**. Specifically, Smart Name Resolution. Introduced in windows 8 and windows 10. And can dns leak too!!! IPv6 is not the issue so ignore that bit.

Quote
basically, what is happening is; The Windows 10 Creators Update is waiting for timeouts from trying to resolve any IPv6 addresses via the other network interfaces and for Smart Name Resolution (which determines which adapter returns the quickest DNS response). This leads to slower browsing because its checking the other network interface (if IPv6 is enabled on the interface) in your system first and the timeout for that is up to about 60 seconds then it waits for Smart Name Resolution to time out before going with the TAP adapter interface. Disabling IPv6 on the interface and disabling Smart Name Resolution in the registry keeps them from being checked thus no timeout wait and thus faster browsing.

For ages i was getting the long 'resolving host/' wait for every link clicked when my vpn was on.

PROCEED WITH CAUTION, BACK UP REGISTRY ETC

Quote
SmartNameResolution in registry

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient] > look for 'DisableSmartNameResolution' > if it does not exist then create it by right clicking in right pane and selecting new DWord and name it DisableSmartNameResolution then change its value to 1.

after the above steps, reboot the computer. (actually you don't need to reboot but some people might need to do so for some reason and its a pretty standard thing to reboot after registry changes especially on 32 bit systems, your choice.) The whole thing can be done in two minutes or less, its simple to do.

If using Windows 10 Pro and above you can also disable Smart Name Resolution via the group policy editor (gpedit.msc), to do this:

Press WIN+R and write gpedit.msc

Expand Administrative templates

Expand Network

Click DNS-client

Double-click "Turn off smart multi-homed name resolution"

Check the box called "Enabled"

Click "Apply all" and then "OK"

Taken from a vpn reddit i won't link but orignal source is https://www.privateinternetaccess.com/forum/discussion/comment/46635/#Comment_46635

So glad i can actually browse the internet without waiting 30 seconds every click
« Last Edit: March 26, 2019, 01:06:54 PM by Simon234 »

Offline miker1808

  • Newbie
  • *
  • Posts: 1
Re: Slow resolving host (fix)
« Reply #1 on: July 23, 2019, 09:12:37 AM »
Hi,
I've been suffering the "Resolving Host" problem with AVAST VPN turned on for about a week.... It started suddenly ...unprompted by any changes that I had knowingly made. VPN has been installed for about 6 weeks without a problem.

I followed the fix as described in the earlier post but I don't have "DNS client" folder in the "Windows NT" and so was loathe to proceed ... any thoughts on next steps?