Author Topic: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)  (Read 1433 times)

0 Members and 1 Guest are viewing this topic.

Offline zeroczar

  • Newbie
  • *
  • Posts: 5
I have been have having issues with getting my firewalls active, it seems to be due to the Base Filtering Engine not running, however whenever i have tried getting it permission to run i get error codes stating that it does not have access, i have tried dism, system health restore, tried scans with malwarebytes and the free version of ccleaner and giving admin to it through registry but it gets denied when i try to do that.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37109
Re: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)
« Reply #1 on: March 31, 2019, 12:04:23 AM »
What firewall?
What avast?


If you install avast internet security (or any avast with firewall) then your windows firewall is autodisabled (never run two software firewalls) and since you say firewalls, i guess you have more then one?





« Last Edit: March 31, 2019, 12:11:26 AM by Pondus »

Offline zeroczar

  • Newbie
  • *
  • Posts: 5
Re: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)
« Reply #2 on: March 31, 2019, 12:56:54 AM »
Avast internet security, not really sure what you call it but the firewall for the internet everything, i have the same issue with malwarebytes premium which neither had problems till one day i was playing a game then the screen blacked, it became unresponsive so i single tapped the off power button and it successfully closed all programs and shut down, then when i started it up it began acting strangely with some aspects of the computer working fine like the internet but the taskbar not, then i would restart and it seems it would reverse, so i eventually shut it down for a while and since then it has been fine but afterwards i noticed i had no access to the internet so i had to give certain things in cmd.exe admin and it began to work find, however i noticed the firewalls were not working anymore.

Some other interesting things is i cannot run windows defender at all and at on point when my computer was acting up it said i had to activate my Windows in the bottom right.

Offline zeroczar

  • Newbie
  • *
  • Posts: 5
Re: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)
« Reply #3 on: March 31, 2019, 01:10:35 AM »
I have malwarebytes which i am uncertain has a firewall or not, i presume it does as it apparently blocks things, but aside from that windows defender must not have been enabled as i had no issues with it before the incident.
« Last Edit: March 31, 2019, 01:17:34 AM by zeroczar »

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37109
Re: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)
« Reply #4 on: March 31, 2019, 10:31:04 AM »
Quote
I have malwarebytes which i am uncertain has a firewall or not,
Malwarebytes does NOT have a firewall

Sett your avast firewall network profile to private
https://support.avast.com/en-eu/article/Antivirus-Firewall-Application-Rules


Quote
Some other interesting things is i cannot run windows defender at all and at on point when my computer was acting up it said i had to activate my Windows in the bottom right.
When you install a antivirus program (that also has a firewall) then windows defender and windows firewall is autodisabled



« Last Edit: March 31, 2019, 10:36:47 AM by Pondus »

Offline zeroczar

  • Newbie
  • *
  • Posts: 5
Re: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)
« Reply #5 on: March 31, 2019, 01:14:55 PM »
I am not sure if i am reading this properly but it seems I can't do that because it won't allow me to edit Application settings as the firewall won't start. i read this https://support.avast.com/en-au/article/Troubleshoot-Antivirus-BFE-error and it says BFE is need for Avast installation, is it also required for it running afterwards also?  I am trying a Bootscan as i hope this may fix things if not i am not sure what to do then.

Offline zeroczar

  • Newbie
  • *
  • Posts: 5
Re: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)
« Reply #6 on: April 01, 2019, 02:27:12 AM »
Well that did not work.

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 85782
  • No support PMs thanks
Re: Firewalls not working(Windows Firewall Defender, Avast, Malwarebytes)
« Reply #7 on: April 01, 2019, 02:55:36 AM »
I am not sure if i am reading this properly but it seems I can't do that because it won't allow me to edit Application settings as the firewall won't start. i read this https://support.avast.com/en-au/article/Troubleshoot-Antivirus-BFE-error and it says BFE is need for Avast installation, is it also required for it running afterwards also?  I am trying a Bootscan as i hope this may fix things if not i am not sure what to do then.

First you need to check and see if the Base Filtering Engine (BFE) is running, was it running ?

If not start it and I would also suggest it is set to start Automatically (you would need to be running as an Administrator to make those changes) to ensure it is available for Avast to use. Images two and three of the Actions in the link you gave. 

Report your findings on starting that BFE service.

Before moving on to further recommendations the initial actions should be completed, report any findings/problems here, before advancing on to the next step in fault finding/resolution.

The Boot-time Scan was under further recommendations all of the previous Actions in the link you gave should be done first.
« Last Edit: April 01, 2019, 02:57:36 AM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.697) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security