Author Topic: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch  (Read 12217 times)

0 Members and 1 Guest are viewing this topic.

Offline sivanov

  • Newbie
  • *
  • Posts: 7
Hi,

crossposting this here, since I'm not sure the original mail to support@avast.com was received by the appropriate team:

The current debian-package does not install on Debian Stretch (this
worked with avast_2.2.0-1_amd64.deb):

```
dpkg -i avast_3.0.0-1_amd64.deb
Selecting previously unselected package avast.
(Reading database ... 163326 files and directories currently installed.)
Preparing to unpack avast_3.0.0-1_amd64.deb ...
Unpacking avast (3.0.0-1) ...
dpkg: dependency problems prevent configuration of avast:
 avast depends on libssl1.0.0; however:
  Package libssl1.0.0 is not installed.

dpkg: error processing package avast (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (232-25+deb9u9) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 avast
```

The problem here is that libssl1.0.0 is not packaged in Debian Stretch
(it has libssl1.0.2, which according to
  • should be compatible).


From the changelog I guess the addition is from adding/testing support
for Ubuntu 18+ (where libssl1.0.0 exists as package, but contains
version 1.0.2)

The last version (2.2.0-1) did not include any dependency on libssl
(despite needing it).

If I can provide any help in resolving this issue, please don't hesitate
to ask!

Thanks,
stoiko




Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76029
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline sivanov

  • Newbie
  • *
  • Posts: 7
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #2 on: April 18, 2019, 05:32:46 PM »
Thanks - wrote a message there!

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76029
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #3 on: April 19, 2019, 05:46:10 AM »
You're welcome.
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 394
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #4 on: April 25, 2019, 02:39:09 PM »
Hello,

thanks a lot for reporting this. We are very sorry such an embarrassing error has happened. As you may have noticed, this was a first release for Linux after 2 years, with complete change of the whole build and packaging process. We have tested the packages on multiple distributions, how we may have missed such an important distribution I have no idea.

The previous maintainer has very carefully ensured that the same .deb package used to run on multiple Ubuntu and Debian stable versions. That solution was already very fragile (see the "hidden" dependencies), and due to libcurl3/4 schism on Ubuntu and also on Debian in version 10, it is no longer possible to do this. We are currently working on providing builds for stable versions of supported distributions, with correct package dependencies, etc.. We will accelerate this, and provide working packages for stretch ASAP.

We apologise for the inconvenience.
Kind regards,
Ondrej Kolacek

Offline sivanov

  • Newbie
  • *
  • Posts: 7
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #5 on: May 07, 2019, 10:44:50 AM »
Hi,

Thanks for picking up the topic an working on a resolution!

I'll gladly test the new packages if you want!

For that particular issue it probably would be enough to change the dependency to 'libssl1.0.0|libssl1.0.2' from 'libssl1.0.0'?

Offline luchillo17

  • Newbie
  • *
  • Posts: 4
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #6 on: May 10, 2019, 05:57:21 AM »
Hi there, I've faced this today, i love avast and have a license, but then tried to install in Ubuntu (which was complex because there's no docs on that topic) and got the issue with the libssl1.0.0.

I want to use the same anti-virus in all my PC's, including Ubuntu ones, i'll gladly test the solution as well.

Btw i think i've had this issue before, and i think my quick fix that time was to alias the libssl1.0.x to libssl1.0.0, could that work @sivanov as a hacky quick fix?

Offline sivanov

  • Newbie
  • *
  • Posts: 7
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #7 on: May 10, 2019, 10:18:27 AM »
@luchillo17: Thanks for the hint! - I'm pretty sure that once installed avast_3.0.0-1 would run fine, but my concern was with the errors during installation (which break the package manager).
Anyways I'll try to verify that avast does run when installed.


Offline luchillo17

  • Newbie
  • *
  • Posts: 4
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #8 on: May 10, 2019, 02:05:18 PM »
@sivanov Sure, let me know when it's fixed, and where to get the latest, because there's nearly no updated docs on it.

Offline sivanov

  • Newbie
  • *
  • Posts: 7
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #9 on: May 10, 2019, 06:26:23 PM »
@luchillo17: indeed the problem does not stop at the dependencies, since avast_3.0.0 uses libcurl4 - and stretch only provides libcurl3 (even though the dev package would suggest otherwise) -
```
avast: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_4' not found (required by avast)
```

Offline luchillo17

  • Newbie
  • *
  • Posts: 4
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #10 on: May 10, 2019, 06:46:44 PM »
@sivanov Indeed i remember hitting that, had to install by hand, the issue for me was libssl1.0.0, which can't be installed i think? i have a critical dev session tomorrow so i'll not be trying anything weird this weekend, but monday i'll try both the sym link forl libssl1.0.0 and installing manually libcurl4.

Do you get any error if you install libcurl4 yourself?

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 394
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #11 on: May 13, 2019, 03:45:21 PM »
Hello,

please check changes in techdoc (http://deb.avast.com/lin/doc/techdoc.pdf) in section 2 - Installation.

Currently there are two sources from which you can install deb packages:
"deb http://deb.avast.com/lin/repo debian release", which we have tested that can be installed on Debian 8, Ubuntu 14.04 and Ubuntu 16.04
and
"deb http://deb.avast.com/lin/repo ubuntu release", which can be installed on Ubuntu 18.04. Please note that the 'ubuntu' in the name was unfortunate, hopefully today or tomorrow we will also add it to the repo as ubuntu-bionic ("deb http://deb.avast.com/lin/repo ubuntu-bionic release")

We will also release a package for Debian 9 ("debian-stretch") at the same time, this should fix the issue from the OP.

As you can see, we will switch to providing builds for stable versions of major Linux distributions. We will do this for Debian 10 and CentOS 8 when they are released.

We will have to be more clear regarding this; I will probably make a sticky post with the link to the tech doc.

Kind regards,
Ondrej Kolacek

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 394
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #12 on: May 16, 2019, 03:45:58 PM »
Hello,

the issue should now be resolved; please use
Code: [Select]
deb http://deb.avast.com/lin/repo debian-stretch release
in /etc/apt/sources.list to obtain the working package.

Kind regards,
Ondrej Kolacek

Offline luchillo17

  • Newbie
  • *
  • Posts: 4
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #13 on: May 17, 2019, 02:27:25 AM »
You sure about that?  8)
Sorry couldn't resist, but i can't install, check the attached file please, that shows when running apt update, and the second attached file shows what happens if i run the install command.

As far as i read you guys support LTS versions, meaning me running Ubuntu 19.04 could block me from installing?
« Last Edit: May 17, 2019, 02:33:19 AM by luchillo17 »

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 394
Re: avast_3.0.0-1_amd64.deb installation broken on Debian Stretch
« Reply #14 on: May 17, 2019, 02:19:50 PM »
You sure about that?  8)
Sorry couldn't resist, but i can't install, check the attached file please, that shows when running apt update, and the second attached file shows what happens if i run the install command.

As far as i read you guys support LTS versions, meaning me running Ubuntu 19.04 could block me from installing?

Hi,

thanks for the info! We will hopefully fix the Debian 9 32bit issue today.Edit: this issue should now be fixed.

Regarding supported distro versions: we will build Avast on LTS versions of CentOS, Debian and Ubuntu to guarantee that avast works on these versions; however we will neither test nor fix issues on other versions. And since our packages should now have all the required dependencies spelled out in .deb/.rpm (unlike in 2.* version where some dependencies were not present), there is higher chance that some dependencies may be missing and package thus uninstallable.

Kind regards,
Ondrej Kolacek
« Last Edit: May 17, 2019, 03:57:05 PM by ondrej.kolacek »