Author Topic: Avast blocking Access to Roku  (Read 7581 times)

0 Members and 1 Guest are viewing this topic.

Offline Scott378

  • Newbie
  • *
  • Posts: 2
Avast blocking Access to Roku
« on: May 09, 2019, 03:57:28 PM »
After installing Avast (paid version updated to latest version) Plex is no finding my roku.  If I go to my roku I can play music from my media server which is the same Windows 10 box that cannot access Roku.  My android phone can connect with my roku and instruct it which music to play.  Network setting is "Private" and if I turn off shield in Avast the roku will appear and I can stream to it from the windows machine.  Please help!

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: Avast blocking Access to Roku
« Reply #1 on: May 09, 2019, 06:12:15 PM »
It sounds as if you've got a paid product from avast including the firewall?  Avast Free does not have a firewall.

Did you reboot after setting the avast firewall to Private?  Did you set a firewall exclusion for roku if you already rebooted and still have issues?

Default avast firewall setting is Public, which is more restrictive than Private, and automatically blocks incoming connections on your work or home network.  Private is trusted and allows all connections on a trusted network.
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline Scott378

  • Newbie
  • *
  • Posts: 2
Re: Avast blocking Access to Roku
« Reply #2 on: May 10, 2019, 03:41:51 PM »
Yes it's paid version of Avast.
It's set to private, rebooting did not help. 
How would I set the exclusion for Roku since I am not running Roku software on my Windows 10 machine?  Somehow the firewall is blocking access to the roku even though it's on the same network.  My android phone with the Plex app can connect to both my desktop Plex media server or the Roku plex.  I can use my phone to direct Plex to stream from Windows 10 machine, just not the Windows 10 machine itself.
« Last Edit: May 10, 2019, 11:06:56 PM by Scott378 »

Offline BWhit

  • Avast team
  • Sr. Member
  • *
  • Posts: 273
Re: Avast blocking Access to Roku
« Reply #3 on: May 13, 2019, 05:23:43 PM »
Hi Scott378,

I'm sorry to hear that you are having issues accessing your Roku. I would advise to try changing the following system rules for the firewall. To access the system rules, please click the settings 'cog' icon on the upper right-hand side of the Firewall screen > click the "System Rules" button on the Settings screen:

    1. Please set the "Allow Windows File and Printer sharing" option to "Enabled"
    2. Please set the "Allow remote desktop connections to this computer" option to "Enabled"

If you are still having issues accessing the Roku from the PC after changing these settings, please try changing the following Geek Area settings for the firewall. To access the Geek Area, please click "Search" in the top right of the Settings screen (if you still have the system rules options showing, please close this window) > type geek:area in the text box and press enter/return > click "Search" in the top right of the screen > type Firewall and press enter/return.

    1. Please enable "Internet Connection Sharing mode" (click the box to the right of the setting so that a green tick appears).
    2. Please enable "Allow all connections with Friends when in Private mode"
    3. Please disable "Enable automatic profile switching"
    4. Please disable "Enable automatic port scan detection"

Offline Showbox2

  • Newbie
  • *
  • Posts: 1
Re: Avast blocking Access to Roku
« Reply #4 on: May 14, 2019, 10:06:13 PM »
Hello

I Purchased premimum version of Avast after reading review from https://showbox.fun/windows-defender-vs-avast/ website.

All is fine for first 3 days but when I tried to install Showbox app latest version its saying that file is corrupted. Can any one explaine me why?

Thanks

Online bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 44291
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking Access to Roku
« Reply #5 on: May 14, 2019, 10:48:08 PM »
Hello

I Purchased premimum version of Avast after reading review from https://showbox.fun/windows-defender-vs-avast/ website.

All is fine for first 3 days but when I tried to install Showbox app latest version its saying that file is corrupted. Can any one explaine me why?

Thanks
Corrupted file usually happens when the download has a problem or, if the program itself has a problem.
I'd suggest downloading it again to see if that helps. If not, contact Showbox and find out what the problem is.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline inventor00

  • Newbie
  • *
  • Posts: 4
Re: Avast blocking Access to Roku
« Reply #6 on: May 16, 2019, 10:30:14 PM »
Hi Scott378,

I'm sorry to hear that you are having issues accessing your Roku. I would advise to try changing the following system rules for the firewall. To access the system rules, please click the settings 'cog' icon on the upper right-hand side of the Firewall screen > click the "System Rules" button on the Settings screen:

    1. Please set the "Allow Windows File and Printer sharing" option to "Enabled"
    2. Please set the "Allow remote desktop connections to this computer" option to "Enabled"

If you are still having issues accessing the Roku from the PC after changing these settings, please try changing the following Geek Area settings for the firewall. To access the Geek Area, please click "Search" in the top right of the Settings screen (if you still have the system rules options showing, please close this window) > type geek:area in the text box and press enter/return > click "Search" in the top right of the screen > type Firewall and press enter/return.

    1. Please enable "Internet Connection Sharing mode" (click the box to the right of the setting so that a green tick appears).
    2. Please enable "Allow all connections with Friends when in Private mode"
    3. Please disable "Enable automatic profile switching"
    4. Please disable "Enable automatic port scan detection"

Thanks. The above allowed me to print to my network printer which the firewall was blocking. Using Avast Premium.  I only turn on the printer when I need it, and the Avast updates had been blocking it from printing. I typically would have to turn off Avast to print with my Ethernet network laser HP printer.  Doing both parts above finally allowed me to print.