Author Topic: Server 2003 R2 Backup Fails  (Read 9061 times)

0 Members and 1 Guest are viewing this topic.

bowcaps

  • Guest
Server 2003 R2 Backup Fails
« on: July 18, 2006, 06:45:17 PM »
Since installing Avast on my server, the native back up utility fails every time, the error message is -

Error returned while creating the volume shadow copy: 0xffffffff.

Error returned while creating the volume shadow copy:ffffffff

this has only occured since instally the suite, previously the stand alone server version caused no problems, could this be related to the inhouse avast database?

Any help / advice appreciated.

Thanks

Nigel

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Server 2003 R2 Backup Fails
« Reply #1 on: July 18, 2006, 06:48:36 PM »
Hi, and welcome to the avast forums.

So, you have installed the avast Management Server (AMS) software on that machine, and since doing that, the problem started to happen?

What operating is this, exactly?
Also, if you open Windows Event Viewer, are there any entries like this?


Event Type:    Error
Event Source:   VSS
Event Category:           None
Event ID:          6013
Date:                30.06.2006
Time:                23:50:42
User:                N/A
Computer:        SCHIG003

Description:

Sqllib error: OLEDB Error encountered calling IDBInitialize::Initialize. hr = 0x80004005. SQLSTATE: 08001, Native Error: 17

Error state: 1, Severity: 16

Source: Microsoft OLE DB Provider for SQL Server

Error message: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.



Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

bowcaps

  • Guest
Re: Server 2003 R2 Backup Fails
« Reply #2 on: July 18, 2006, 10:25:15 PM »
Hi Vlk

the event viewer is thus -

Event Type:   Error
Event Source:   VSS
Event Category:   None
Event ID:   6013
Date:      18/07/2006
Time:      19:17:03
User:      N/A
Computer:   DBTD-SERV01
Description:
Sqllib error: OLEDB Error encountered calling IDBInitialize::Initialize. hr = 0x80004005. SQLSTATE: 08001, Native Error: 17
Error state: 1, Severity: 16
Source: Microsoft OLE DB Provider for SQL Server
Error message: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.


I have removed AMS and back up works fine again.

I do wish to have this software on my server / workstations, is there a work around?

All suggestions / assistance appreciated.

Many thanks

Nigel

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Server 2003 R2 Backup Fails
« Reply #3 on: July 18, 2006, 10:56:33 PM »
This is a bug in the VSS service. Try applying the following three MS patches:

891957 Update is available that fixes various Volume Shadow Copy Service issues in  Windows Server 2003
http://support.microsoft.com/default.aspx?scid=kb;en-us;891957

913648 A new Volume Shadow Copy Service update is now available that fixes  various Volume Shadow Copy Service problems in Windows Server 2003
http://support.microsoft.com/default.aspx?scid=kb;EN-US;913648     

915331 The backup process fails and a time-out error occurs in Volume Shadow Copy Service writers
http://support.microsoft.com/default.aspx?scid=kb;EN-US;915331

I'm afraid you'll have to call the MS hotline to obtain (some of) those patches - but it should be free of charge.


The patches should resolve the issue.

Thanks
Vlk
« Last Edit: July 18, 2006, 11:00:25 PM by Vlk »
If at first you don't succeed, then skydiving's not for you.

bowcaps

  • Guest
Re: Server 2003 R2 Backup Fails
« Reply #4 on: August 11, 2006, 11:29:54 AM »
Hi Vlk,

unfortunatly after all the hassle of getting the hotfixes from microsoft and rebooting the server several times, the problem has not gone away.

I still have the error in the event viewer when trying to back up and the back-up process fails.

Any other suggestions?

Thanks in advance

Nigel