Author Topic: Allowing local access on packet rules  (Read 407 times)

0 Members and 1 Guest are viewing this topic.

Offline james942

  • Newbie
  • *
  • Posts: 3
Allowing local access on packet rules
« on: June 11, 2019, 03:22:04 PM »
I am using UPS Worldship which connects to my database via an OBDC connection. This uses TCP and a port number. At the moment, I have a custom packet rule set up on our SQL Server to block any access from the internet. However, when I try to connect to the database from Worldship, the firewall blocks it. I checked the firewall log and it only shows two colons in the address part. How can I allow a connection to the software when its local?

Offline Pondus

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 35951
Re: Allowing local access on packet rules
« Reply #1 on: June 11, 2019, 04:30:32 PM »
Set firewall to private and reboot
Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline Pondus

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 35951
Re: Allowing local access on packet rules
« Reply #2 on: June 11, 2019, 04:31:47 PM »
Is your firewall network profile in private or puplic mode?

Setting up Firewall Application Rules in Avast Antivirus
https://support.avast.com/en-eu/article/Antivirus-Firewall-Application-Rules

=================================================================

NOTE:The Network profiles control the settings which determine how strictly Firewall protects your PC.

Private: a lower level of security suitable for when your PC is connected to a trusted network such as your home or work network.
This profile enables better connectivity, and permits all communication within the network.

Public: a higher level of security suitable for when your PC is connected to a public network such as in a cafe or airport.
Because public networks present greater security risks, no incoming communication is permitted when this profile is set.

=================================================================



Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline james942

  • Newbie
  • *
  • Posts: 3
Re: Allowing local access on packet rules
« Reply #3 on: June 12, 2019, 11:31:16 AM »
The firewall is currently set on Private network. I have a custom packet rule set up for my SQL Server application to block anything inbound from the internet. However connecting to the database via ODBC, it blocks it even when its on the same computer

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 60304
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Allowing local access on packet rules
« Reply #4 on: June 12, 2019, 11:45:57 AM »
Try the Geek Area settings, mentioned here: https://forum.avast.com/index.php?msg=1505540
Windows 8.1 [x64] - Avast PremSec 19.7.2388.BC - CC 5.60 - EEK - Firefox ESR 60.8 [NS/AOS/uBO] - TB 60.8 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline james942

  • Newbie
  • *
  • Posts: 3
Re: Allowing local access on packet rules
« Reply #5 on: June 12, 2019, 12:02:47 PM »
Hi. Thank you, I have tried the settings in the Geek Area but to no avail. I dont know if this helps. In the firewall log, it comes up with the following when its blocked access to my SQL

Remote Address: Blank, Remote Port: 0. Local Address: ::, Local port: 1434, Protocol: TCP

I have tried to create an allow rule in Packet Rules for address "::" but no luck

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 60304
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Allowing local access on packet rules
« Reply #6 on: June 12, 2019, 01:02:24 PM »
Hi, probably best to contact support: https://support.avast.com/contact
Windows 8.1 [x64] - Avast PremSec 19.7.2388.BC - CC 5.60 - EEK - Firefox ESR 60.8 [NS/AOS/uBO] - TB 60.8 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0