Author Topic: Avast wont let me restore a file  (Read 463 times)

0 Members and 1 Guest are viewing this topic.

Offline Carlos803

  • Newbie
  • *
  • Posts: 3
Avast wont let me restore a file
« on: June 15, 2019, 02:34:43 AM »
Today I started up my PC and inmidiatly after that Avast moved atiu9pag.dll to the Virus Chest, and when I try to restore the file nothing happens, it says "file succesfuly restored", but the file is not really restored. Is part of my graphic drivers so i really need it back!!!

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81784
  • No support PMs thanks
Re: Avast wont let me restore a file
« Reply #1 on: June 15, 2019, 02:44:24 AM »
Is the file still in the virus chest ?
I have been able to Restore a file from the virus chest and I no longer had a copy in the virus chest (which used to happen in previous versions).

What was the location it was meant to be restored ?

What reason/alert was given to send it to the Virus Chest ?
I'm just wondering if, A avast still considers it infected, but I wouldn't have expected to see the "file successfully restored" message if that was the case.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Carlos803

  • Newbie
  • *
  • Posts: 3
Re: Avast wont let me restore a file
« Reply #2 on: June 15, 2019, 03:17:13 AM »
Thanks for answering me.
The file is still in the virus chest. The alert was: "File successfully restored,It's happy to be back", but it just wont come back.
The file is from System32\DriverStore\FileRepository\...\atiu9pag.dll
I tryed running as administrator but the issue persists

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81784
  • No support PMs thanks
Re: Avast wont let me restore a file
« Reply #3 on: June 15, 2019, 04:02:25 AM »
By alert I'm talking about the reason it was sent to the virus chest, e.g. what did avast say in the virus alert ?

If it is still in the virus chest you could try the Send for Analysis if you think it is a false positive detection.  That I believe would be the only reason why you would consider trying to sending it back to the original location (e.g. Restore).

That said I believe there are some issues with the options in the Virus Chest. 
I tried to send a file for analysis, but I kept getting an error 'Something went wrong.' In the forums I got a suggestion from an avast team member that it was probably because it is no longer detected. 

But when I tried to restore I got another error 'Whoops, error occurred.  This file can't be restored'.  That file location was a sub folder of Windows\Temp.  Even trying to delete it from the virus chest doesn't work, even after confirmation I want to delete, it remains in the chest.

So all in all I believe the virus chest is currently stuffed, sorry for using technical terms.

I think that we need some Avast Team input on this.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Carlos803

  • Newbie
  • *
  • Posts: 3
Re: Avast wont let me restore a file
« Reply #4 on: June 15, 2019, 04:18:07 AM »
I clicked the "Send for Analysis" option, so I'll have to wait. Thanks for the help!

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81784
  • No support PMs thanks
Re: Avast wont let me restore a file
« Reply #5 on: June 15, 2019, 11:32:17 AM »
I clicked the "Send for Analysis" option, so I'll have to wait. Thanks for the help!

You're welcome.
I have tried to draw some attention to this topic.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81784
  • No support PMs thanks
Re: Avast wont let me restore a file
« Reply #6 on: June 29, 2019, 07:28:19 PM »
Follow up, there has been a recent release of Avast 19.6.2383.

Have you updated yet and if so does that resolve the virus chest issue ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Cluster-Lizard2014

  • Sr. Member
  • ****
  • Posts: 240
Re: Avast wont let me restore a file
« Reply #7 on: June 30, 2019, 01:22:55 PM »
This suggestion won't fix the problem but it should get the DLL back where it should be. There are obvious risks involved so it is up to you to take that decision.

Find a reliable DLL repository (there is one I've used successfully several times for replacing missing DLLs) and look for that atiu9pag.dll. In fact I've already checked and there are five different versions available all with checksums so an authentic replacement copy of your original is likely to be one of them. Download it.

Next find out where that DLL should be installed and put it back there. BTW do not be tempted to use any DLL install tool you might be offered, do it all manually.

Finally write in an AVAST global exclusions path so it does not get sent to the Virus Chest again.

Theoretically that should fix it.   
« Last Edit: June 30, 2019, 01:26:10 PM by Cluster-Lizard2014 »