Author Topic: Avast wont let me restore a file  (Read 177 times)

0 Members and 1 Guest are viewing this topic.

Offline Carlos803

  • Newbie
  • *
  • Posts: 3
Avast wont let me restore a file
« on: June 15, 2019, 02:34:43 AM »
Today I started up my PC and inmidiatly after that Avast moved atiu9pag.dll to the Virus Chest, and when I try to restore the file nothing happens, it says "file succesfuly restored", but the file is not really restored. Is part of my graphic drivers so i really need it back!!!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81413
  • No support PMs thanks
Re: Avast wont let me restore a file
« Reply #1 on: June 15, 2019, 02:44:24 AM »
Is the file still in the virus chest ?
I have been able to Restore a file from the virus chest and I no longer had a copy in the virus chest (which used to happen in previous versions).

What was the location it was meant to be restored ?

What reason/alert was given to send it to the Virus Chest ?
I'm just wondering if, A avast still considers it infected, but I wouldn't have expected to see the "file successfully restored" message if that was the case.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.5.2378/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Carlos803

  • Newbie
  • *
  • Posts: 3
Re: Avast wont let me restore a file
« Reply #2 on: June 15, 2019, 03:17:13 AM »
Thanks for answering me.
The file is still in the virus chest. The alert was: "File successfully restored,It's happy to be back", but it just wont come back.
The file is from System32\DriverStore\FileRepository\...\atiu9pag.dll
I tryed running as administrator but the issue persists

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81413
  • No support PMs thanks
Re: Avast wont let me restore a file
« Reply #3 on: June 15, 2019, 04:02:25 AM »
By alert I'm talking about the reason it was sent to the virus chest, e.g. what did avast say in the virus alert ?

If it is still in the virus chest you could try the Send for Analysis if you think it is a false positive detection.  That I believe would be the only reason why you would consider trying to sending it back to the original location (e.g. Restore).

That said I believe there are some issues with the options in the Virus Chest. 
I tried to send a file for analysis, but I kept getting an error 'Something went wrong.' In the forums I got a suggestion from an avast team member that it was probably because it is no longer detected. 

But when I tried to restore I got another error 'Whoops, error occurred.  This file can't be restored'.  That file location was a sub folder of Windows\Temp.  Even trying to delete it from the virus chest doesn't work, even after confirmation I want to delete, it remains in the chest.

So all in all I believe the virus chest is currently stuffed, sorry for using technical terms.

I think that we need some Avast Team input on this.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.5.2378/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Carlos803

  • Newbie
  • *
  • Posts: 3
Re: Avast wont let me restore a file
« Reply #4 on: June 15, 2019, 04:18:07 AM »
I clicked the "Send for Analysis" option, so I'll have to wait. Thanks for the help!

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81413
  • No support PMs thanks
Re: Avast wont let me restore a file
« Reply #5 on: June 15, 2019, 11:32:17 AM »
I clicked the "Send for Analysis" option, so I'll have to wait. Thanks for the help!

You're welcome.
I have tried to draw some attention to this topic.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.5.2378/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/