Author Topic: June 2019 Avast interface taking over 1 minute to load  (Read 596 times)

0 Members and 1 Guest are viewing this topic.

Offline valhalla300

  • Newbie
  • *
  • Posts: 4
June 2019 Avast interface taking over 1 minute to load
« on: June 18, 2019, 04:07:35 PM »
I have noticed with each successive version of Avast in the past 6 months or so, that the interface is taking longer and longer to load. It will bring up a dark grey box with the progress indicator spinning the whole time. Now it is taking over 1 minute. Today it was not loading at all. There was no grey box popping up and right clicking on the system tray icon was not opening the sub-menu. This makes me nervous thinking that something corrupted Avast or that Avast itself has a virus.... I restarted my laptop in safemode but Avast does not seem to work in safe mode. I restarted it again in normal mode and it started working but it still takes a long time to load the interface. Is this a known issue for Avast??? Any ideas of why it is doing this?

Thanks!

VH

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 36993
Re: June 2019 Avast interface taking over 1 minute to load
« Reply #1 on: June 18, 2019, 04:20:20 PM »

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5417
  • Spartan Warrior
Re: June 2019 Avast interface taking over 1 minute to load
« Reply #2 on: June 19, 2019, 05:49:38 PM »
Avast A/V is not designed to automatically start in Safe Mode.

Safe Mode is meant to start only essential Microsoft operating system files and processes: 
https://www.howtogeek.com/164876/how-to-use-safe-mode-to-fix-your-windows-pc-and-when-you-should/
https://www.lifewire.com/safe-mode-2626018

Likely this is happening because of accumulated dross over time in the Avast antivirus program.  If the repair suggested by Pondus does not work to your satisfaction, try the solution proposed by Uberevangelist bob3160:  https://forum.avast.com/index.php?topic=227899.msg1509762#msg1509762 (Reply# 3) 

Even though issue is different for you, the process of fixing all program glitches is the same. 

I recommend an over-the-top install or clean install every time Avast moves from, say, version 19.4 to version 19.6 or even between using the full offline installer instead of the recommended online installer.  Always seems to help minimize glitches and you get to keep a current or older install copy just in case.   :)
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.10.2442 (build 20.10.5824.618) UI version 1.0.591.