Author Topic: System process aswHdsKe.sys high CPU usage  (Read 1527 times)

0 Members and 1 Guest are viewing this topic.

Offline Whatisname

  • Newbie
  • *
  • Posts: 3
System process aswHdsKe.sys high CPU usage
« on: June 25, 2019, 12:16:25 PM »
Hi,
Running free Avast anti virus 19.5.2378

Recently the system process has started using a high % of the CPU (25% to 30%) continuously on my Windows 8.1 pro

Running  Sysinternals Process explorer shows aswHdsKe.sys taking about 25% of the CPU.

Internet searches indicate this process is either a virus or an Avast process. 

Assuming it is an Avast process I have tried resetting Avast to default setting and rebooted.

I have also tried a Avast repair but after over 30 minutes it was still running so I stopped it.

I cannot cancel the kill the process as it is says it is unable to access the thread.

Anyone any ideas?

Thanks

Kevin

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 65912
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: System process aswHdsKe.sys high CPU usage
« Reply #1 on: June 25, 2019, 12:32:48 PM »
Hi Kevin, same OS - no issues.

- Which Avast..? (Free/Pro/IS/Premier)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
Win 8.1 [x64] - Avast PremSec 20.6.2420.BUC [UI.542] - CC 5.68 - EEK - FF ESR 68.11 [NS/AOS/uBO/PB] - TB 68.11 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Whatisname

  • Newbie
  • *
  • Posts: 3
Re: System process aswHdsKe.sys high CPU usage
« Reply #2 on: June 25, 2019, 01:26:21 PM »
Asyn,

Running free Avast anti virus 19.5.2378
No other security software running unless W8.1 is doing something I don't know about.
I have been using Avast for free on this system for  few years without any issues.

I recently had an issue with 100% disk usage tried a few things related to Windows (can't remember what just something simple as suggested on a forum)  and it went away but this problem appeared.
No new software installed recently.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 65912
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: System process aswHdsKe.sys high CPU usage
« Reply #3 on: June 25, 2019, 07:51:20 PM »
Update to the latest version (19.6.2383): https://forum.avast.com/index.php?topic=228012.0
Win 8.1 [x64] - Avast PremSec 20.6.2420.BUC [UI.542] - CC 5.68 - EEK - FF ESR 68.11 [NS/AOS/uBO/PB] - TB 68.11 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Whatisname

  • Newbie
  • *
  • Posts: 3
Re: System process aswHdsKe.sys high CPU usage
« Reply #4 on: June 25, 2019, 10:06:24 PM »
Asyn,

Thanks for the help. I tried your suggestion and so far it appears to be working. I must admit I thought I had the latest version but had not checked.

Thanks

Kevin


Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 65912
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: System process aswHdsKe.sys high CPU usage
« Reply #5 on: June 26, 2019, 05:19:03 AM »
You're welcome.
Win 8.1 [x64] - Avast PremSec 20.6.2420.BUC [UI.542] - CC 5.68 - EEK - FF ESR 68.11 [NS/AOS/uBO/PB] - TB 68.11 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline jcaldeira

  • Newbie
  • *
  • Posts: 1
Re: System process aswHdsKe.sys high CPU usage
« Reply #6 on: July 16, 2019, 03:20:59 PM »
Hi,

I'm having exactly this problem, which makes the fan constantly work, videos sometimes go slower, and battery drain faster. Very annoying.

Avast free 19.6.2383, have had it for years. Windows 10 Pro build 17134.885. No other security related software.

Any suggestions would be very welcome, at this point I'm tempted to just uninstall avast.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 65912
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: System process aswHdsKe.sys high CPU usage
« Reply #7 on: July 17, 2019, 05:22:14 AM »
1. Download Avast Free Antivirus: https://files.avast.com/iavs9x/avast_free_antivirus_setup_offline.exe
2. Follow instructions: https://www.avast.com/uninstall-utility (Run this tool for all prior installed Avast versions..!!)
3. Reinstall Avast with the downloaded installer from point 1.
4. Reboot.
Win 8.1 [x64] - Avast PremSec 20.6.2420.BUC [UI.542] - CC 5.68 - EEK - FF ESR 68.11 [NS/AOS/uBO/PB] - TB 68.11 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline S911

  • Newbie
  • *
  • Posts: 2
Re: System process aswHdsKe.sys high CPU usage
« Reply #8 on: October 21, 2019, 11:47:33 PM »
I would like to point out that this issue is once again present. Pretty sure this started again with the new version, which I installed yesterday or the day before.

Today I noticed the "System" process in the Task Manager showing a constant 13% CPU usage, equally to full usage of one of the 8 cores.
Using the Process Explorer software, something called "aswHdsKe.sys" showed up as the culprit. Searching for the CPU usage issue with this process lead me here.

Process Explorer:

This process is using 1 out of 8 cores 100% of the time, unnecessarily wasting processing power and energy.

As there is no new version around to update to and hope to solve the issue that way, I am a bit unsure what to do. Last time I had to reinstall Avast was when I could not update the software for some reason, it was quite a hassle and I would prefer not having to go through that again. Especially since I am quite unsure as to whether that would fix the issue or not - considering it might be version related.
Is this a known issue, will reinstalling help or do I need to wait for a new version?


Details:
Windows 10 Pro (Version 1803)
Avast Free 19.8.2393 (Build 19.8.4793.541)
No other anti-virus software present

Offline Jakub Dubovic

  • Avast team
  • Jr. Member
  • *
  • Posts: 25
Re: System process aswHdsKe.sys high CPU usage
« Reply #9 on: October 23, 2019, 10:12:32 AM »
Hello,

We have done some more investigation and most likely identified the cause of the issue.
It should be fixed in 19.10.

Thank you for your patience!

Offline S911

  • Newbie
  • *
  • Posts: 2
Re: System process aswHdsKe.sys high CPU usage
« Reply #10 on: November 06, 2019, 07:56:46 PM »
The issue appears to be gone after the last program update: Version 19.8.2393 (Build 19.8.4793.544).
No noticable, unusual "System" CPU usage anymore.

Thank you.