Author Topic: AVAST Business Antivirus Pro Plus blocking the iPhone hotspot via USB  (Read 1114 times)

0 Members and 1 Guest are viewing this topic.

Offline Filippo1974

  • Newbie
  • *
  • Posts: 5
Hi All,

I apologize in advance if this issue is already known, but after some googling I didn't find anything similar to my situation, so here I am.

Basically I have AVAST blocking the hotspot feature of my smartphone (Apple iPhone 6S plus) but only when I'm using that feature through the USB port. I usually use this instead of the Wi-Fi connection because for unknown reasons the Wi-Fi between the phone and my laptop appears to be very unstable, with frequent disconnections (I tried anything, including updating the wi-fi card driver, to no avail).

So, when AVAST is active and running, if I connect the phone to an USB port, the phone asks me to enter an authorization code (which normally happens the very first time one connects an iPhone to a PC after installing iTunes). After entering the code, nothing happens. The phone is not authorized, iTunes does not see the phone connected and the hotspot feature does not work. If I repeat the same operation with AVAST disabled instead, no authorization code required, iTunes sees the phone and the hotspot connection is correctly started. Curiously, after the phone is initially recognized, I can reenable AVAST and everything will continue to work: the important thing is that I keep AVAST disabled while plugging the phone on the USB port.

Anybody experienced the same and figured it out? Not a blocking issue, but a little annoying since I must remember to disable AVAST each time I plug the phone on the USB port.

If it can help, here is my configuration:
HP EliteBook 850 G2 notebook
Windows 10 Pro x64 version 1903
All device drivers up-to-date

Thanks in advance for any advice,
Filippo

Offline Filippo1974

  • Newbie
  • *
  • Posts: 5
A quick update. I contacted the Customer Support and with their assistance I nailed down the problem to the Firewall component of Avast Business. In fact, to let the hotspot be recognized and start the connection it is enough to temporarily disable only the firewall part, not the entire suite as I used to do initially. This said, at the moment I'm unsure about what to do to work around the issue. I'll let you know if I find anything useful.

Best regards,
Filippo

Offline mickey.b

  • Business Senior Support Technician
  • Moderator
  • Full Member
  • *
  • Posts: 104
    • Avast Business Technical Support
A quick update. I contacted the Customer Support and with their assistance I nailed down the problem to the Firewall component of Avast Business. In fact, to let the hotspot be recognized and start the connection it is enough to temporarily disable only the firewall part, not the entire suite as I used to do initially. This said, at the moment I'm unsure about what to do to work around the issue. I'll let you know if I find anything useful.

Best regards,
Filippo

I apologize that you're having this issue, but please definitely post on here what you find out in case anyone else has this same issue.
- Mickey B.
Avast Business Senior Support Technician
https://www.avast.com/business/support