Author Topic: ASWARDISK.SYS Hangs during Safe Mode then reboots loop  (Read 8500 times)

0 Members and 1 Guest are viewing this topic.

Offline peppershaker2

  • Newbie
  • *
  • Posts: 2
ASWARDISK.SYS Hangs during Safe Mode then reboots loop
« on: June 18, 2019, 02:12:03 AM »
My Windows 7 machine just started hanging on boot up. 
I am able to get to safe mode and the last file that it tries to load is ASWARDISK.SYS
I have tried a repair disk that I created from Gateway but the only options are to repair OS or System Restore.  Neither of these are the options I would like to use.  I wonder if during an Avast update if the driver could has been damaged?  I would like to understand if I have options vs a complete rebuild and losing my data?

Thanks for any direction

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5415
  • Spartan Warrior
Re: ASWARDISK.SYS Hangs during Safe Mode then reboots loop
« Reply #1 on: June 19, 2019, 06:59:47 PM »
Using a Linux Live CD will allow you to save and back up your personal files to some sort of backup media such as an USB stick.  You'll need to download a Linux operating system to a working system and create a live CD or USB from the resulting .iso file.  You do not install Linux.  Find the full Desktop version you can use for your system and download it.

Suggest going here:  https://tutorials.ubuntu.com/tutorial/try-ubuntu-before-you-install#0

Because Ubuntu is running in memory only from either the CD or USB, no changes will be made to your Windows system.  Once you have backed up your personal data (including bookmarks, etc.,.) you can do whatever you need to fix your installation. https://duckduckgo.com/?q=how+to+repair+windows+7&t=ffab&ia=web
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline peppershaker2

  • Newbie
  • *
  • Posts: 2
Re: ASWARDISK.SYS Hangs during Safe Mode then reboots loop
« Reply #2 on: June 26, 2019, 05:33:41 AM »
I’ll give it try....Thanks

Offline blh_

  • Newbie
  • *
  • Posts: 1
Re: ASWARDISK.SYS Hangs during Safe Mode then reboots loop
« Reply #3 on: August 15, 2019, 10:22:51 PM »
I booted into safe mode and uninstalled Avast Secure Browser and all is well.      :o