Author Topic: Schedule scan is scanning external drives even when I tell it not to.  (Read 802 times)

0 Members and 1 Guest are viewing this topic.

Offline diebesgrab

  • Newbie
  • *
  • Posts: 3
I recently started using Avast Security for Mac on a new MacBook Air. I attempted to set a daily scheduled scan, but I've run into an issue where even though I set the scan not to target "mounted removable volumes" or "mounted network volumes," my external USB-connected hard drives are still being scanned. This is a bit problematic as they're very large, and while occasional scanning may be a good idea, I don't really want a 12+ hour scan on a daily basis—and that's exactly what I'm running into while they're connected.

Attached is a screenshot of my scheduled scan settings.

Any advice on how to fix the problem short of making sure they aren't connected when running the scan, or running the scan manually, would be appreciated.

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 208
Hello,

we will check whether everything is working as it is supposed to, but Avast asks MacOS whether a specific volume is removable, so if MacOS considers your usb drive as not being removable, we scan it.

In the settings you have shown, you can set an exception for your usb drives via path; this will ensure that avast does not scan it.
Kind regards,
Ondrej Kolacek

Offline diebesgrab

  • Newbie
  • *
  • Posts: 3
Thank you! I'll try that and see how it goes.

Offline diebesgrab

  • Newbie
  • *
  • Posts: 3
I've given it a go for a few days, and while including those path exclusions works for manual scans, it doesn't appear to actually exclude the specified drives in scheduled scans. I'm scratching my head here.

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 208
I've given it a go for a few days, and while including those path exclusions works for manual scans, it doesn't appear to actually exclude the specified drives in scheduled scans. I'm scratching my head here.

When you schedule a scan, it's parameters are fixed, you can not change them in any way. You need to delete the old scheduled scan and schedule a new one with the appropriate exclusions. Maybe this could be the problem?