Author Topic: Firewall Blocking RDP Connections and Ignoring Custom Rules  (Read 7465 times)

0 Members and 1 Guest are viewing this topic.

Offline MZ6Alex

  • Newbie
  • *
  • Posts: 3
Hi All, I'm currently having an issue where I cannot remote desktop into my computer because Avast Firewall is actively blocking in the incoming connection attempts. I cannot for the life of me get it to stop doing this and am becoming very frustrated.

I'm just going to bullet point everything below since I think it will be easier to explain:
  • System: Windows 10 Pro 1903 - Avast Premier 19.6.2383 (build 19.6.4546.494)
  • Remote desktop has been enabled in Windows settings.
  • Remote desktop has been enabled in Avast Firewall System Rules (allow incoming remote desktop connections) along with incoming/outgoing ping requests
  • Unable to ping computer at all. Ping returns no response/destination host unreachable.
  • If avast firewall is disabled, RDP and ping work again.
  • When attempting to connect to the PC, I can actively see both "Host Process for Windows Services" and "System" being blocked in the "Apps recently managed by your firewall" area.
  • Modifying the rules for those processes to allow all connections for both has zero effect.
  • Restarting the computer has zero effect.
  • Reinstalling Avast Premier has zero effect.

So, am I missing something or is this some kind of bug? I don't know what else to do.

Thanks in advance!

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 64644
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #1 on: July 03, 2019, 05:17:03 AM »
Set the Avast Firewall to private mode and reboot.
Win 8.1 [x64] - Avast PremSec 20.4.2408.B#3 [UI.518] - CC 5.65 - EEK - Firefox ESR 68.8 [NS/AOS/uBO/PB] - TB 68.8.1 - ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline MZ6Alex

  • Newbie
  • *
  • Posts: 3
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #2 on: July 03, 2019, 05:35:32 AM »
I did try this, but with no luck. Although maybe it's also worth noting that for some reason this setting is not persistent for me either. Every time I restart the computer I get the pop-up in the bottom right corner asking me if the network is private or public (gets set to public by default and I have to change it). The computer is connected via ethernet (no wi-fi card installed).

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 64644
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #3 on: July 03, 2019, 05:45:46 AM »
Try the Geek Area settings, mentioned here: https://forum.avast.com/index.php?msg=1505540
Win 8.1 [x64] - Avast PremSec 20.4.2408.B#3 [UI.518] - CC 5.65 - EEK - Firefox ESR 68.8 [NS/AOS/uBO/PB] - TB 68.8.1 - ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline MZ6Alex

  • Newbie
  • *
  • Posts: 3
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #4 on: July 03, 2019, 06:44:08 AM »
Yes! That worked! Thank you! ;D
What do these changed settings do then? Are there any security implications to be aware of from making the changes?

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 64644
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #5 on: July 03, 2019, 06:51:13 AM »
You're welcome.
Win 8.1 [x64] - Avast PremSec 20.4.2408.B#3 [UI.518] - CC 5.65 - EEK - Firefox ESR 68.8 [NS/AOS/uBO/PB] - TB 68.8.1 - ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline rtd3

  • Newbie
  • *
  • Posts: 1
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #6 on: November 07, 2019, 08:40:42 PM »
I'm replying to this post because it describes exactly what I am experiencing.

I have had Avast Firewall working great, but then I received an Avast program update and I'm assuming something was changed in my environment.

In a nutshell,
1. I have the firewall turned on.
2. In the settings I have allowed Remote Desktop Connections.
3. In the application rules, I have added a line for TCP/UDP in from port 3389
4. In the Geek:area I have Internet Connection Sharing mode enabled, as well as "Allow all connections with Friends".  The other flags in the Firewall area are turned off.
5. My Network connections are private.
6. I can rdp in when I am doing so from within my own network.
7. I can rdp in from outside my network only when I turn off the Avast Firewall.
8. I also do not get any blocking entries in my firewall log.
9. Both of the systems I am using are windows 10.

Very Frustrating..   Any ideas/thoughts are appreciated..
Thank you.

Offline r@vast

  • Avast team
  • Poster
  • *
  • Posts: 420
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #7 on: November 08, 2019, 11:18:54 AM »
I'm replying to this post because it describes exactly what I am experiencing.

I have had Avast Firewall working great, but then I received an Avast program update and I'm assuming something was changed in my environment.

In a nutshell,
1. I have the firewall turned on.
2. In the settings I have allowed Remote Desktop Connections.
3. In the application rules, I have added a line for TCP/UDP in from port 3389
4. In the Geek:area I have Internet Connection Sharing mode enabled, as well as "Allow all connections with Friends".  The other flags in the Firewall area are turned off.
5. My Network connections are private.
6. I can rdp in when I am doing so from within my own network.
7. I can rdp in from outside my network only when I turn off the Avast Firewall.
8. I also do not get any blocking entries in my firewall log.
9. Both of the systems I am using are windows 10.

Very Frustrating..   Any ideas/thoughts are appreciated..
Thank you.

Hi,
You mentioned that it only occurred after the update.
I would suggest that you "Restart" (not reboot) your PC.
If you have already done so and are still experiencing the issue, please post a support file id here or PM me.
Please follow these steps:
1. Open - Avast Premium Security > Click on -  Menu > Settings > General > Troubleshooting > Select - Enable debug logging (at the bottom)
2. Please try to connect again to the PC in question.
3. Please generate the support file and reply with the support file id.

To generate the support file, please see this link.
https://support.avast.com/en-ww/article/Submit-support-file



Offline shmeld

  • Newbie
  • *
  • Posts: 7
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #8 on: January 09, 2020, 06:41:06 PM »
Unfortunately I have the same prolem: some days ago the possibility of remote desktop with AVAST firewall  ended. However I haven't remote desktop even from local network. The settings and OS are the same than in case of rtd3.   Could you help?
« Last Edit: January 09, 2020, 06:43:22 PM by shmeld »

Offline r@vast

  • Avast team
  • Poster
  • *
  • Posts: 420
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #9 on: January 10, 2020, 10:18:31 AM »
Unfortunately I have the same prolem: some days ago the possibility of remote desktop with AVAST firewall  ended. However I haven't remote desktop even from local network. The settings and OS are the same than in case of rtd3.   Could you help?

Hi,

please post a support file id here.
Please follow these steps:
1. Open - Avast Premium Security > Click on -  Menu > Settings > General > Troubleshooting > Select - Enable debug logging (at the bottom)
2. Please try to connect again to the PC in question.
3. Please generate the support file and reply with the support file id.

To generate the support file, please see this link.
https://support.avast.com/en-ww/article/Submit-support-file

Offline shmeld

  • Newbie
  • *
  • Posts: 7
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #10 on: January 13, 2020, 08:51:32 PM »
The file id is X9VA8. Hope for solution.

Offline r@vast

  • Avast team
  • Poster
  • *
  • Posts: 420
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #11 on: January 15, 2020, 08:50:44 AM »
The file id is X9VA8. Hope for solution.

Hi, please make sure that you have (allow "All connections" for RDP mstsc.exe in Application rules.
Please see the attached screenshot.


Offline shmeld

  • Newbie
  • *
  • Posts: 7
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #12 on: January 16, 2020, 10:42:06 PM »
Made new packet rule. Unfortunately without success. . By the way new problem arised: no able to connect my samsung TV via my laptop when avast firewall on. Very unhappy. Considering uninstall avast premium and get along windows firewall...

Offline shmeld

  • Newbie
  • *
  • Posts: 7
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #13 on: January 16, 2020, 10:44:56 PM »
Sorry made new application rule.

Offline r@vast

  • Avast team
  • Poster
  • *
  • Posts: 420
Re: Firewall Blocking RDP Connections and Ignoring Custom Rules
« Reply #14 on: January 17, 2020, 02:02:12 PM »
Made new packet rule. Unfortunately without success. . By the way new problem arised: no able to connect my samsung TV via my laptop when avast firewall on. Very unhappy. Considering uninstall avast premium and get along windows firewall...

Hi,

Thank you for the provided information.
Could you provide us with a new log file, please?