Author Topic: Offline updates - 'There was an error while changing the product configuration'  (Read 2144 times)

0 Members and 1 Guest are viewing this topic.

Offline Boris1969

  • Newbie
  • *
  • Posts: 4
Hi, wondering of someone can shed some light on this? Its almost as if the latest Avast Free can no longer accept the offline updates from for versions 12+.

I allowed my home install of last years Avast free to update itself over the internet earlier on this year to the latest 2019 version, and I'm regretting it. Due to a broadband cap at home, I download the offline updates elsewhere, save them to usb and apply them at home. This has worked fine for the past 3 years, but updating to 2019 has done something. It accepts one offline update, then refuses to accept any subsequent ones about a week later with the error in the subject header. Connecting and updating from the internet temporarily fixes the problem and it accepts one more offline update a week later, but further offline updates do exactly the same until updated via the internet again. Also noticed that when an offline update is accepted, the Avast front end says up-to-date, but if you look at the defs version under the update tab, it can think the old defs are still active or the dates of the defs are 'odd', I remember seeing a year 2090-something there at one point.

Program version of Avast free is 19.4.2374 (build 19.4.4318.0)
Windows 7 64bit

I updated the program version to the latest June 2019 again last night, but I have done this before with no change after I previously uninstalled/re-installed using latest avastclear.

Log file created when offline update failed:

2019-07-10 18:04:33.299Infoinstup[5484,1912]Command: '"C:\Program Files\AVAST Software\Avast\setup\instup.exe" /vps_upd:"C:\Users\PHILJA~1\AppData\Local\Temp\"'
2019-07-10 18:04:33.299Infoinstup[5484,1912]CPU: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz,8
2019-07-10 18:04:33.299Infoinstup[5484,1912]OS: Windows 7 SP1 x64
2019-07-10 18:04:33.299Infoinstup[5484,1912]setup: x64
2019-07-10 18:04:33.299Infoinstup[5484,1912]Memory: 16% load. Phys:14037760/16757988K free, Page:14202636/16960888K free, Virt:-103164/-128K free
2019-07-10 18:04:33.299Infoinstup[5484,1912]DISKs: C:\ - 6GB free / 49GB total
2019-07-10 18:04:33.299Infoinstup[5484,1912]DISKs: D:\ - 258GB free / 415GB total
2019-07-10 18:04:33.299Infoinstup[5484,1912]DISKs: F:\ - 703GB free / 931GB total
2019-07-10 18:04:33.299Infoinstup[5484,1912]Running module version: instup.exe - '19.4.4318.0'
2019-07-10 18:04:33.299Infoinstup[5484,1912]Running module version: Instup.dll - '19.4.4318.0'
2019-07-10 18:04:33.299Infomutex[5484,1912]The ownership of the secure mutex has been successfully taken.
2019-07-10 18:04:33.299Infoinstup[5484,1912]Loading product state
2019-07-10 18:04:33.299Infoinstup[5484,1912]Guid = fee5cadb-8f3c-4749-84cf-5e89c755d44b, Created = 16:27:06 21.06.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Persistent Guid = 90a1c135-ce62-4a81-b1f7-6fb33967ea3a, Created = 16:27:06 21.06.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]ProductId = ais
2019-07-10 18:04:33.299Infoinstup[5484,1912]Edition = 1
2019-07-10 18:04:33.299Infoinstup[5484,1912]SubEdition =
2019-07-10 18:04:33.299Infoinstup[5484,1912]Installed Part info:
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'jrog2' = 'jrog2', 7031 (0x00001B77), 11:44:16 21.06.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'program' = 'prg_ais', 319031622 (0x13040946), 10:21:43 09.04.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'setup' = 'setup_ais', 319031622 (0x13040946), 10:21:43 09.04.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'vps' = 'vps_win32', 419832066 (0x19062102), 11:44:18 21.06.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Latest Part info:
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'jrog2' = 'jrog2', 7031 (0x00001B77), 11:44:16 21.06.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'program' = 'prg_ais', 319031622 (0x13040946), 10:21:43 09.04.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'setup' = 'setup_ais', 319031622 (0x13040946), 10:21:43 09.04.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Part 'vps' = 'vps_win32', 419832066 (0x19062102), 11:44:18 21.06.2019
2019-07-10 18:04:33.299Infoinstup[5484,1912]Backing up 'C:\Program Files\AVAST Software\Avast\setup\setup.ini' to registry
2019-07-10 18:04:33.315Infoinstup[5484,1912]'C:\Program Files\AVAST Software\Avast\setup\setup.ini' successfully backed up to registry
2019-07-10 18:04:33.315Infousnca[5484,1912]USN cache loaded from the disk.
2019-07-10 18:04:33.330Infopart[5484,1912]SetInstalled: Part package part-jrog2-1b77.vpx is installed.
2019-07-10 18:04:33.346Infopart[5484,1912]SetInstalled: Part package part-prg_ais-13040946.vpx is installed.
2019-07-10 18:04:33.393Infoinstcore[5484,1912]PkgLoadProductInfo: product XML was successfully loaded for part 'program'.
2019-07-10 18:04:33.408Infopart[5484,1912]SetInstalled: Part package part-setup_ais-13040946.vpx is installed.
2019-07-10 18:04:33.424Infoinstcore[5484,1912]PkgLoadProductInfo: product XML was successfully loaded for part 'setup'.
2019-07-10 18:04:33.424Infopart[5484,1912]SetInstalled: Part package part-vps_win32-19062102.vpx is installed.
2019-07-10 18:04:33.440Infoinstup[5484,1912]Loading Proxy settings
2019-07-10 18:04:33.440Infoinstup[5484,1912]Proxy-Type: 'no proxy'
2019-07-10 18:04:33.440Infoinstup[5484,1912]Proxy-Authorization: 'no authentication'
2019-07-10 18:04:33.440Infoinstup[5484,1912]Proxy-Port: '8080'
2019-07-10 18:04:33.440Infoinstup[5484,1912]Proxy-Name: ''
2019-07-10 18:04:33.440Infoinstup[5484,1912]Proxy-User: ''
2019-07-10 18:04:33.440Infoinstup[5484,1912]Proxy-Pass: '???'
2019-07-10 18:04:33.471Warningini_access[5484,5292]failed to read from ini file C:\ProgramData\AVAST Software\Avast\burger_client.ini
2019-07-10 18:04:33.486Infowizard[5484,1912]Running module version: HTMLayout.dll - ''
2019-07-10 18:04:33.502Infowizard[5484,1912]Loaded module version: C:\Program Files\AVAST Software\Avast\setup\HTMLayout.dll - ''
2019-07-10 18:04:33.549Infowizard[5484,1912]Setup gui was successfully started.
2019-07-10 18:04:33.674Infoinstcore[5484,1912]Sfx VPS update has started.
2019-07-10 18:04:33.689Noticeservers[5484,1912]Load: 'urlpgm' key used as the program repository.
2019-07-10 18:04:33.689Infoservers[5484,1912]Server definition(s) loaded from 'C:\Users\PHILJA~1\AppData\Local\Temp\\servers.def'
2019-07-10 18:04:33.689Infoprod[5484,1912]LoadPartInfo: iex = iex-c returned 0x00000000
2019-07-10 18:04:33.689Infoprod[5484,1912]LoadPartInfo: jrog2 = jrog2-1b8a returned 0x00000000
2019-07-10 18:04:33.689Infoprod[5484,1912]LoadPartInfo: vps = vps_win32-19062802 returned 0x00000000
2019-07-10 18:04:33.689Infoengine[5484,1912]LoadLatestProdAndParts: product file 'prod-vps.vpx' was successfully loaded.
2019-07-10 18:04:33.689Infoengine[5484,1912]LoadLatestProdAndParts: part file part-jrog2-1b8a.vpx was successfully loaded.
2019-07-10 18:04:33.705Infoengine[5484,1912]LoadLatestProdAndParts: part file part-vps_win32-19062802.vpx was successfully loaded.
2019-07-10 18:04:33.705Errorinstup[5484,1912]InitGroups: definition XML for part 'vps' was not loaded yet!
2019-07-10 18:04:33.705Infoengvps[5484,1912]ExtractEmUpdates: Embeded uUpdates and EmUpdates special package 'C:\Users\PHILJA~1\AppData\Local\Temp\\emu-946.vpx' was not found (not in SFX).

Offline User1920

  • Newbie
  • *
  • Posts: 1
Not sure if this helps, but I was getting "There was an error while changing the product configuration" error when trying to update the definitions on an offline install of Avast. It seemed to go away after running the Avast clear utility, re-installing Avast and selecting the 'Software Updater' as one of the components to install.

(Originally I had not selected the 'Software Updater' component during installation as I didn't think this would be required for manual offline updates.)
« Last Edit: August 12, 2019, 08:35:51 AM by User1920 »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11819
    • AVAST Software
The web page now includes a link for an updater for versions 19+.
That's the one to use for offline virus definition updates on Avast v19.

Offline Boris1969

  • Newbie
  • *
  • Posts: 4
Hi, not sure what you mean by 'how many users package'?

Noticed that the offline updates download page now has a '19+' link instead of the old '12+', so I'll give that a go and see if its any better, sounds promising...

Offline Boris1969

  • Newbie
  • *
  • Posts: 4
The downloaded '19+' appears to have worked, no silly error messages or funny def dates being reported in-app. Looks like the 12+ updates were incompatible with Avast v19.

I'll see what happens next one I try to apply, but I think it should be ok now.

When was v19 first released, almost a year ago?
If so, its taken that long to fix offline updates?!