Author Topic: When Avast full shields up, DHCP IP does not work, NO IP available  (Read 574 times)

0 Members and 1 Guest are viewing this topic.

Offline erik138

  • Newbie
  • *
  • Posts: 2
There is an odd problem that occurred on my Laptop and Desktop PC, for windows that have had Avast install for some time (not new installations).
Avast stops the DHCP client from getting an IP number from the DHCP server.  The ONLY WAY around this is to uninstall Avast, turn off the internet shields or manually configure a fixed IP into settings of the network card.


This makes it a nightmare to travel, as if they shields are up you cannot join local networks. You either have to get your phone to join the network, find the IP range and spoof an allocation manually or you have to turn off your protection to connect.


If you google search "unable to get IP from DHCP Windows 10" you will find many people have this problem but do not know where the issue lies. I found one post that suggested it was Avast, and sure as crap, it was.

Any plans to fix this?

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 69424
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: When Avast full shields up, DHCP IP does not work, NO IP available
« Reply #1 on: July 13, 2019, 09:41:00 AM »
- Which Avast..? (Free/Pro/IS/Premier)
- Which version..?
- OS..? (32/64 Bit..? - which SP/Build..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
Win 8.1 [x64] - Avast PremSec 21.2.2453.Beta#4 [UI.601] - EEK - Firefox ESR 78.8 [NS/uBO/PB] - TB 78.8
Avast-Tools: Secure Browser 88.2 - Cleanup P 21.1 - SecureLine 5.9 - Driver Updater 21.1 - CCleaner 5.77
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0