Author Topic: Avast Blocking Web Browsing  (Read 5341 times)

0 Members and 1 Guest are viewing this topic.

Offline zwipp

  • Newbie
  • *
  • Posts: 6
Avast Blocking Web Browsing
« on: August 20, 2019, 04:44:12 AM »
Avast keeps blocking websites for me. Whenever I start searching on google for things or when I visit websites for the first time in a few hours, Avast completely blocks all internet access in my browsers. I get a timeout message on every site I'm trying to visit, including sites I'm currently on that has been working fine for hours.




(Updated)

I know this is Avast's doing because as soon as I go to "Avast shields control" and click on "Disable for 10 minutes" (or more) all my sites loads instantaneously and the problem completely disappears.

I'm not losing the internet connection over all. All my online games and applications are fine, I just can't visit websites without getting timeouts in my browsers.
It should be noted however that the sites will load eventually, about a 30 - 60 seconds after I get the first timeout message.


I'm running on:
-Microsoft Windows 10 Professional: 10.0.17763 build 17763

Avast:
-Avast Premium Security: 19.7.2388 (version 19.7.4674.520)

Web browser:
-Google Chrome
-Edge

Anyone know how to fix this?
« Last Edit: August 22, 2019, 02:49:37 AM by zwipp »

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72794
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Blocking Web Browsing
« Reply #1 on: August 20, 2019, 07:19:56 AM »
Set the Avast Firewall to private mode and reboot.
Win 8.1 [x64] - Avast PremSec 21.10.6772.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.3 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline zwipp

  • Newbie
  • *
  • Posts: 6
Re: Avast Blocking Web Browsing
« Reply #2 on: August 20, 2019, 04:14:20 PM »
Set the Avast Firewall to private mode and reboot.

My network settings are already set to private network.  :-\

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72794
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Blocking Web Browsing
« Reply #3 on: August 20, 2019, 04:20:10 PM »
- Which version of Premier..?
- OS - which Build of W10..?
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
Win 8.1 [x64] - Avast PremSec 21.10.6772.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.3 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline zwipp

  • Newbie
  • *
  • Posts: 6
Re: Avast Blocking Web Browsing
« Reply #4 on: August 20, 2019, 04:42:27 PM »
- Which version of Premier..?
- OS - which Build of W10..?
- Other security related software installed..?
- Which AV(s) did you use before Avast..?

Avast Premium Security: 19.7.2388 (version 19.7.4674.494)
Microsoft Windows 10 Professional: 10.0.17763 build 17763

-Other security related software installed?
None except for what came with windows. (Windows Security)

-Which AV(s) did you use before Avast?
None except for what came with windows. (Windows Security)

I'm running a new installation of Windows on my computer. The only AV program it had was the built in Windows Security thing.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72794
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Blocking Web Browsing
« Reply #5 on: August 20, 2019, 04:44:35 PM »
1. Download Avast Premier Antivirus: https://files.avast.com/iavs9x/avast_premier_antivirus_setup_offline.exe
2. Follow instructions: https://www.avast.com/uninstall-utility (Run this tool for all prior installed Avast versions..!!)
3. Reinstall Avast with the downloaded installer from point 1.
4. Reboot.
Win 8.1 [x64] - Avast PremSec 21.10.6772.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.3 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5420
  • Spartan Warrior
Re: Avast Blocking Web Browsing
« Reply #6 on: August 21, 2019, 11:26:51 AM »
If you've updated or upgraded to version 19.7, your issues could be related to a DNS setting in Avast, especially as you are running Avast Premier Security (formerly Avast Internet Security).

That setting is Real Site which, for me, seems to randomly turn itself off.  Windows Network Diagnostics will report the DNS server is not responding or not found and no internet connection is available.

Fix is to ensure Real Site is on or, if you hare having troubles updating the newest version after install because of no internet connectivity, and avast emergency updater, remediation exe, and/or overseer exe all cannot connect because there is no internet connection, this workaround is as follows:
  • Open Program and Features and navigate to AIS
  • Click on Change
  • Box will now say 'Checking for install conditions...
  • Allow completion and close the dialog box
You should now have an internet connection to browse websites...temporarily.  It will drop off shortly but the network will still show as connected.  That was odd...

For some reason, 19.7 Real Site default setting is set to off, and when that happens, no internet connection will occur.

Not something readily found as I've always had Real Site set to on in all prior versions of AIS.  Just turn Real Site on and you'll be good to go.

Also seeing licensing issues,  Avast is reporting no license even tho I've purchased a multi-year license with 606 days remaining.  Even tho the migration to Avast Premier Security is said to perhaps take weeks it already has done so.  I put the licensing issues down to the migration not being done as smoothly as it should be, my licenses still show as valid.  Perhaps the licensing servers need to be updated a little more quickly?

Note that the GUI still says Avast Internet Security too.
Windows 10 Home 64-bit 20H2 Avast Premier Security version 21.3.2459 (build 21.3.6164.652) UI version 1.0.612.

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5420
  • Spartan Warrior
Re: Avast Blocking Web Browsing
« Reply #7 on: August 22, 2019, 02:07:42 AM »
Same program but now with a name change, same licenses:  See below.  Used the upgrade offer from avast, quick and painless.

A reboot was required and Real Site had to be reset after restart, as internet connection refused to start on reboot (again).  Running Windows firewall at this time.
Windows 10 Home 64-bit 20H2 Avast Premier Security version 21.3.2459 (build 21.3.6164.652) UI version 1.0.612.

Offline zwipp

  • Newbie
  • *
  • Posts: 6
Re: Avast Blocking Web Browsing
« Reply #8 on: August 22, 2019, 02:24:33 AM »
1. Download Avast Premier Antivirus: https://files.avast.com/iavs9x/avast_premier_antivirus_setup_offline.exe
2. Follow instructions: https://www.avast.com/uninstall-utility (Run this tool for all prior installed Avast versions..!!)
3. Reinstall Avast with the downloaded installer from point 1.
4. Reboot.

I have now tried this, but unfortunately it didn't work.  :-\
I get this message in my browser now:




If you've updated or upgraded to version 19.7, your issues could be related to a DNS setting in Avast, especially as you are running Avast Premier Security (formerly Avast Internet Security).

That setting is Real Site which, for me, seems to randomly turn itself off.  Windows Network Diagnostics will report the DNS server is not responding or not found and no internet connection is available.

I'm running:
Avast Premium Security: 19.7.2388 (version 19.7.4674.520)

Avast Real Site is set to ON and has always been on. I don't seem to have the problem with it turning itself off, but I might have the DNS server thing.  ???

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5420
  • Spartan Warrior
Re: Avast Blocking Web Browsing
« Reply #9 on: August 22, 2019, 02:57:07 AM »
....
Fix is to ensure Real Site is on or, if you hare having troubles updating the newest version after install because of no internet connectivity, and avast emergency updater, remediation exe, and/or overseer exe all cannot connect because there is no internet connection, this workaround is as follows:
  • Open Program and Features and navigate to AIS
  • Click on Change
  • Box will now say 'Checking for install conditions...
  • Allow completion and close the dialog box
You should now have an internet connection to browse websites...temporarily.  It will drop off shortly but the network will still show as connected.  That was odd...  [EDIT] Should've said 'That's odd....'

For some reason, 19.7 Real Site default setting is set to off, and when that happens, no internet connection will occur.

Not something readily found as I've always had Real Site set to on in all prior versions of AIS.  Just turn Real Site on and you'll be good to go.
[snip]
Did you try the above?  You may have to turn Real Site off for a moment, wait a bit, and then back on.  What Real Site does is set the DNS Server used by Avast and by extension your internet connection..."Checking for install conditions" will modify your network connections if you choose the second option.

I'm putting some of this bug on the massive migration issue of moving to Avast Premier Security from whatever version you may have.  For example, re-deploying the same licenses for paid versions used before require a valid and good internet connection to transition to APS, but if you're not connected, well....it's not going to happen. And the bug, while not common, is still there and would seem to show mostly on clean installs, as here.  Overlays should be affected less.
Windows 10 Home 64-bit 20H2 Avast Premier Security version 21.3.2459 (build 21.3.6164.652) UI version 1.0.612.

Offline zwipp

  • Newbie
  • *
  • Posts: 6
Re: Avast Blocking Web Browsing
« Reply #10 on: August 22, 2019, 03:26:25 AM »
Did you try the above?  You may have to turn Real Site off for a moment, wait a bit, and then back on.  What Real Site does is set the DNS Server used by Avast and by extension your internet connection..."Checking for install conditions" will modify your network connections if you choose the second option.

I did try to turn it off and then back on after waiting a bit, but it didn't do anything.
Not too long after trying that Avast acted up and totally blocked off my internet access, after turning "Avast shields control" off for 10 minutes I managed to get my internet back, but Avast crashed shortly after...

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72794
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Blocking Web Browsing
« Reply #11 on: August 22, 2019, 05:16:16 AM »
Follow instructions: https://support.avast.com/article/33/ and post your File-ID here afterwards.
Win 8.1 [x64] - Avast PremSec 21.10.6772.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.3 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline zwipp

  • Newbie
  • *
  • Posts: 6
Re: Avast Blocking Web Browsing
« Reply #12 on: August 23, 2019, 09:35:51 PM »
Follow instructions: https://support.avast.com/article/33/ and post your File-ID here afterwards.

Is this supposed to take hours to complete? It's been going for 40 minutes and it's not even at 10%.  ???



edit:
After waiting about 3h for it to complete and not get further then 30% I'll have to stop, because I need to shut the computer off for the day...
It can't be ment to take over 6 hours to complete, can it?
« Last Edit: August 23, 2019, 11:48:15 PM by zwipp »

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72794
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Blocking Web Browsing
« Reply #13 on: August 24, 2019, 05:06:44 AM »
It can't be ment to take over 6 hours to complete, can it?
Nope, it should only take a few minutes.
Win 8.1 [x64] - Avast PremSec 21.10.6772.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.3 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline vojtech.vobr

  • Avast team
  • Newbie
  • *
  • Posts: 1
Re: Avast Blocking Web Browsing
« Reply #14 on: August 26, 2019, 10:59:04 AM »
Can you please provide dump of AvastSvc service at the moment your web doesn't work?

1. Disable Self Defense in Troubleshooting settings
2. Use Task Manager to create dump file of the AvastSvc.exe service (available in context menu of given process)
3. Upload dump to our FTP with some unique name, you can send me the name in PM - https://support.avast.com/en-in/article/FTP-file-upload

Thank you