Author Topic: Outlook Plugin Error [?log@clog@@... could not be located...]  (Read 11794 times)

0 Members and 1 Guest are viewing this topic.

nathanhaigh

  • Guest
Outlook Plugin Error [?log@clog@@... could not be located...]
« on: January 14, 2004, 09:27:29 AM »
I have been using avast quiet successfully over the past several months. I started with a demo version of avast, and then entered a free serial number i obtained from avast. Around this time i started to experience problems with the plugin to outlook, namely errors are displayed during outlook startup, and avast nolonger scans my e-mails. I've had a bit of a poke around the avast and outlook settings, and i noticed that avast is supposted to uses the ip address 127.0.0.1 to route e-mails through. I have also recently installed apache web server to my machine, which also uses this ip address....could this be the source of my problems? Can i change the ip address that avast uses?

Setup:
WinXP Pro SP1, plus some updates (may not be very recent...been busy lately)
Outlook2002 SP2
Apache Web serever also working on 127.0.0.1

Error Messages:
"The proceedure entry point ?log@clog@@.....etc could not be located in the dynamic link library aswCmnB.dll"
"Avast: Unable to connect to the avast engine. Asats mail protection cannot be started"
"The addin "<avast path>AshOutXt.dll" could not be installed or loaded. This problem may be resolved by using detect and repair on the help menu. Unable to load "<avast path>AshOutXt.dll" You may be out of memory, out of system resources, or missing a .dll file."

I have done detect and repair of both outlook and avast, done a uninstall/reboot/remove avast dir/reinstall of avast. and still get the same error. Even after and uninstall of avast, i can still see the avast plugin in the plugin manager of outlook.

Any help would be appreciated!
Nathan
« Last Edit: January 26, 2004, 06:15:10 PM by Vlk »

sedina

  • Guest
Re:Outlook Plugin Error
« Reply #1 on: January 14, 2004, 05:55:10 PM »
Hi, try to find extend.dat on your disk and delete it. Outlook uses this file for storing some data about plugins. pavels

zippy 2004

  • Guest
Re:Outlook Plugin Error
« Reply #2 on: January 23, 2004, 02:56:30 AM »
 :(

I to have encountered the same error as nathanhaigh with regards to this outlook error;

Error Messages:
"The proceedure entry point ?log@clog@@.....etc could not be located in the dynamic link library aswCmnB.dll"
"Avast: Unable to connect to the avast engine. Asats mail protection cannot be started"
"The addin "<avast path>AshOutXt.dll" could not be installed or loaded. This problem may be resolved by using detect and repair on the help menu. Unable to load "<avast path>AshOutXt.dll" You may be out of memory, out of system resources, or missing a .dll file."

I have deleted the 'extend.dat' file that you suggested, but to no avail. I also noticed that if I search again after restarting my machine it appears again with the current date in the 'Created On' section?

Any help would be appreciated as I am eager to protect my mail.

Many thanks in advance.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Outlook Plugin Error
« Reply #3 on: January 23, 2004, 08:07:25 AM »
Guys, what version of avast do you have, exactly?
The latest version is 4.1.335 and should not exhibit this problem...
If at first you don't succeed, then skydiving's not for you.

zippy 2004

  • Guest
Re:Outlook Plugin Error
« Reply #4 on: January 23, 2004, 11:40:52 AM »
I am running version 4.1.335?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Outlook Plugin Error
« Reply #5 on: January 23, 2004, 12:00:55 PM »
1. Can you post a screenshot?
2. Can you check the version of the file aswCmnB.dll (located in the avast folder). Right-click it in explorer, choose Properties and move to the Version tab. Does it show 4.1.334?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

zippy 2004

  • Guest
Re:Outlook Plugin Error
« Reply #6 on: January 23, 2004, 03:34:51 PM »
I have attached a screenshot as requested for the main error that appears first.

I do get a second message saying 'Avast unable to connect to Avast engine. Avast mail protection cannot be started'

Followed by a third error message saying 'The add-in "C:\Program Files\Alwil Software\Avast4\ashOutXt.dll" could not be installed or loaded. This problem may be resolved by using Detect and Repair on the Help menu. Unable to load "C:\Program Files\Alwil Software\Avast4\a...". You may be out of memory, out of system resources, or missing a .dll file.

I have also checked the 'aswCmnB.dll' file and it says that it is version number 4.1.304.0? - Although I have downloaded the latest version and this is confirmed if I try and download again?

Jaco

  • Guest
Re:Outlook Plugin Error
« Reply #7 on: January 26, 2004, 11:32:20 AM »
Is this problem solved yet? I get the same error but would like to protect my e-mail with Avast...

Kind regards,

Jaco.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Outlook Plugin Error
« Reply #8 on: January 26, 2004, 11:54:31 AM »
Hmmmm... ???

Why does the file have version 304???
You did a clean install, right?

I just tried a clean install of version 4.1.335, and the file aswCmnB.dll has version 4.1.334 (as expected).

You can try to uninstall the current version, download the latest version from our website ( e.g. http://download1.avast.com/iavs4pro/setupeng.exe ) and install that.

It should definitely work.

Also, make sure Outlook hasn't disabled the plugin - Outlook About Box -> Disabled Items.

Vlk
If at first you don't succeed, then skydiving's not for you.

Jaco

  • Guest
Re:Outlook Plugin Error
« Reply #9 on: January 26, 2004, 01:29:28 PM »
Nah. I just uninstalled the software, manually removed the remaining folders, and downloaded it again at http://download1.avast.com/iavs4pro/setupdut.exe. Still not the right version.

(also tried the english version, same there...)

Kind regards,

Jaco.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Outlook Plugin Error
« Reply #10 on: January 26, 2004, 03:20:24 PM »
Jaco, you seem to understand computers well... Could you please

1. try to search the file aswCmnB.dll for the string ?log@CLog@@QAAKHKGPADQAEKZZ .
2. if the string is not present in the file, send the file to my email address

?

Thanks
Vlk

PS. Hey you play Mafia? ;D Cool...
« Last Edit: January 26, 2004, 03:21:08 PM by Vlk »
If at first you don't succeed, then skydiving's not for you.

Jaco

  • Guest
Re:Outlook Plugin Error
« Reply #11 on: January 26, 2004, 03:36:04 PM »
Searched the file. The string is present.

I mailed you the file anyway.

Kind regards,

Jaco.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Outlook Plugin Error
« Reply #12 on: January 26, 2004, 03:44:31 PM »
Thanks. The file is OK.

One more thing - please do a search of all local disks for the file (aswCmnB.dll).
If there are multiple copies of the file, it's not good. The only one that you should have is the one in the avast folder.
If at first you don't succeed, then skydiving's not for you.

Jaco

  • Guest
Re:Outlook Plugin Error
« Reply #13 on: January 26, 2004, 04:03:04 PM »
Found the same file in the windows\system\ folder. Version 4.1.259.0. I deleted the file but the problem persists.

Kind regards,

Jaco.

zippy 2004

  • Guest
Re:Outlook Plugin Error
« Reply #14 on: January 26, 2004, 04:23:29 PM »
I have also tried a clean install and I also found a duplicate 'aswCmnB.dll' file in the Windows\Systems folder, which I have deleted and now the first error: 'The procedure error point  ?log@CLog@@QAAKHKGPADQAEKZZ could not be located....' has disappeared, but I still have the error:  "Avast: Unable to connect to the avast engine. Asats mail protection cannot be started" followed by error message saying 'The add-in "C:\Program Files\Alwil Software\Avast4\ashOutXt.dll" could not be installed or loaded. ?????