Author Topic: Is anyone else having issue with Avast on macOS Catalina?  (Read 6768 times)

0 Members and 1 Guest are viewing this topic.

Offline stamatgeorge

  • Newbie
  • *
  • Posts: 1
Is anyone else having issue with Avast on macOS Catalina?
« on: October 31, 2019, 11:30:56 PM »
Is anyone else having issue with Avast on macOS Catalina?

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 905
  • Product manager of Mac AV and Cleanup
Re: Is anyone else having issue with Avast on macOS Catalina?
« Reply #1 on: November 01, 2019, 03:59:32 PM »
Is anyone else having issue with Avast on macOS Catalina?

what is exactly the issue? There are two actions that are required from user to make to run the product run on 100%
1) allow System software from developer "AVAST Software a.s."  in Security&Privacy > General.  This step is necessary from macosx 10.13 High Sierra to enable kernel extensions (aka KEXT) that are necessary for file, web and mail shield. Without it the realtime protection won't work. But you can still use the other features like scans, Wi-Fi Inspector. More details in the FAQ - https://support.avast.com/en-eu/article/Mac-Security-High-Sierra-allow-extensions
2) enabling Full Disc Access from macosx 10.15 Catalina. This will allow access to your home directory. If you don't allow it the the AV cannot protect these parts of your hard drive. They are not protected by file or ransomware shield. And these parts of your hard drive cannot be scanned by any scan as the operating system won't allow Avast to access them. More details - https://support.avast.com/en-eu/article/Mac-full-disk-access

Anyway - more details about your issue may help to resolve it.
Quality is also a feature.

Offline Michael Dodd

  • Newbie
  • *
  • Posts: 2
Re: Is anyone else having issue with Avast on macOS Catalina?
« Reply #2 on: November 02, 2019, 10:42:50 PM »
Is anyone else having issue with Avast on macOS Catalina?

I'm having an issue.  Avast slows everything down.  I have a brand new iMac 2019 with SSD and when it first boots up, apps open almost immediately before AVAST is installed.  Once Avast is installed they bounce like 6 times before they open.  Also screen draws are slower when windows are first opened.  Once an app is opened however, it's fast to re-open once it's in cache.  Slowness is the only issue.  I tried for fun Avira and Sophos and they are even slower.  I tried the free trial of Intego Virus Barrier and it doesn't slow down anything on my iMac.  it's definitely something to do with the way these free program versions are accessing information on hard drives or in my case an SSD.  It creates some kind of Bottle neck.  I hope Avast can acknowledge this and come up with a fix. I'm tempted to pay the yearly rate for Intego and see if Avast fixes it.

Yes I'm running Mac OS Catalina.  Avast never slowed anything down on my previous computer in Mac OS Mojave.  I'm using the free version of Avast so I know they probably won't offer support but if it's insanely slow surely there's something they can do.

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 305
Re: Is anyone else having issue with Avast on macOS Catalina?
« Reply #3 on: November 04, 2019, 02:24:47 PM »
I'm using the free version of Avast so I know they probably won't offer support
While there is no guarantee, there is a very high chance an actual developer will eventually see your post on Mac AV portion of the forum. There is also a chance that they will react. This chance is higher than it would seem from reading the forum, as this reaction often takes form of an email directly to the person posting about the issue. The forums is for us an important channel to get feedback about our product.

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 305
Re: Is anyone else having issue with Avast on macOS Catalina?
« Reply #4 on: November 06, 2019, 05:03:53 PM »
OK, the issue Michael Dodd experiences is a general issue with quite a large slowdown of Microsoft apps, and is not connected with Catalina.

To explain a reason why there even is a slowdown, IMO the most important aspect of Antivirus app are the active shields. The most important of them is File Shield. This is a process which hooks into MacOS system and whenever something accesses a file, it verifies that it is not infected. Of course, it decides what to do based not only on the content of the file, but also on the way it is opened and on the app that is opening it, etc., and unless the file is changed it tries to remember the result. Presence of such shields is why there is a general slowdown caused by nearly all antivirus applications. The slowdown is the largest just after restart, as everything needs to be rechecked again instead of reusing old results. And when a behemoth of an app like some of MS apps starts, it opens a LOT of files.

I will forward the MS app issue to our virus lab team, hopefully they will be able to improve the performance.
« Last Edit: November 06, 2019, 05:06:12 PM by ondrej.kolacek »

Offline Michael Dodd

  • Newbie
  • *
  • Posts: 2
Re: Is anyone else having issue with Avast on macOS Catalina?
« Reply #5 on: November 07, 2019, 04:10:03 AM »
OK, the issue Michael Dodd experiences is a general issue with quite a large slowdown of Microsoft apps, and is not connected with Catalina.

This is not entirely true.  it affects all apps (not just MS) as they all open slower and the screen icon draws when I open Catlina are slower.  It really affects Opening apps the first (after they are in cache it doesn't bother them) and drawing of new windows when first opened. 

Thank you for checking into this however, I will keep checking the post.

Offline yeppoon

  • Newbie
  • *
  • Posts: 1
Re: Is anyone else having issue with Avast on macOS Catalina?
« Reply #6 on: June 06, 2020, 01:36:22 AM »
This is not entirely true.  it affects all apps (not just MS) as they all open slower and the screen icon draws when I open Catlina are slower.

I have an older MacBookPro. I upgraded to Catalina and after install I was so impressed with Catalina, I made it my Primary partition to boot to. Not only did Avast slow down my system, it made it almost unusable from start up, every single app, the entire system, and added 1 minute to ready, longer than before I installed Avast. Not only that, after I uninstalled Avast, it left a residual slowness which is aggravating, like the apps bouncing when starting 6 times or more, every single App and Entire system bogged in the mud with the wheels spinning, looking for traction. Absolutely hopeless and I am being kind, because now, I ave to reinstall Catalina to be rid of the residual slowness, which will take all day.

Before my bad experience, Catalina was "blindingly fast", blink and you would miss any task, right now, before re install, it is like a slug and I hate the entire MacBook Pro, and want to throw it through the window.