Author Topic: Secondary AvastUI exe  (Read 310 times)

0 Members and 1 Guest are viewing this topic.

Offline Pierogi

  • Newbie
  • *
  • Posts: 7
Secondary AvastUI exe
« on: November 11, 2019, 12:28:42 AM »
Hi. I have noticed that since yesterday, after some time of OS startup, like 30 minutes to 1,5 hour, a secondary AvastUI.exe process is launching without reason. There were no any pop-ups and I'm not opening UI manually. It was happening only when I was opening UI manually or pop-up showed up, now it's happening by itself just like that. Any suggestions what it could be, is it normal behaviour?

Offline Armel_08

  • Sometimes I'm active on this board, and sometimes I'm not.
  • Newbie
  • *
  • Posts: 9
Re: Secondary AvastUI exe
« Reply #1 on: November 11, 2019, 05:11:21 AM »
I'm pretty sure that is normal. If you really want to be safe though so you can make sure if the secondary program isn't a virus, go to the task manager, right-click on the avast processes, then select "Open File Location" and both processes should be in This PC > Local Disk > Program Files > AVAST Software > Avast (assuming you installed Avast on your main drive). If it's not in that path, it could be a different process, or if it's in a weird location like System32 or something like that, there might be a possibility of a virus that's posing as Avast. Don't worry, it's most likely just a separate Avast process :)
It's okay to be paranoid about your security, as long as you're protected!

Offline Pierogi

  • Newbie
  • *
  • Posts: 7
Re: Secondary AvastUI exe
« Reply #2 on: November 11, 2019, 10:20:52 AM »
Process path directory leads to the original Avast folder, like the main AvastUI process that is launching always, and it's even pointing the same exe file. I can even say that this process is the same as the one when is launching (with the same command prompt) when I open UI manually or have a pop-up about the product. I can't really say it could be a virus or something like that, because I'm not installing any weird things from unknown sources since never. The last program I have installed was Avast, like a month ago. I'm not even visiting unsafe/unknown sites, I'm not clicking on ads, not running weird exe or bat files. Yet I'm still wondering what it could be, because it wasn't happening by itself before till two days ago. And if someone noticed that as well.

Also the command line of this process in task manager points to some log file in AppData\Roaming\Avast Software\Avast\log\ folder
But at the end of the command line it says: Log severity error (if that matters).
« Last Edit: November 11, 2019, 10:24:38 AM by Pierogi »

Offline Armel_08

  • Sometimes I'm active on this board, and sometimes I'm not.
  • Newbie
  • *
  • Posts: 9
Re: Secondary AvastUI exe
« Reply #3 on: November 11, 2019, 10:45:56 PM »
I don't think it's a virus, it could be that a new update came and for some reason, AvastUI opens twice. The logging severity error I don't know. I have to research about it myself. Just asking, does it say Logging severity with a colon at the end or with no colon?
It's okay to be paranoid about your security, as long as you're protected!

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 82189
  • No support PMs thanks
Re: Secondary AvastUI exe
« Reply #4 on: November 11, 2019, 11:07:59 PM »
Having more than on Avastui.exe isn't a problem and has been that way for a little time, a few program updates ago.  Mostly it related to the Avast Tray icon and the actual User Interface, but there are other times that it is in use. 

Though as an avast user, I simply don't know them all, but there are many such topics relating to multiple instances of avastui.exe in the forums.

As far as Logging severity is concerned, I believe the Log severity error means only log errors and nothing below that level.  Users could change that in the various Shield settings > Report File.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4793.541) UI-1.0.415/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Pierogi

  • Newbie
  • *
  • Posts: 7
Re: Secondary AvastUI exe
« Reply #5 on: Yesterday at 11:50:19 AM »
I tried to enable silent mode and left OS to work for long hours, and secondary UI exe stopped launching itself by now. My thought are that it was a pop-up that was attempting to active, but it was crashing, or something like that. And as far as I know, in silent mode pop-ups are not showing.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 82189
  • No support PMs thanks
Re: Secondary AvastUI exe
« Reply #6 on: Yesterday at 12:39:43 PM »
Correct, in silent mode popups/alerts are silent/no show.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4793.541) UI-1.0.415/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/