Author Topic: Core Shields Off - Macbook Pro - No Allow Button on Install  (Read 2175 times)

0 Members and 1 Guest are viewing this topic.

Offline tphilis

  • Newbie
  • *
  • Posts: 1
Core Shields Off - Macbook Pro - No Allow Button on Install
« on: December 28, 2019, 02:08:23 AM »
Hi,

I am running Avast Premium Security version 14.3 and the core shields are off with error: "We're sorry. There is some kind of problem on our side. We'll fix it as soon as possible." When installing there was no "Allow" button displayed in the Security and Privacy dialog. I've uninstalled and reinstalled. Also updated from High Sierra to Catalina. Still exactly the same behavior.

What next? I see this problem in the forums but no solution.

Thanks

Offline lukas.hasik

  • Avast team
  • Advanced Poster
  • *
  • Posts: 928
  • Product manager of Avast Security for Windows
Re: Core Shields Off - Macbook Pro - No Allow Button on Install
« Reply #1 on: December 28, 2019, 07:50:21 PM »
Unfortunately, we probably don't have an answer :( We are using the API provided by Apple to request the kext installation. we have seen and also reported several cases when the button either didn't appear or couldn't be clicked to allow the kexts. The ALLOW button in Security&Privacy should be visible for 30 minutes after an app tries to load the kext (according to Apple docs). Try to restart your Mac, please. Some users reported that the issue magically resolved or disappeared after several restarts.

Hi,

I am running Avast Premium Security version 14.3 and the core shields are off with error: "We're sorry. There is some kind of problem on our side. We'll fix it as soon as possible." When installing there was no "Allow" button displayed in the Security and Privacy dialog. I've uninstalled and reinstalled. Also updated from High Sierra to Catalina. Still exactly the same behavior.

What next? I see this problem in the forums but no solution.

Thanks
Quality is also a feature.