Author Topic: avast email scanner...???  (Read 7926 times)

0 Members and 1 Guest are viewing this topic.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3870
  • Just an avast user
Re: avast email scanner...???
« Reply #15 on: August 31, 2006, 08:25:44 AM »
Yes the location is correct.

Is there a concern that prevents you allowing us to see the log?

raemi00

  • Guest
Re: avast email scanner...???
« Reply #16 on: August 31, 2006, 09:35:00 AM »
08/30/06 19:26:38 00000F94:   Started as service, Log = 1
08/30/06 19:26:38 00000F94:   Build 4.7.871
08/30/06 19:26:38 00000F94:   Windows XP Workstation (Service Pack 2)
08/30/06 19:26:38 00000F94:   Using WinSock 2.0
08/30/06 23:25:23 00000CB4:   Cannot connect to IMAP server 124.120.234.103
(124.120.234.103:143), connect error 10061

This is the log; like I said, not whole lot to go on.
« Last Edit: September 01, 2006, 10:26:34 PM by raemi00 »

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3870
  • Just an avast user
Re: avast email scanner...???
« Reply #17 on: August 31, 2006, 09:47:04 AM »
Ah, as it says at the top of the log .... Log=1

I asked you to enter Log=20 not log=20

Sorry I did not notice it earlier.


raemi00

  • Guest
Re: avast email scanner...???
« Reply #18 on: August 31, 2006, 10:40:36 AM »
Log=20, it is then.
I'll change and see if this will help solve the problem.
Thanks for your assistance.

raemi00

  • Guest
Re: avast email scanner...???
« Reply #19 on: September 01, 2006, 05:34:35 PM »
Well, i've got another one and this time Log=20 is set correctly.

08/31/06 13:12:40 00000EC4:   Started as service, Log = 20
08/31/06 13:12:40 00000EC4:   Build 4.7.871
08/31/06 13:12:40 00000EC4:   Windows XP Workstation (Service Pack 2)
08/31/06 13:12:40 00000EC4:   Using WinSock 2.0
09/01/06 11:14:57 00000ABC:   PATH: \Device\HarddiskVolume2\Program Files\Tor\tor.exe
09/01/06 11:15:14 00000ABC:   Cannot connect to POP server 210.197.251.212 (210.197.251.212:110), connect error 10061
09/01/06 11:15:14 00000ABC:   sent 94 (440)
09/01/06 11:15:14 00000ABC:   --POP Finishing connection handler

So, what do you think?
« Last Edit: September 01, 2006, 10:26:05 PM by raemi00 »

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3870
  • Just an avast user
Re: avast email scanner...???
« Reply #20 on: September 01, 2006, 08:32:32 PM »
As you have probably guessed - you have found it. 

You did mention earlier that you user Tor/Vidalia as a web anonymizer.  I guess I should not have made assumptions about how Tor works.

Tor operates a bit like P2P clients, the folks who run Tor servers decide what port they will listen on and (as often happens with P2P) they choose a well-known email port since they know the server will not be running as an email server and the port will work for them.  They then tell Tor users to connect to their server on that well-known port.  This is, of course, all under the covers to you and so once in a while you connect to a Tor server on a port that is monitored by the avast Internet Mail Scanner and it shows up in the systray. It most likely also disrupts the Tor connection that is being attempted.

The solution is to edit the avast4.ini file and in the section headed:

[MailScanner]

add a line:

IgnoreProcess=tor.exe

avast will then ignore use of the ports it intercepts when made by Tor.


I will also drop a note to the avast team suggesting that they add Tor to their list of automatic exclusions so that the next Tor user along doesn't have to work out the issue again.
« Last Edit: September 01, 2006, 08:36:46 PM by alanrf »

raemi00

  • Guest
Re: avast email scanner...???
« Reply #21 on: September 01, 2006, 08:57:17 PM »
Yup. I was pretty sure I didn't have any malware imbedded in my pc. But like I also said, you can never be sure.
Thanks for answering my question. I really appreciated it. Also glad I helped avast little bit about tor. Thanx again!