Author Topic: [U3] fatal error:language dll not found  (Read 24193 times)

0 Members and 1 Guest are viewing this topic.

Offline zul

  • Newbie
  • *
  • Posts: 1
[U3] fatal error:language dll not found
« on: August 27, 2006, 04:30:36 PM »
sorry if this is the wrong section for my post since i couldn't find topic for avast u3 version. the avast version i'm using is preinstalled in my drive.i'm using sandisk cruzer.
the problem is whenever i tried to run,avast couldn't run properly and this message occur:
Quote
Fatal error:language  DLL (u3lang.dll) was not found. Please reinstall the program to correct my problem.

how i can solve this problem?
can i just reinstall again like normal u3 application?
if i reinstall using trial version installer(which download from avast) is that the current one is the trial version or not?
« Last Edit: August 28, 2006, 11:12:47 AM by Vlk »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: fatal error:language dll not found
« Reply #1 on: August 28, 2006, 10:58:19 AM »
Please try the following:

1. uninstall Avast from the U3 launchpad.
2. go to http://www.avast.com/eng/download-avast-u3.html and install the latest version from our website.

The trial period should stay the same.


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline pkocsis

  • Newbie
  • *
  • Posts: 6
Re: [U3] fatal error:language dll not found
« Reply #2 on: October 04, 2006, 10:26:50 PM »
I have the same problem.....ERROR, u3lang.dll not found!  It only happens on one of my machines.  Avast loads fine on all others.   I have tried to un-install then re-install avast, but the same thing still occurs....any other ideas?

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11786
    • AVAST Software
Re: [U3] fatal error:language dll not found
« Reply #3 on: October 05, 2006, 11:22:40 AM »
Did the error appear right after the installation (when you plugged the device for the first time)?
If, after avast! reinstallation, you plug the device without being connected to the Internet (i.e. without avast! having the chance to update itself) - does the error appear as well?

Offline pkocsis

  • Newbie
  • *
  • Posts: 6
Re: [U3] fatal error:language dll not found
« Reply #4 on: October 06, 2006, 07:11:23 PM »
No, it worked fine for about 1 month, then just started to fail at avast launch.  It works fine on every other machine I've tried, it just won't launch on my laptop.  Even after uninstall/re-install, it works great on all other machines I've tried except my laptop!

Also, I pulled my internet access and inserted my U3 device....same thing....launchpad saying that "there was an error launching the U3 application"....any other ideas on what I can do to get this fixed?

Thanks!

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: [U3] fatal error:language dll not found
« Reply #5 on: October 06, 2006, 10:00:07 PM »
Please check if the %TEMP% environment variable is set correctly.
If at first you don't succeed, then skydiving's not for you.

Offline pkocsis

  • Newbie
  • *
  • Posts: 6
Re: [U3] fatal error:language dll not found
« Reply #6 on: October 07, 2006, 08:37:22 PM »
My TEMP directory is perfectly fine.  It is set at:

C:\DOCUME~1\Paul\LOCALS~1\Temp

...and that directory exists....

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: [U3] fatal error:language dll not found
« Reply #7 on: October 08, 2006, 07:23:24 PM »
In this case, it might be useful to post the contents of the files *.log (there should be two of them) in the folder

C:\Documents and Settings\paul\Application Data\U3\<some numbers>\1F30627F-0195-44d4-8C24-1999F3C02C50\Exec

(they should exist when the "Fatal error" message is on the screen)


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline pkocsis

  • Newbie
  • *
  • Posts: 6
Re: [U3] fatal error:language dll not found
« Reply #8 on: October 08, 2006, 08:38:13 PM »
With the error dialog up, there are no log files in the Exec folder.  The only 2 files in the Exec folder are applications, namely avu3_upd and AvU3Launcher.  Please also note that the error dialog does not look like an avast dialog, it looks more like a generic U3 LaunchPad dialog.  I have attached a jpeg of the actual error dialog.

Again, to re-iterate, this only happens on my laptop.  All other machines (that I've inserted my U3 device into) launch avast just fine.....

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: [U3] fatal error:language dll not found
« Reply #9 on: October 08, 2006, 10:20:18 PM »
Well, this is not the dialog I meant. I meant the "Fatal error" dialog, that should indeed look like an Avast U3 Edition message box.
If at first you don't succeed, then skydiving's not for you.

Offline pkocsis

  • Newbie
  • *
  • Posts: 6
Re: [U3] fatal error:language dll not found
« Reply #10 on: October 10, 2006, 07:15:18 AM »
OK, Sorry....in order to get the "Error" dialog ("Fatal error: Language DLL (u3lang.dll) was not found. Please reinstall the program to correct the problem") I do the following:

1. Insert the U3 device
2. open a cmd window and issue the following set commands:

set U3_HOST_EXEC_PATH=C:\Documents and Settings\Paul\Application Data\U3\<my u3 device number>\1F30627F-0195-44d4-8C24-1999F3C02C50\Exec
set U3_APP_DATA_PATH=G:\System\Apps\1F30627F-0195-44d4-8C24-1999F3C02C50\Data
set U3_DEVICE_EXEC_PATH=G:\System\Apps\1F30627F-0195-44d4-8C24-1999F3C02C50\Exec

...then I issue the command:

cd %U3_HOST_EXEC_PATH%

and then I issue:

AvU3Launcher

This is when I get the avast window which says "Initializing" and immediately receive the "Error" dialog.   With this error dialog up, I go to the Exec folder you previously mention, and there are no log files....in fact, there's 3 files there, namely:

AvU3Launcher.exe
avu3_upd.exe
setup.exe

The "setup.exe" was NOT there before I issued the AvU3Launcer command stated above.....

Offline elwing

  • Newbie
  • *
  • Posts: 1
Re: [U3] fatal error:language dll not found
« Reply #11 on: December 15, 2006, 05:40:34 AM »
I got the same problem exactly like yours.

And I found maybe it was because some stunned process locked some file. I suffered this from a failed updating, for example.

I solved that problem by doing following steps:

1. Uninstall your avast! u3 edition, and completely delete "1F30627F-0195-44d4-8C24-1999F3C02C50" folder in your u3 device after your uninstallation.  it should be below "H:\System\Apps". better erase related info in LPDB.xml & LPGDB.xml.
2. unplug your U3 device.
3. reboot your system.
4. browse to "C:\Documents and Settings\YOUR NAME\Application Data" , and completely delete the whole "U3" folder.
5. plug your u3 device, reinstall avast!.

My English is poor, hope this can help you.
« Last Edit: December 15, 2006, 08:04:21 AM by elwing »

Offline ksav

  • Newbie
  • *
  • Posts: 5
  • Ho Ho!!!
Re: [U3] fatal error:language dll not found
« Reply #12 on: January 03, 2007, 10:08:43 AM »
Hi,

I also had the same issue with a failed update.  I've tracked this down to me putting M$ EFS on certain
directories, i.e.
My Docs
Temp Internet
Desktop
etc..

The issue is when the automated update starts, it downloads to one of %temp% encrypted areas, Avast then tries to move the downloaded updates to another 'unencrypted' area and fails.  This is because the OS would normally issue a warning dialog box which requires human intervention, at this point the whole process fails.  Q: would it be possible to issue a CMD line command to place the updates somewhere other than the default?

Cheers

Offline Tarkin

  • Newbie
  • *
  • Posts: 2
Re: [U3] fatal error:language dll not found
« Reply #13 on: July 22, 2007, 07:28:17 AM »
I have had the same error (Fatal error:language  DLL (u3lang.dll) was not found).

Is it possible that that occurs after an unsafe removal of the U3 USB flash disk?

PS: can this be solved by reinstalling the u3lang.dll in its original location, on the pc which has reported the error message?

PS(2): Before safely removing my U3 flash disk, it has made an automatic scan of my PC, and also detected 8 malwares (among them the libsys.exe, and lasass.exe from the system 32 folder). And, out of the 8, 7 were wemoved.
« Last Edit: July 22, 2007, 07:38:02 AM by Tarkin »

Offline Gryphone

  • Newbie
  • *
  • Posts: 1
Re: [U3] fatal error:language dll not found
« Reply #14 on: May 08, 2008, 03:45:31 PM »
I'm a newbie in the forum, faced the same problem, and since the conversation ends without concrete solution, so this might help because I think I found the solution to this.

This problem occurs after an unsuccessful updating process, whether the automatic update when the Avast! U3 loads, or when it's done manually through the program console. I experienced the problem because the internet connection here is SO BAD, it disconnects randomly from every 5 hour, to every 2 minutes. Everytime I failed downloading the update, the Avast program failed to load afterwards.

So I tried to simulate the disconnection by going to a very good hotspot with an excellent connection, update the Avast, and interrupt the process by disabling the wifi device . . . the same problem came. I tried it once more : Reinstalling it, putting in the license key, update it and interrupt the process. Same thing. So I tried to reinstalled it again, and updated it without interruption. No problem. And the next two days, I went back to the hotspot, update and interrupt it again, same problem came back. So I conclude, it is the interrupted updating process. So guys, when you want to update the virus definitions, you might consider to find a good internet connection, or else, you have to download the 31 megs of initial update all over again. With a T1 connection, it should be no problem . . . but those with dial-ups, it's hell :))