Author Topic: Avast and Xilinx Vivado simulator  (Read 1095 times)

0 Members and 1 Guest are viewing this topic.

Offline Gordon53

  • Newbie
  • *
  • Posts: 6
Avast and Xilinx Vivado simulator
« on: January 28, 2020, 01:04:21 AM »
Hi
I am having problems with Avast when I run the Xilinx Vivado simulator. Avast sends me a message that it is checking the simulator when it starts running and then comes back with no issues. However, the simulator never ends and cant be stopped. I have to kill the program and reboot the PC. The only way to make it work is to turn off all the Avast shields before running the simulator. Can anyone assist with fixing this issue?

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 67480
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast and Xilinx Vivado simulator
« Reply #1 on: January 28, 2020, 05:19:10 AM »
You can report a suspected FP (File/Website) here: https://www.avast.com/false-positive-file-form.php
Win 8.1 [x64] - Avast PremSec 20.9.2435.Beta#3 [UI.578] - CC 5.73 - EEK - FF ESR 78.4 [NS/AOS/uBO/PB] - TB 78.4 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Gordon53

  • Newbie
  • *
  • Posts: 6
Re: Avast and Xilinx Vivado simulator
« Reply #2 on: January 28, 2020, 09:15:12 AM »
Hi, it is not a false positive, it just hangs my program.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 67480
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast and Xilinx Vivado simulator
« Reply #3 on: January 28, 2020, 09:15:45 AM »
Well, report it anyway.
Win 8.1 [x64] - Avast PremSec 20.9.2435.Beta#3 [UI.578] - CC 5.73 - EEK - FF ESR 78.4 [NS/AOS/uBO/PB] - TB 78.4 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline rocksteady

  • Advanced Poster
  • **
  • Posts: 893
Re: Avast and Xilinx Vivado simulator
« Reply #4 on: January 28, 2020, 03:31:36 PM »
@Gordon53,
You didn't mention which Avast product you are using. If you are using Avast Premium and Avast Firewall, have you tried setting Avast Firewall to Private and Restart.

Offline Gordon53

  • Newbie
  • *
  • Posts: 6
Re: Avast and Xilinx Vivado simulator
« Reply #5 on: January 28, 2020, 10:46:58 PM »
@rocksteady
Thanks for your reply. I am using Avast Premium and Avast Firewall. The Avast Firewall is already set to private. The issue happens when I run my application. Avast halts it while it scans it, then when it gives the OK the app doesnt recover. Killing the application and restarting it doesnt help as the application says that files are locked. Only a reboot, turning off the shields and restarting the app will fix the issue.

Offline Gordon53

  • Newbie
  • *
  • Posts: 6
Re: Avast and Xilinx Vivado simulator
« Reply #6 on: January 30, 2020, 01:28:28 AM »
For anyone who is interested I have had to make an exception for the file xsimk.exe in my current project directory. Once that's done everything works as it should.

Offline Gordon53

  • Newbie
  • *
  • Posts: 6
Re: Avast and Xilinx Vivado simulator
« Reply #7 on: February 13, 2020, 11:43:28 PM »
Again, for anyone interested, it is the file shield that is causing the issue.

Offline rocksteady

  • Advanced Poster
  • **
  • Posts: 893
Re: Avast and Xilinx Vivado simulator
« Reply #8 on: February 14, 2020, 04:08:04 PM »
You can report a suspected FP (File/Website) here: https://www.avast.com/false-positive-file-form.php
Did you actually report a false positive to Avast as suggested by Asyn?
That would have got their attention.

Offline Gordon53

  • Newbie
  • *
  • Posts: 6
Re: Avast and Xilinx Vivado simulator
« Reply #9 on: February 17, 2020, 11:18:37 AM »
Yes, I did report a false positive. They have responded with an email and asked me to see if I could work out which shield is causing the problem which I have done.