Author Topic: Help! Avast is blocking my Internet!  (Read 2452 times)

0 Members and 1 Guest are viewing this topic.

Nadir

  • Guest
Help! Avast is blocking my Internet!
« on: August 31, 2006, 08:48:54 AM »
I used Avast Home since a couple of  months now, and reported no problems.
I don't know if it is linked, but last week I set Zone Alarm to "Engage Internet Lock" (which I seldom do, and probably not since I use avast) and the reverted to normal, but afterwards was not able to browse the web AND send/receive email with OE.
By googling around, I found that disabling "AshWebSv.exe" e "AshMaiSv.exe" through Task Manager all works again...by the way, disabling those services through the avast interface don't solve the problem.
avast has all the permission to work through ZA, and anyway the problem persists even when shutting ZA down, so it's not a firewall fault.
I fisically deleted the two exe from avast folder and reinstalled them though the repair utility, but again the proble  resurfaced...any suggestion?
If I browse or use mail with those two services shutted  down, what risks I run into?
Thanx for your help

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87660
  • No support PMs thanks
Re: Help! Avast is blocking my Internet!
« Reply #1 on: August 31, 2006, 03:43:24 PM »
avast isn't blocking your internet connection, it doesn't have that function, it scans and if it finds infection it alerts you to it, it doesn't block. Something is blocking those two elements of avast and that is usually your firewall.

ZA has a habit of forgetting its permissions, even though it shows the effected programs as being allowed to connect. The best solution is to delete the entries in ZA for ashwebsv.exe and ashmaisv.exe, ZA will then ask again when you use them, answer Yes.

You would probably found this answer sooner by using the forums search function (button at the top of every page).
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.4.6062 (build 23.4.8118.762) UI 1.0.762/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Nadir

  • Guest
Re: Help! Avast is blocking my Internet!
« Reply #2 on: August 31, 2006, 05:28:31 PM »
I'm sure you're right about Avast FUNCTIONS, what I mean I got some sort of compatibility problem here...I tried your solution but not, it didn't work  :-[
Fact is, the connection is blocked even with ZA shutted down, and UNTIL I manually stop the ashWebSv service via Task Manager: at that point, the connection works with or without ZA active.
I could disinstall ZA and see what happens...do you think it could help?

...................................

OK, so it was definitely the firewall...I disinstalled and reinstalled it, and now everything works fine...probably ZA was so badly damaged it was not even going to shut down effectively, even if it pretended so...
Anyway, thanx for your help!
« Last Edit: August 31, 2006, 06:46:08 PM by Nadir »

Nadir

  • Guest
Re: Help! Avast is blocking my Internet!
« Reply #3 on: August 31, 2006, 06:53:13 PM »
OK, so it was definitely the firewall...I disinstalled and reinstalled it, and now everything works fine...probably ZA was so badly damaged it was not even going to shut down effectively, even if it pretended so...
Anyway, thanx for your help!

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 87660
  • No support PMs thanks
Re: Help! Avast is blocking my Internet!
« Reply #4 on: August 31, 2006, 07:45:24 PM »
Glad that the problem is resolved, welcome to the forums.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.4.6062 (build 23.4.8118.762) UI 1.0.762/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security