Author Topic: When Windows starts a red circle stays for 1 minute..  (Read 46957 times)

0 Members and 1 Guest are viewing this topic.

Offline RicardoB

  • Newbie
  • *
  • Posts: 13
Re: When Windows starts a red circle stays for 1 minute..
« Reply #45 on: September 15, 2006, 02:22:16 AM »
Vlk,

I have uploaded two files:

>> RicardoB_ashServ_with_red_Circle.zip
I believe I got it right because it was right when I saw the "ashServ.exe" process running. Did I ?
The red Circle dissapeared just a few seconds after I run it.

>> RicardoB_ashServ_after_red_circle_dissapears.zip
(Just in case it helps for any reason.
The "ashServ.exe" process keeps running after Avast starts.)

I realized that "ashServ.exe" process takes a long time to appear in the Task Manager, and when it does, avast starts in a few seconds.

What is more strange is that during this "long time" no processes appear to use more than 1 percent of the processor. (99 percent CPU idle) Maybe a memory scanning or any memory procedure???

« Last Edit: September 15, 2006, 02:25:18 AM by RicardoB »

Offline drahnier

  • Full Member
  • ***
  • Posts: 173
Re: When Windows starts a red circle stays for 1 minute..
« Reply #46 on: September 15, 2006, 06:07:49 PM »
fwiw: I have the very same problem on two notebooks running vista rc1. on a 2processor Thinkpad the "delay" is 30sec, on a 1processor 1.2Ghz Sony it is almost 1 min.
_____________________
drahnier

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: When Windows starts a red circle stays for 1 minute..
« Reply #47 on: September 15, 2006, 06:22:28 PM »
drahnier, could you please check the status of the ashServ.exe process during the delay?

What is the duration of the period betwen ashServ.exe starting (i.e. first appearing in the Task Manager) and the red circle disappearing?

I.e. e.g. on the machine where it takes a minute to load, is ashServ.exe there for the whole minute, or only for a part of it?


Because so far it seems to me that ashServ.exe is not really hung, it just takes the system long time to load it! Maybe it's because it has a dependency on the RPC service which (under certain circumstances) loads slowly (?)


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re: When Windows starts a red circle stays for 1 minute..
« Reply #48 on: September 15, 2006, 07:32:34 PM »
Vlk

I'm thinking along the same thing.  My red circle does not disappear until after I have an internet connection.  With my cable modem and router the red circle disappears as soon as everything is online and able to access the Internet.  In my case that is taking about 15 seconds after the Avast icon appears in the task bar.  Avast may be trying to establish an internet connection and can't during that short time period?
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline drahnier

  • Full Member
  • ***
  • Posts: 173
Re: When Windows starts a red circle stays for 1 minute..
« Reply #49 on: September 15, 2006, 08:16:57 PM »
Vlk

I'm thinking along the same thing.  My red circle does not disappear until after I have an internet connection.  With my cable modem and router the red circle disappears as soon as everything is online and able to access the Internet.  In my case that is taking about 15 seconds after the Avast icon appears in the task bar.  Avast may be trying to establish an internet connection and can't during that short time period?

If this is the case, wouldn't it help to set the ashServ.exe to start delayed? This is a new feature in Vista which I havn't tried yet, but probably avast is a nice candidate for this.

I can do some further testing tomorrow eavening at the earliest but maybe someone with a litle more time at hand and running Vista could try this.
_____________________
drahnier

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: When Windows starts a red circle stays for 1 minute..
« Reply #50 on: September 15, 2006, 08:36:14 PM »
If this is the case, wouldn't it help to set the ashServ.exe to start delayed?
Do you know how to delay a Windows Service startup? I haven't found a way to do so...

This is a new feature in Vista which I havn't tried yet, but probably avast is a nice candidate for this.
OS is becoming better and better  8)
The best things in life are free.

Offline drahnier

  • Full Member
  • ***
  • Posts: 173
Re: When Windows starts a red circle stays for 1 minute..
« Reply #51 on: September 15, 2006, 09:29:05 PM »
If this is the case, wouldn't it help to set the ashServ.exe to start delayed?
Do you know how to delay a Windows Service startup? I haven't found a way to do so...

This is a new feature in Vista which I havn't tried yet, but probably avast is a nice candidate for this.
OS is becoming better and better  8)

from memory: administrative tools -> services will start a management console which will list all installed services and their current state. double-click the avast antivirus service to pop up a properties box. set startup type as "Automatic (Delayed Start)". quit mgmt console and restart computer.
_____________________
drahnier

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re: When Windows starts a red circle stays for 1 minute..
« Reply #52 on: September 15, 2006, 09:49:57 PM »
Quote
from memory: administrative tools -> services will start a management console which will list all installed services and their current state. double-click the avast antivirus service to pop up a properties box. set startup type as "Automatic (Delayed Start)". quit mgmt console and restart computer.

I see no option for Automatic (Delayed Start).  Jus for Automatic.

The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline drahnier

  • Full Member
  • ***
  • Posts: 173
Re: When Windows starts a red circle stays for 1 minute..
« Reply #53 on: September 15, 2006, 10:10:17 PM »
Quote
from memory: administrative tools -> services will start a management console which will list all installed services and their current state. double-click the avast antivirus service to pop up a properties box. set startup type as "Automatic (Delayed Start)". quit mgmt console and restart computer.

I see no option for Automatic (Delayed Start).  Jus for Automatic.



look harder ...
_____________________
drahnier

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re: When Windows starts a red circle stays for 1 minute..
« Reply #54 on: September 15, 2006, 10:42:17 PM »
All I have is automatic, manual, Disabled.  How come you have that extra option?
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84105
  • No support PMs thanks
Re: When Windows starts a red circle stays for 1 minute..
« Reply #55 on: September 16, 2006, 12:31:43 AM »
Snap Frank on XP Pro, perhaps this is a Vista beta ?
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.9.2437 (build 20.9.5758.0) UI-1.0.579/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: When Windows starts a red circle stays for 1 minute..
« Reply #56 on: September 16, 2006, 02:57:59 AM »
I see no option for Automatic (Delayed Start).  Jus for Automatic.
This is Vista...

Do you know how to delay a Windows Service startup? I haven't found a way to do so...
I was thinking on XP...  ::)

Net start command only works if the service is logged as an user.
How to start a service as System or Network?
The best things in life are free.

Offline Culpeper

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1187
Re: When Windows starts a red circle stays for 1 minute..
« Reply #57 on: September 16, 2006, 05:01:23 AM »
You can delay how services are started in XP but it requires messing with what the service is dependent upon.   Personally, I'm not willing to go that far with Avast.  If I had a problem with Avast starting up like some of the other folks then I may want to look into it.  But my 15 seconds is not long since the computer is actually still in the process of booting up when the red circle disappears on the Avast icon.

http://support.microsoft.com/?kbid=193888


« Last Edit: September 16, 2006, 05:06:18 AM by Culpeper »
The wind in the wires made a tattletale sound
And a wave broke over the railing
And every man knew, as the Captain did, too,
T'was the witch of November come stealing.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: When Windows starts a red circle stays for 1 minute..
« Reply #58 on: September 16, 2006, 08:08:30 AM »
Tech,

On my current system I just wrote a small routine to delay 2 minutes at startup and then NET START:

Diskeeper Service
Fax Service
Windows automatic update service

all the services start, as they should as SYSTEM. 

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84105
  • No support PMs thanks
Re: When Windows starts a red circle stays for 1 minute..
« Reply #59 on: September 16, 2006, 03:27:58 PM »
That sounds like a useful routine, care to share Alan ;D
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.9.2437 (build 20.9.5758.0) UI-1.0.579/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security