Author Topic: Firewall does not apply rules in "Ask" mode  (Read 11173 times)

0 Members and 1 Guest are viewing this topic.

Offline lackschuh

  • Newbie
  • *
  • Posts: 9
Re: Firewall does not apply rules in "Ask" mode
« Reply #30 on: April 15, 2020, 02:00:12 PM »
EDIT: its on a point where even with the firewall turned off (otherwise i cant browse the internet, all my programs are waiting for permission) the question is poping up. endlessly.
Why don't you use the avast firewall in "auto decision" mode in the meantime?

Because I am the imperator of my computer and not avst. I have to decide not avast. So fix this sh*t now!

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47431
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Firewall does not apply rules in "Ask" mode
« Reply #31 on: April 15, 2020, 02:24:53 PM »
EDIT: its on a point where even with the firewall turned off (otherwise i cant browse the internet, all my programs are waiting for permission) the question is poping up. endlessly.
Why don't you use the avast firewall in "auto decision" mode in the meantime?

Because I am the imperator of my computer and not avst. I have to decide not avast. So fix this sh*t now!
You apparently also got up on the wrong side of the bed this morning. Getting aggravated at those trying to help isn't the answer either.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline o_O

  • Newbie
  • *
  • Posts: 7
Re: Firewall does not apply rules in "Ask" mode
« Reply #32 on: April 15, 2020, 05:13:11 PM »
EDIT: (so i dont double post)
so this is what im going thru right now: i reboot my system. avast starts asking about programs wanting access. i hit either allow or deny. avast asks again. process repeats itself endlessly. i move avast window out of my way i start using the computer. i run other programs such internet browser. i see theyre not doing well. i bring back avast window and hit allow for that 1st program avast asked about. then, 2 or 3 more times. then, the question about the browser. then, about avast itself. then, some other program or system routine. then, avast stops asking things. then, at some point during the day one or another program, sometimes programs avast already asked during this run (including avast itself and its modules).

during the phase of asking questions again and again, i turned firewall off and even then it kept asking. i went to the settings and set things manually, and even then it kept asking.

every time im going to renew my subscription i check to see if avast is still well rated among other software (it is) and if it still have a firewall because thats the way i work. im with avast since the earlier 2000's and it was always a great help. the moment avast drops its firewall im gone, wont even wait for my plan to expire.

now, answering some suggestions: those workarounds were for the 1st days. i cant keep my system like that for this long, be it in auto mode or dealing with pop ups every 2 seconds. i have standards to keep and use my computer for many tasks, work and recreation. i dont know if this is happening because this version was rushed or there were not enough testing. its been about 10 days since reported and acknowledged and nothing changed. i even looked for older versions to manually install but all i found were too old or from unreliable sources.

the worst part is that i need to reboot my system again and will have to go thru all of that again.

EDIT: its on a point where even with the firewall turned off (otherwise i cant browse the internet, all my programs are waiting for permission) the question is popping up. endlessly.
Why don't you use the avast firewall in "auto decision" mode in the meantime?

because its not about what i choose to go with; the questions keep popping up.  at this point, i dont even trust the firewall is doing its job.
« Last Edit: April 15, 2020, 05:37:48 PM by o_O »

Offline deltoroxp

  • Newbie
  • *
  • Posts: 1
Re: Firewall does not apply rules in "Ask" mode
« Reply #33 on: April 15, 2020, 07:56:52 PM »
Same problem here. I was thinkging i post my issue here but see, many other people have the same. For now i have deactivate the avast firewall and use the windows one with an extra program to manage the firewall like I'm used to from Avast. So search for Windows Firewall Control from Malewarebytes. It works exactly the same way avast did. For each software, the window will pop up and ask you for make a rule, allow or block. That works great so far. So avast have time to fix and you can use a firewall and make the rules for them you like.

Offline PrometeusFre

  • Newbie
  • *
  • Posts: 2
Re: Firewall does not apply rules in "Ask" mode
« Reply #34 on: April 16, 2020, 09:38:25 PM »
Looks like the last beta update fixed the problem. Until now that annoying problem is gone.

Offline HawkerEng

  • Jr. Member
  • **
  • Posts: 24
Re: Firewall does not apply rules in "Ask" mode
« Reply #35 on: April 17, 2020, 12:34:59 AM »
Beta or MicroUpdate?
I thought the micro updates were more current than the beta.  What version do you have in your about section?

I rebooted this morning and am now at 20.2.5130.570. This micro update took me from previously .568 (and .566 before that).
I am still getting the problem when I put my computer to sleep and wake it up. So I do not think today's micro update solved the problem. Hopefully this gets solved soon. It's really annoying and I can't see how any one can think that "auto decide" is a valid work around as the auto rules are way to lenient.

Looks like the last beta update fixed the problem. Until now that annoying problem is gone.

Offline PrometeusFre

  • Newbie
  • *
  • Posts: 2
Re: Firewall does not apply rules in "Ask" mode
« Reply #36 on: April 17, 2020, 01:04:30 AM »
Beta or MicroUpdate?
I thought the micro updates were more current than the beta.  What version do you have in your about section?

I rebooted this morning and am now at 20.2.5130.570. This micro update took me from previously .568 (and .566 before that).
I am still getting the problem when I put my computer to sleep and wake it up. So I do not think today's micro update solved the problem. Hopefully this gets solved soon. It's really annoying and I can't see how any one can think that "auto decide" is a valid work around as the auto rules are way to lenient.

Beta. I think that Beta versions are more recent. Mine is 20.3.2403 (build 20.3.5164.561)

I have the 'Ask' option set back and all is well as before, so far.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47431
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Firewall does not apply rules in "Ask" mode
« Reply #37 on: April 17, 2020, 01:12:47 AM »
Beta or MicroUpdate?
I thought the micro updates were more current than the beta.  What version do you have in your about section?

I rebooted this morning and am now at 20.2.5130.570. This micro update took me from previously .568 (and .566 before that).
I am still getting the problem when I put my computer to sleep and wake it up. So I do not think today's micro update solved the problem. Hopefully this gets solved soon. It's really annoying and I can't see how any one can think that "auto decide" is a valid work around as the auto rules are way to lenient.

Beta. I think that Beta versions are more recent. Mine is 20.3.2403 (build 20.3.5164.561)

I have the 'Ask' option set back and all is well as before, so far.
Beta will be your next version after beta testing is completed. https://forum.avast.com/index.php?topic=233481.0
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline chris..

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2722
Re: Firewall does not apply rules in "Ask" mode
« Reply #38 on: April 17, 2020, 10:33:22 AM »
While the beta has worked well for this particular bug ("ask" mode), avast should not spend too much time on further testing with the beta.
I remind you that it's already been 15 days since customers (who pay for a product that should have already been tested upstream with a beta version, and not the opposite) have been encountering this annoying problem for their security (the workaround in "auto decision" mode is not necessarily secure and that's not what we ask a firewall to do).
I'm already hearing the responses telling us to go to beta, but customers shouldn't have to do beta testing, otherwise there's no point in paying.
« Last Edit: April 17, 2020, 10:38:30 AM by chris.. »

Offline micsi

  • Newbie
  • *
  • Posts: 2
Re: Firewall does not apply rules in "Ask" mode
« Reply #39 on: April 17, 2020, 11:44:13 AM »
Hi all!

I just upgraded to Avast Premium, and faced the same issue. What I saw was, that with Avast installed, some programs lost connection to the internet. When I opened the application settings for the firewall, I tried to set the access policy to all connections for this app, but it was "automagically" reset it to internet out level. Other than that, the whole application rule page seemed to constantly refresh itself, rewriting the values to the initial for every application. For applications with no predefined rule, I tried to set the value to "ask", then it started asking me again and again, whether to allow this application internet connection, even though this definitely had a rule listed. I tried to reset the previous value to allow and to auto-decide, the pop up window kept appearing, even after I shut the firewall off. Restarting the machine, and reinstalling avast didn't help. I also installed the Beta version, that supposedly fixes this issue, but it still persists.

Hope it gets fixed soon, I have to uninstall avast until then.

Offline chris..

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2722
Re: Firewall does not apply rules in "Ask" mode
« Reply #40 on: April 17, 2020, 12:46:10 PM »
Restarting the machine, and reinstalling avast didn't help. I also installed the Beta version, that supposedly fixes this issue, but it still persists.
Maybe you didn't uninstall avast properly? (See the link in bob3160's signature)
On the other hand, have you tried to reset the default settings in the UI "Troubleshooting" tab?

Offline micsi

  • Newbie
  • *
  • Posts: 2
Re: Firewall does not apply rules in "Ask" mode
« Reply #41 on: April 17, 2020, 05:58:04 PM »
I uninstalled the software, restarted the PC, and installed the beta version using that link. The only thing that changed is, that it said my device is not configured correctly, when scanning the Wifi connection. But it didn't give me any detail on that, and would not solve it by itself. I've got noe reponse when clicking on a device shown in the network by avast. I also tried restarting again, no luck.

Offline chris..

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2722
Re: Firewall does not apply rules in "Ask" mode
« Reply #42 on: April 17, 2020, 07:02:33 PM »
I uninstalled the software, ....
How did you uninstall it?
I wasn't talking about the beta link given by bob, but the link (in his signature) to properly uninstall avast

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47431
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Firewall does not apply rules in "Ask" mode
« Reply #43 on: April 17, 2020, 07:14:51 PM »
I uninstalled the software, ....
How did you uninstall it?
I wasn't talking about the beta link given by bob, but the link (in his signature) to properly uninstall avast

Uninstall Avast
Download the Avast Uninstall Utility to your Deskto http://www.avast.com/en-gb/uninstall-utility
For Windows XP and Vista get the Avast Removal tool from here   https://install.avcdn.avast.com/iavs9x-xp/avastclear.exe
Uninstall Avast via control panel and follow the directions.
Run the Uninstall Utility and accept the reboot to safe mode
Once complete reboot your system.
A video to help you use the Avast Uninstall Utility is available at: https://youtu.be/KD8LO8OxmvM

Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline HawkerEng

  • Jr. Member
  • **
  • Posts: 24
Re: Firewall does not apply rules in "Ask" mode
« Reply #44 on: April 17, 2020, 09:04:17 PM »
Chris, your advise is really UNHELPFUL and in many ways dangerous.
It's as if you just want to post bad advice to talk. I don't get some of you that feel the need to post bad advise or advise that doesn't answer the question, just to be heard. Do you not have something better to do with your life?


The bug reported is a known issue, the ASK bug is real and no amount of uninstalling or reinstalling is going to help that. Until AVAST fixes it, and they have acknowledged it exists, there is nothing we can do but live with it.

Reset to default not only won't help it can be very dangerous as it resets the Firewall to not asking and auto accepting everything. Besides no where has anyone said to do that or it works. The whole reset was to fix a big an early bug with the firewall not turning on at all. That issue has long since been fixed in the first micro update.

Micsi. I'm sorry, yep you hit the ASK bug that has not been fixed yet with no safe workable solution yet. The only proposed solution, to disable ask and accept everything is pretty much the same as turn off the firewall so not advised.


Restarting the machine, and reinstalling avast didn't help. I also installed the Beta version, that supposedly fixes this issue, but it still persists.
Maybe you didn't uninstall avast properly? (See the link in bob3160's signature)
On the other hand, have you tried to reset the default settings in the UI "Troubleshooting" tab?