Author Topic: avast! free Antivirus 20.2.2401 共有フォルダトラブル  (Read 7441 times)

0 Members and 1 Guest are viewing this topic.

Offline doragubu

  • Jr. Member
  • **
  • Posts: 52
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #15 on: April 24, 2020, 05:36:11 PM »
こんにちは。NONさん。



> ルータ云々というよりは、doragubu さんの使用されているネットワーク環境全体において、例えばNASの共有設定がどうとか、IPの振り方がどうとか、そういう話です。

 IPアドレスは、運用状態に依存しています。アドレス空間は、192.168.xxx.0/24です。
今回トラブったNASやPCは本稼働中なので、リモートでの操作・管理がしやすいように(ルーター側で)IP固定になっています。

 仮運用中は基本ルーターのDHCP任せです。
トラブっているOptiPlex 7040だけは例外で、本稼働に向けた環境整備中だったのでIP固定になっています。

 NASの共有設定は、基本デフォルトのままです。アクセス(読み書き)するためのパスワード無し、アカウント制御無し。
今回トラブったNASは、デフォルトでWindows/Macのアクセスが有効。

 弄るとしたら、
サーバー名。
時計をルーターに同期するよう設定。
ゴミ箱を、有効に切り替え。
ジャンボフレームに対応しているなら、最大フレームサイズへ変更。
この程度です。

 ちなみに、トラブったNASはパソコン環境の殆どが入っています。
 普通はCドライブにOSとアプリが入っている状態だと思いますが、私はインストールするタイプのアプリが殆どないので、CドライブはOSのみ、NASにポータブル版のオンラインソフトを置いた状態になっています。一部動作レスポンスに問題が出るソフトをDドライブに置いていますが。
 スタートアップに登録して常駐させているものもいくつか含まれています。

 X230が3台、基本365日24時間稼働しています。なので、今回トラブったNASは、Windows UpdateでPCを止める時しか止めることができません。



> 見たところ、それなりの数の機器/環境をお持ちのように読めましたので。

 あはは。
自作もできるようになりましたので、一部パーツを抜かれたPCをメンテして稼働させたりもしてます。
あと、QNAP、SynorogyのNASが気になってます。
Droboは自分の欲しいものではないと判ってしまったので、もういいです(--;
BuffaloのLinuxベースのNASは比較的安価で、HDDの換装が簡単なのが魅力です。が、LS510Dシリーズからはファームウェアのインストール方法が変わったらしいので、その影響で換装も(--;



> インストールしていなくとも、何らかの設定をシステムに対して行っているソフトであれば、仮に非常駐でも影響なしとは言い切れません。常駐ならなおさらです。

Proxomitronを常駐させているので、これがネットワークアクセスに関与している可能性は否定できないですね。
その関係で、Proxomitronを経由させるようにWindowsのプロクシの設定を手動設定しています。
だから『VPNアクセスのバグ』を気にしていたのです。LAN内だから影響はないだろうとは思いつつ。



> まあ、オフィス系ソフトやGIMPが影響するとは思いませんが。

 訂正です。

 GIMPはNASでした。



> ちなみに、他のNASで症状は出ますか?そのNASはSMB1ですか?

 以前にも書いたように、起動時にマウントしていないNASに問題は発生していません。
 トラブっているのは、起動時にマウントしているこのNASただ1台です。

 LS-GLシリーズよりも古い、初代LinkStation H-LANシリーズ(当然SMB1オンリー対応)も稼働していますが、やはり問題ありません。
 LS-GLシリーズはもう1台稼働していますが、マウントしていないので問題は発生していません。
 LS410Dシリーズは、アクセスしてきたマシンに合わせて自動切り替えするようなので(固定していません。できるのかな?)。
 昨晩、ASUSTOR AT3104Tを久々に稼働させましたが、これも問題ありませんでした。



> NAS のパスを除外に入れて、症状に変化はありますか?

 !?
 すいません。理解できませんでした。



> Avast がインストールされていないWindows 10 1909 64bit の環境でSMB1への接続を試験したところ、同様に×印が付く状態となりました。
> 恐らくAvast のバージョンアップとは関係なく、直近のいずれかのWindows Update により、SMB1の接続に関する挙動が変わった可能性が高いかと思います。

 整備が終わったOptiPlexでの再現テスト結果です。
 といっても、スクリーンショットがそれなりの数あるし、Avast!以外に犯人がいるかもしれないということでやることも結構あるので、今回はひとまずWindows 10(前編)です。
 つまり、『犯人はWindows 10なのか?』から始めます。
 組み込んだHDDに代替済みセクタが大量発生していますが、回復不可能セクタが発生していないので問題ないと判断しました。

 ということで、Windows 10 Pro (x64) v1909をクリーンインストールして、トラブっているNASをマウントして、再起動したときのスクリーンショットを添付します。
 この段階では、問題は発生していません。
 が、ファイルサイズが制限を超えた! 壁紙が原因だ! Jpegに変換して、さらに圧縮!
 若干眠く、そしてノイジーになったけど、無事400KBを切りました。

 Windows 10 Pro (x64) v1909インストールディスクは、2019/11/15にダウンロードしたisoファイルから作成しました。
 パッチの影響を分離するため、ネットワークに接続しない状態でクリーンインストール(つまり、ローカルアカウント)。そして、便利で邪魔な自動更新を無効にします。
 また、NASにアクセスするために『SMB 1.0/CIFS ファイル共有のサポート』にチェックを入れます。
 レジストリ・チューニングなども極力しない状態です。
 壁紙が! エクスプローラーが眩しい!!!

 この後、デバイスドライバーを一通り更新しましたが、問題は発生しませんでした。

 ここでバックアップを取って、ひとまず終了。

 ファームウェアが最新ではないようなのですが、これはダウングレードできないので後回しにします。

 次回は、Windows 10(後編)です。



 よろしくお願いします。
« Last Edit: April 24, 2020, 05:42:46 PM by doragubu »

Offline doragubu

  • Jr. Member
  • **
  • Posts: 52
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #16 on: April 24, 2020, 06:14:14 PM »
こんにちは。NONさん。



 今回は、Windows 10(後編)です。スクリーンショットを2枚しかアップロードできないかもしれないので、その2に続くかもしれませんが(^^;

 パッチは、毎月リリースされたもの全て保存してあり、バッチファイルで月別にインストールする環境が整えてあるので、2019年11月分から順次インストールしていくことで、パッチの影響を見ることができます。

 蛇足ですが、先月末頃にリリースされたVPNに関する緊急パッチKB4554364は、正式版が今月のパッチに含まれているはずなので、除外します。

 KB890830は、最後に最新版をインストールします。

 結果ですが、シロでした。今月リリース分をインストールしても、Tドライブに赤バツ印は付きませんでした。

 2020-04-2.jpgが今月分をインストールして再起動したときのスクリーンショットです。

 そして、KB890830でフルスキャンしたのが2020-04-3.jpgです。

 Tablacus Explorer を起動したもの2枚をアップロードできないので、その2に続きます(^^;



 よろしくお願いします。

Offline doragubu

  • Jr. Member
  • **
  • Posts: 52
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #17 on: April 24, 2020, 06:29:21 PM »
こんにちは。NONさん。



 今回は、Windows 10(後編)その2です。Windows 10編は、今回でひとまず最後です。

 2020-04-3-Tablacus Explorer-Clean.jpgがNASに置いた、最新版の素(アドオンを追加する前)の状態のTablacus Explorerを起動したときのスクリーンショットです。

 そして、2020-04-3-Tablacus Explorer.jpgが、アドオンを追加した後のTablacus Explorerを起動したときのスクリーンショットです。こちらには、アドオンに「ステータスバー」「アドオンの更新」「正規表現インクリメンタルサーチ」の3つが追加されているのが見えます。

 ここでバックアップを取って、ひとまず終了。

 次回は、avast!編を予定しています。
 が、最新版をダウンロードしようとしたら、『このサイトにはアクセスできません』と怒られました。
 旧版のインストーラーを使っても、最新版をインストールできるのかな?



 よろしくお願いします。

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5514
  • Whatever will be, will be.
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #18 on: April 25, 2020, 02:28:34 PM »
> ちなみに、他のNASで症状は出ますか?そのNASはSMB1ですか?

 以前にも書いたように、起動時にマウントしていないNASに問題は発生していません。
 トラブっているのは、起動時にマウントしているこのNASただ1台です。
他のNASを起動時にマウントして、問題が発生しますか?

Quote
> NAS のパスを除外に入れて、症状に変化はありますか?

 !?
 すいません。理解できませんでした。
Avast の除外に、NAS のドライブレター並びにIPアドレスを追加して、変化があるかどうか?です。
\\192.168.0.x と x:\ を追加するイメージでしょうか。

 旧版のインストーラーを使っても、最新版をインストールできるのかな?
オンラインインストーラーであれば、自動的に最新版がダウンロードされます。
オフラインインストーラーであっても、インストール時にインターネットに接続しておけば、最新版になるはずです。
Desktop: Win10 Pro 22H2 64bit / Core i5-7400 3.0GHz / 32GB RAM / Avast 23 Premium Beta(Icarus) / Comodo Firewall
Notebook: Win10 Pro 22H2 64bit / Core i5-3340M 2.7GHz / 12GB RAM / Avast 23 Free / Windows Firewall Control
Server: Win11 Pro 23H2 64bit / Core i3-4010U 1.7GHz / 12GB RAM / Avast One 23 Essential

Avast の設定について解説しています。よろしければご覧ください。

Offline doragubu

  • Jr. Member
  • **
  • Posts: 52
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #19 on: April 25, 2020, 06:43:51 PM »
> 他のNASを起動時にマウントして、問題が発生しますか?

 Buffalo製のみですが、試してみました。20.2-1.pngがスクリーンショットです。
 結果、問題が発生するのは、あの1台だけでした。
 何故か『切断した~』になっちゃってますが。でも、サブフォルダが表示されているように、読み書きは問題なくできています。
 Sドライブが、初代LinkStation HD-HLANシリーズです。
 Uドライブが、トラブっているのと同型のLS-GLシリーズです。容量は違いますが、同一バージョンのファームウェアで稼働しています。
 Vドライブが、LS410Dシリーズです。



> Avast の除外に、NAS のドライブレター並びにIPアドレスを追加して、変化があるかどうか?です。

 ひょっとして、『例外』のことですか?
 試してみましたが、変化無しでした。
 20.2-2.pngが前者のみを適用した場合、20.2-3.pngが後者も適用した場合です。



> オフラインインストーラーであっても、インストール時にインターネットに接続しておけば、最新版になるはずです。

 了解しました。
 一番新しいavast_free_antivirus_setup_online_19.7.2388.exeでインストールしてみることにします。



 まさか、『HDD以外のどこかが壊れてた』なんてことは、ないよな~。その証拠に、Windows 10編で問題は発生していないし。

 最新版Ubuntu LTSをTorrentダウンロードしようと、それ用のLS410Dの電源入れたら、一見正常に起動したように見えて、その実共有フォルダが見つからない(--;
 どこが壊れたのかなぁ。HDDかなぁ。本体側かなぁ。どっちも、イヤだなぁ~(^^;



 よろしくお願いします。
« Last Edit: April 25, 2020, 06:46:52 PM by doragubu »

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5514
  • Whatever will be, will be.
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #20 on: April 25, 2020, 07:59:59 PM »
> 他のNASを起動時にマウントして、問題が発生しますか?

 Buffalo製のみですが、試してみました。20.2-1.pngがスクリーンショットです。
 結果、問題が発生するのは、あの1台だけでした。
 何故か『切断した~』になっちゃってますが。でも、サブフォルダが表示されているように、読み書きは問題なくできています。
 Sドライブが、初代LinkStation HD-HLANシリーズです。
 Uドライブが、トラブっているのと同型のLS-GLシリーズです。容量は違いますが、同一バージョンのファームウェアで稼働しています。
 Vドライブが、LS410Dシリーズです。
当該1台だけということは、そのNAS本体の設定や、その1台に紐づくWindows側の設定、格納されているファイルのファイル名(制御文字が混じっている等)など、その1台に特有の何かがあるということだと思います。

Quote
> Avast の除外に、NAS のドライブレター並びにIPアドレスを追加して、変化があるかどうか?です。

 ひょっとして、『例外』のことですか?
 試してみましたが、変化無しでした。
 20.2-2.pngが前者のみを適用した場合、20.2-3.pngが後者も適用した場合です。
指定が誤っていると思われます。
Avast では /24 のような範囲指定はできない(通常のパス扱いされます)ので、個別のIPで登録してください。
http:// で追加してもおそらく意味がないので、¥¥192.168.x.x で追加してください。
また、Tドライブを割り当てているのであれば、T:¥も追加してください。
« Last Edit: April 25, 2020, 08:02:49 PM by NON »
Desktop: Win10 Pro 22H2 64bit / Core i5-7400 3.0GHz / 32GB RAM / Avast 23 Premium Beta(Icarus) / Comodo Firewall
Notebook: Win10 Pro 22H2 64bit / Core i5-3340M 2.7GHz / 12GB RAM / Avast 23 Free / Windows Firewall Control
Server: Win11 Pro 23H2 64bit / Core i3-4010U 1.7GHz / 12GB RAM / Avast One 23 Essential

Avast の設定について解説しています。よろしければご覧ください。

Offline doragubu

  • Jr. Member
  • **
  • Posts: 52
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #21 on: April 26, 2020, 10:08:48 AM »
こんにちは。

投稿すると、なぜか
This page isn’t working
になってしまいます。

数回試してみましたが、状況は変わりません。

回避方法はありますか?

Offline doragubu

  • Jr. Member
  • **
  • Posts: 52
Re: avast! free Antivirus 20.2.2401 共有フォルダトラブル
« Reply #22 on: April 26, 2020, 10:17:09 AM »
あ、これは問題ないんだ。

テキストファイルにして添付したら、やっぱり怒られた(^^;

放送禁止用語でも混じっていたのかな(^^;;;