Author Topic: NEW Version: 20.3 (April 2020)  (Read 17725 times)

0 Members and 1 Guest are viewing this topic.

Offline cbino

  • Jr. Member
  • **
  • Posts: 93
Re: NEW Version: 20.3 (April 2020)
« Reply #30 on: May 05, 2020, 06:00:05 PM »
Meanwhile, I uninstalled my Avast Premium.
The latest versions have always been released with several bugs and the latter more than the others (see the various problems detected and posted in this forum) despite being tested through the beta.
This is inconceivable in a product of a certain scale and that I have used for years and years considering it the best!

Offline Michael1975

  • Newbie
  • *
  • Posts: 1
Re: NEW Version: 20.3 (April 2020)
« Reply #31 on: May 05, 2020, 09:22:28 PM »
Buenas, he instalado la nueva versión y resulta al apagar el ordenador me tarda una eternidad pero si desactivo el avast no tengo ese problema y se apaga rápido quería saber que puede ser ????

Offline jacquesbiard

  • Newbie
  • *
  • Posts: 8
Re: NEW Version: 20.3 (April 2020)
« Reply #32 on: May 05, 2020, 09:24:38 PM »
After the new version was automatically installed, my PC does not fully boot. It hangs with a black screen after the Welcome screen.
I entered safe mode and uninstalled my Avast Premium, and then the PC boots without problems. I am under W7.
Anybody with the same problem ? and maybe with a solution ? I already wasted several hours and start to be really upset.
Thanks

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71128
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: NEW Version: 20.3 (April 2020)
« Reply #33 on: May 06, 2020, 06:09:46 AM »
Below I notice an animated icon (circle with a rotating ball) and which always remains so. It's normal?
That's a known bug and should get fixed soon.
Note, it has been fixed in UI 512.
Win 8.1 [x64] - Avast PremSec 21.6.6435.IBC [UI.655] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline loungehake

  • Dummy Half
  • Sr. Member
  • ****
  • Posts: 284
  • Come on lad! You've only got 70 yards to go.
Re: NEW Version: 20.3 (April 2020)
« Reply #34 on: May 06, 2020, 10:38:06 AM »
I attempted a version update from 20.2 to 20.3 using the Avast UI.  It failed (so I was told) so I repaired and restarted.  Version 20.3 is now in use.  I didn't intend that once the update had failed.

Are aesthetic updates to the GUI really necessary?  They create additional scope for program use errors and add no value to the core function of Avast which is to ensure system security and safety.

Having read other user comments on version 20.3, I was surprised to find that my initial impressions are that it seems to work OK.  The first system which received the bounty of Avast 20.3, a Windows 8.1 64bit installation on an ancient Toshiba Satellite Pro P200 with Core Duo T5550 processor is now more responsive, especially when using a web browser on newspaper websites. It had been quite sluggish but there is a definite improvement, albeit subjective.  I write this in case there was previously a performance issue and user feedback is helpful.
« Last Edit: May 06, 2020, 12:00:54 PM by loungehake »
Windows XP Pro SP3, Avast Free 10.4.2233, Malwarebytes Anti-Exploit 1.12.1.90, Comodo Memory Guardian 2.0.4.20
Windows 7 Ultimate x64, Avast Free 21.5.2470, Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware
Windows 8.1 Pro x64, Avast Free 21.5.2470, Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware
Windows 10 Pro x64, Avast Free 21.5.2470, Malwarebytes Anti-Exploit, Malwarebytes Anti-Ransomware

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71128
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: NEW Version: 20.3 (April 2020)
« Reply #35 on: May 06, 2020, 12:05:32 PM »
Having read other user comments on version 20.3, I was surprised to find that my initial impressions are that it seems to work OK.
Well, as this is a support forum, you can expect to see mostly complaints here.
Unfortunately, only very few users report back, if everything works as expected. ;)
Win 8.1 [x64] - Avast PremSec 21.6.6435.IBC [UI.655] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Pako7

  • Poster
  • *
  • Posts: 409
  • 9 years with Avast and i still recommend it
Re: NEW Version: 20.3 (April 2020)
« Reply #36 on: May 06, 2020, 04:37:27 PM »
As for this version everything is running smoothly

except for WIFI Inspector and Software Updater

Cant rename a device on WIFI inspector after trying to rename nothing changes..

Software Inspector doesn't seem to be able to find the latest versions for some software even the one which Avast own
WinXP ProSP3/ Core2Duo E8300/ 6GB Ram/ avast! Premire 20.3.2405 (Build 20.3.5200.561) / Chromium Edge Version 81.0.416.72 (Official build) (64-bit), Avast Cleanup ,avast! mobile security

Offline kemije8725

  • Newbie
  • *
  • Posts: 18
Re: NEW Version: 20.3 (April 2020)
« Reply #37 on: May 06, 2020, 05:17:00 PM »
This version is working fine. But after updating stats showed me that I had 53 attacks on my pc.
Which made me very concerned.

Should I actually be worried?

Online bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45670
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: NEW Version: 20.3 (April 2020)
« Reply #38 on: May 06, 2020, 05:24:46 PM »
This version is working fine. But after updating stats showed me that I had 53 attacks on my pc.
Which made me very concerned.

Should I actually be worried?
Without more details, it's impossible to answer your question.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, AvastOmni 21.6, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline TheOwner

  • Sr. Member
  • ****
  • Posts: 334
Re: NEW Version: 20.3 (April 2020)
« Reply #39 on: May 06, 2020, 07:02:30 PM »
After clean installation of Avast Free I opened Chrome, then I was redirected to Avast online security extension site. Second day I opened chrome I was redirected to Avast Safe price extension site.
Now Avast behave like malware and doesn't matter that happen only once. I already know Avast is spyware and adware in my PC but this is too much.
« Last Edit: May 06, 2020, 07:05:12 PM by TheOwner »

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85360
  • No support PMs thanks
Re: NEW Version: 20.3 (April 2020)
« Reply #40 on: May 06, 2020, 07:06:37 PM »
This version is working fine. But after updating stats showed me that I had 53 attacks on my pc.
Which made me very concerned.

Should I actually be worried?
Without more details, it's impossible to answer your question.

He has another topic Bob https://forum.avast.com/index.php?topic=233985.0 the problem is Avast provides little or NO detailed information in the stats area.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline cbino

  • Jr. Member
  • **
  • Posts: 93
Re: NEW Version: 20.3 (April 2020)
« Reply #41 on: May 06, 2020, 08:28:12 PM »
I reinstalled Avast Premium Security and noted that the problem is reported here
https://forum.avast.com/index.php?topic=233940.msg1545537#msg1545537
has been solved.
However, I noticed that the Password Protection module, excluded in the custom installation, was installed instead. The on / off button of the functionality obviously does not work. I tried to install Password Protection and then to uninstall it but to no avail and it is still there.
As soon as the antivirus was installed, moreover, I was able, in Settings / Troubleshooting, to access the old Settings menu present in previous versions of Avast (last item below). After a few hours that item, which recalled the old menu, is no longer available. Maybe after some updates? Can I restore it?
Thanks

Offline jacquesbiard

  • Newbie
  • *
  • Posts: 8
Re: NEW Version: 20.3 (April 2020)
« Reply #42 on: May 06, 2020, 08:41:58 PM »
As my PC does not start W7 after the update (my post above), is there a way to reinstall the previous version of Avast Premium ?
Thanks

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9368
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: NEW Version: 20.3 (April 2020)
« Reply #43 on: May 06, 2020, 09:43:57 PM »
I had "Update failed, something went wrong" error on 3 out of 3 systems where avast! notified me with exclamation mark. After clicking Check for updates again it started updating.

Also, why do I have to initiate it myself when it's suppose to be automatic? I don't want it to plaster exclamation mark warnings all over my taskbar. First on itself and then also on Security center icon. Just update the damn thing if update is due and just tell me restart is required afterwards. And not the big entire main interface opening to tell me. Just show a small popup above taskbar where you show all notifications that avast! has updated and that restart is required to complete the update. Isn't that the whole point of having it set to Automatic? To be transparent, non intrusive and up to date at all times? Don't really understand the logic behind current design of updating...
Visit my webpage Angry Sheep Blog

Offline jacques.subileau

  • Jr. Member
  • **
  • Posts: 22
Re: NEW Version: 20.3 (April 2020)
« Reply #44 on: May 07, 2020, 12:23:43 AM »
Updated 3 PC (W10/X64, free version) and got the same message for each PC when clicking "Rechercher des mises à jour". Then click again on "Rechercher des mises à jour". The update resumed and then all went fine. What was the problem ?
Main: Win10 Family 20H2 64bit / Core i7-6500 2.5GHz / 8GB RAM / Avast free 21.2
Other: Win10 Family 20H2 64bit / Core i5-7200 2.5GHz / 8GB RAM / Avast free 21.2