Author Topic: Firewall "Internet Connection Mode" setting is broken  (Read 256 times)

0 Members and 1 Guest are viewing this topic.

Offline Joshua200

  • Newbie
  • *
  • Posts: 1
Firewall "Internet Connection Mode" setting is broken
« on: May 06, 2020, 07:59:50 PM »
Currently on version 20.2.2401 (build 20.2.5130.571) of Avast Premium
Running Windows 10 build 18362

I regularly use ICS for my work as a developer because I have various devices running behind a network switch connected to my laptop. It is the easiest way to set up as a DNS pointing to my development server. However, I recently discovered that the Avast Firewall is interfering with the internet connection on both my laptop and devices connected to the network switch when ICS is turned on. I checked the Firewall settings, and the setting for "Internet Connection Mode" is enabled, but nonetheless it is blocking traffic from these connected devices. Intermittently, it is also interfering with the internet connection on my laptop. I have tried turning it off and on again, but to no avail. The problem reliably occurs between reboots whenever I turn ICS on and the only way ICS will work is if I completely disable the Avast Firewall.

Avast should fix this bug ASAP.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 68007
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Firewall "Internet Connection Mode" setting is broken
« Reply #1 on: May 07, 2020, 05:33:25 AM »
Update to the latest version (20.3.2405): https://forum.avast.com/index.php?topic=233940.0
Win 8.1 [x64] - Avast PremSec 20.10.2440.Beta3 [UI.584] - CC 5.74 - EEK - FF ESR 78.5 [NS/AOS/uBO/PB] - TB 78.5.1 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0