Author Topic: AVAST make Windows boot FAIL and does not gave access to my PC  (Read 589 times)

0 Members and 1 Guest are viewing this topic.

Offline davidegag67

  • Newbie
  • *
  • Posts: 1
Dear All,

I have avast on my lenovo ideapad,

sudently todaty while I swithed on the laptop, it appear the message that "aswVmm.sys" was missing and it does not allow to boot nor to recover into Windows 10 system.

The driver is a AVAST driver. I do not know what to do , but if I have to loose 1TB information for AVAST installation is really unfair.  Please HELP ME.
I have dismounted the ssd from my lenovo and attached to my main PC desktop but here I do not know what to do.. I would like to REMOUVE any AVAST prodcucts.

REgards
DAvide

Offline rocksteady

  • Advanced Poster
  • **
  • Posts: 1199
Re: AVAST make Windows boot FAIL and does not gave access to my PC
« Reply #1 on: May 28, 2020, 08:24:59 PM »
At the end of a very old thread (2013 vintage) there is a more recent post which may help you.
https://forum.avast.com/index.php?topic=125654.msg1518037#msg1518037

Maybe a Repair of Avast may fix the problem. You can do that via the User Interface.
Menu>Settings>Troubleshooting

If that fails and you want to uninstall (or uninstall+clean install) Avast then first need to download the uninstaller avastclear.exe , See here:
https://www.avast.com/uninstall-utility

Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 246
Re: AVAST make Windows boot FAIL and does not gave access to my PC
« Reply #2 on: May 28, 2020, 11:00:02 PM »
Hi davidegag67,

sorry for your troubles, it looks like the driver file in "C:\Windows\System32\drivers\aswvmm.sys" is missing/corrupted. If you have your SSD attached to your PC desktop, simply copy backup version from your Avast program folder:

"C:\Program Files\Avast Software\Avast\setup\Inf\x64\aswVmm.sys" --> "C:\Windows\System32\drivers\aswvmm.sys"

Of course the drive letter of attached SSD would be different from C:

It should be in bootable state again.