Author Topic: Warnings keep popping up about Malware-gen [Trj]  (Read 2062 times)

0 Members and 1 Guest are viewing this topic.

Offline o97082

  • Newbie
  • *
  • Posts: 3
Warnings keep popping up about Malware-gen [Trj]
« on: August 03, 2020, 04:35:04 PM »
Hello, first time posting here.
Today this warning kept popping up, image as follows. For non Chinese users, it says Avast terminated Internet connection from URL by process svchost.exe.

https://imgur.com/a/fmDJv6A

I think it may be about the Internet connection. It comes up about every 15-20 minutes. But when I unplugged my Internet cable the warning stops. It didn't show up in over an hour. But as soon as I plugged in Internet the warning popped up :(

If anyone knows how to solve this, or it is just false positive? Any help would be greatly appreciated. Thank you in advance.


Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37161
  • Not a avast user
Re: Warnings keep popping up about Malware-gen [Trj]
« Reply #1 on: August 03, 2020, 04:59:16 PM »
Have you tried to clear your browser surf history?


wpad.itotolink.com = Blacklisted
https://www.virustotal.com/gui/url/28fd0d3401ffc64fabeb816882a44bd121f0449f7ad940aa59ebabfe8e45601c/detection


If you still have problems, try to run these and let them remove what they find

Malwarebytes Adwcleaner  https://www.malwarebytes.com/adwcleaner/

Malwarebytes Antimalware  https://www.malwarebytes.com/

you may attach scan logs here, see below the box you write in:  Attachments and other options




« Last Edit: August 03, 2020, 10:58:18 PM by Pondus »

Offline goremarcos

  • Newbie
  • *
  • Posts: 2
Re: Warnings keep popping up about Malware-gen [Trj]
« Reply #2 on: August 04, 2020, 04:46:12 PM »
I´m with the same problem. When I connect trought other router or using the smartphone as modem it doesn´t happens anymore. But the smartphone is connected to the WiFi that the same router gives. I don´t understand why trought ethrnet happens this but not trught WiFi.

Thanks to anybody whi can help.

Offline o97082

  • Newbie
  • *
  • Posts: 3
Re: Warnings keep popping up about Malware-gen [Trj]
« Reply #3 on: August 05, 2020, 02:06:30 PM »
Have you tried to clear your browser surf history?


wpad.itotolink.com = Blacklisted
https://www.virustotal.com/gui/url/28fd0d3401ffc64fabeb816882a44bd121f0449f7ad940aa59ebabfe8e45601c/detection


If you still have problems, try to run these and let them remove what they find

Malwarebytes Adwcleaner  https://www.malwarebytes.com/adwcleaner/

Malwarebytes Antimalware  https://www.malwarebytes.com/

you may attach scan logs here, see below the box you write in:  Attachments and other options

Thank you for replying and sorry I'm a bit late. Yesterday my Internet was done because my landlord forgot to pay the bill so Internet was cut. And now it's back but the problem remains.

I cleared my Chrome history through CCleaner and Chrome Setting. The Avast warning still keeps popping up, but less frequently.
Then I downloaded Malwarebytes Adwcleaner as listed, I ran it and it did caught the Trojan from that website and seemed had blocked it as I can find it in History and labeled Blocked Website.
When Malwarebytes is running in the background, the avast warning stops but now it's malwarebyte's notification saying it's blocked an website with the same frequency.
I closed Malwarebyte and the Avast warning still pops up.

How can I blacklist a website, that site wpad.itotolink.com seems the problem.
I also ran Avast Wifi detection tool but it seems I'm connected to itotolink.com.

Attachments are my scan results and some screenshot of Avast with my translation.
Again, Thank you for helping me.

Offline o97082

  • Newbie
  • *
  • Posts: 3
Re: Warnings keep popping up about Malware-gen [Trj]
« Reply #4 on: August 05, 2020, 04:24:57 PM »
Update:

It seems the warning stopped coming out. I will let you guys know if it ever come out again.

So this is what I did:
I first clear google history, cookies and everything.
Then I download malwarebyte adwcleaner from the link Pondus' reply.
I install and run the scan. It finds the virus link and blocks them.
I also run Avast Wifi tool (or whatever it's called)

I do the above steps about twice each. Then the warning stops. Now it's been two hours without warning so I assume it's gone for good now.
Thank you guys!