Author Topic: Core Shields not starting macOS Catalina  (Read 721 times)

0 Members and 1 Guest are viewing this topic.

Offline Dusti_Jawa

  • Newbie
  • *
  • Posts: 7
Core Shields not starting macOS Catalina
« on: August 26, 2020, 08:00:29 PM »
I have a brand new install of macOS Catalina 10.15.6. After installation I clicked the allow button in system preferences, security & privacy already with no issues. After that I ensured that Avast Security was allowed full disk access as well as several system reboots, and the core shields all refuse to start. Under each of the core shields it says "We're sorry. There is some problem on our side. We'll fix it as soon as possible." On another Mac running the same version of macOS and of Avast Security I'm not having this problem at all. When issuing the command kextstat | grep avast the working Mac returns com.avast.FileShield and com.avast.PacketForwarder. On the Mac that the core shield aren't running on this same command returns nothing. I'm hoping that someone out there knows how to fix this problem! Thank you in advance!

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 294
Re: Core Shields not starting macOS Catalina
« Reply #1 on: August 27, 2020, 07:49:44 AM »
Hello,
based on your support package the kernel extensions fail to load; command
/sbin/kextload /Applications/Avast.app/Contents/Backend/drivers/AvastFileShield.kext
fails with
/Applications/Avast.app/Contents/Backend/drivers/AvastFileShield.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil( 8 ).
same for the other driver. I am not 100% sure what could be the reason, I know this happens if some of the directories on the path have not strict enough permissions (writable by non root?), but I think this also can happen when some specific MacOS directories have wrong permissions. I will forward this to my colleague who should know more specifics about how to solve this, however he is currently out of office.

Edit: please run Terminal app and in it run the following command:
sudo kextutil -v 6 /Applications/Avast.app/Contents/Backend/drivers/AvastFileShield.kext &> ~/Documents/avastkextutil.log
afterwards please send me the file avastkextutil.log from your Documents folder to ondrej.kolacek <at> avast.com

Kind regards,
Ondrej Kolacek
« Last Edit: August 27, 2020, 09:07:41 AM by ondrej.kolacek »

Offline Dusti_Jawa

  • Newbie
  • *
  • Posts: 7
Re: Core Shields not starting macOS Catalina
« Reply #2 on: August 27, 2020, 03:57:05 PM »
Ondrej Kolacek,

I just sent you the log file to the email address you specified. I am hoping that between you and your colleague that I will be able to at least know what direction to go in so I can get these Core Shields up and running. Thank you for your time!


Offline Dusti_Jawa

  • Newbie
  • *
  • Posts: 7
Re: Core Shields not starting macOS Catalina
« Reply #3 on: August 28, 2020, 03:57:14 PM »
I just wanted to post an update here in regards to my Core Shields refusing to start. The last thing I just did after thinking about the permissions error I was receiving from the terminal command was to boot into macOS recovery mode, then I went into Disk Utility and performed a repair on both of the partitions for the Operating System (the OS partition and the OS - Data partition), the disk utility didn't list any errors or repairs performed on either of the partitions, however once I booted back into macOS Catalina all three core shields started up and are working perfectly fine now! I have no idea what it actually fixed as there was nothing it listed as corrected, but this is what fixed it for me. Also to clarify, reboots did not fix the issue either, as I had done that several times already while troubleshooting.
« Last Edit: August 28, 2020, 09:18:04 PM by Dusti_Jawa »