Author Topic: RAM usage problem after upgra NEW Avast Version 20.7.2425  (Read 33836 times)

0 Members and 1 Guest are viewing this topic.

Offline TatyK

  • Newbie
  • *
  • Posts: 2
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #15 on: September 02, 2020, 06:05:06 PM »
I'm back to previous version (used the windows restore point) so can't reproduce the problem again to take screen shot.
Anyway one of the Avast processes (started by SYSTEM) was constantly at 13% CPU or higher.
Memory consumption kept getting toward 100% until it was impossible to do anything on PC and system had to be rebooted using button.
System is Windows 7 Ultimate 64 SP1.
Avast is free version and this is the first time I have problem with it, after using it for more then 10 years.
I really want to keep Avast at least while I am still using Windows (planing to switch to Linux eventually since I refuse to get win 10), so going to wait until this version is fixed or next one is released before trying to update again.

Offline Hellstra

  • Newbie
  • *
  • Posts: 2
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #16 on: September 02, 2020, 06:35:31 PM »
Long time Avast Free user here. The latest program update made my system too unstable that I had to uninstall it and then do a fresh install.

- After immediate program update Reboot, my system hanged. Had to restart using the casing Restart button.
- Total CPU usage was at constant 25% at idle.
- Out of my 4 CPU cores, 3 cores-usage was at single digit % and only 1 core-usage was at double digit %.
- My 8GB RAM-usage was at around 50% at idle.


I would provide more help but unfortunately(fortunately) I'm not experiencing any negative issues after the fresh install.


EDIT: This is how it is now:
« Last Edit: September 02, 2020, 06:57:21 PM by Hellstra »

Offline ryo-ken-ohki

  • Newbie
  • *
  • Posts: 2
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #17 on: September 02, 2020, 10:24:57 PM »
I'm not sure if it is related to this but since the Avast Update yesterday i had Blue Screen Crashes every 30-60 minutes
running Windows 7 SP1 and Avast Premium Security
On 2 other computers in our household running Windows 10, there were no issues i know of until now.
The error in the Blue Screen message was most of the time irql_not_less_or_equal.
Every hardware test succeeded without errors.
The only thing that stopped the blue screens was a complete deinstallation of Avast.
Repairing or disabling some or all of the  modules did not help.

Offline jaroslav.nix

  • Avast team
  • Jr. Member
  • *
  • Posts: 67
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #18 on: September 03, 2020, 09:41:42 AM »
Hi ryo-ken-ohki, could you please share with us the memory dump file, which had been created during the BSOD. Please look in the folder c:\Windows\Minidump (and search for the newest file available there) or file C:\Windows\memory.dmp. Thank you.

Offline ryo-ken-ohki

  • Newbie
  • *
  • Posts: 2
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #19 on: September 03, 2020, 10:53:15 AM »
i sent the dumps through the contact page since the forum does not allow dump files also not zip files as attachments.

Offline solek

  • Newbie
  • *
  • Posts: 3
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #20 on: September 03, 2020, 04:30:57 PM »
I use Avast free antivirus 20.7.2425 (сборка 20.7.5568.590)
Photo from Task manager
https://failiem.lv/u/9utjsvd2#/view/samrnugw

https://failiem.lv/u/66844kc5#/view/f6mvwqtm

c:\Windows\Minidump Dump file
https://failiem.lv/f/h4z7g9m9

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87288
  • No support PMs thanks
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #21 on: September 03, 2020, 06:02:59 PM »
Not seeing this on my Win10 Laptop with Avast Free 10.7.2425 (build 20.7.5568.590) UI-1.0.552, CPU and RAM usage relatively small.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.12.6044 (build 22.12.7758.768) UI 1.0.741/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline galantnosts

  • Newbie
  • *
  • Posts: 1
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #22 on: September 05, 2020, 12:36:01 PM »
Thank God for this thead.

Same thing happened to me, CM44/CMpb kept growing in the memory pool for me until it occupies 100% and the whole PC froze. I was using Avast Premium Security.

Repair didn't work but uninstall and a clean download/install seems to have eliminated the issue (so far)

Offline cry4dawn

  • Jr. Member
  • **
  • Posts: 48
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #23 on: September 06, 2020, 07:33:46 AM »
Using Avast Free 20.7.2425 (build 20.7.5568.590)

Using Windows 10 64 bit.

and I updated it today and I have had my system just lock up twice now since I updated it. Never had issues like this before. Obviously a serious issue that needs to be fixed now.

Odd why Avast is using 32% or more of my CPU.

I had updated the version and also uninstall and reinstalled it and does not seem to fix the problem.

« Last Edit: September 06, 2020, 07:55:21 AM by cry4dawn »

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5237
  • Whatever will be, will be.
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #24 on: September 06, 2020, 08:43:31 AM »
Does resetting Avast settings (Settings => General => Troubleshooting => RESET TO DEFAULT) make any change?
Main: Win10 Pro 22H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 22 Premium Beta(Icarus) / Comodo Firewall
Mobile: Win10 Pro 22H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 22 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline cry4dawn

  • Jr. Member
  • **
  • Posts: 48
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #25 on: September 06, 2020, 08:46:19 AM »
So I rolled back my windows system restore and my numbers are once again normal for Avast with CPU usage. No more lock ups.

I would say this is an issue that needs to be looked at as a CRITICAL issue Monday morning with a fast turn around resolution. Why are there also more Avast things added to TaskManager in the latest update?

Either way, this update should be pulled and not be allowed to destroy peoples machines.

Please see the attached image after rollback.

Can you let us know when this issue is resolved.

Offline cry4dawn

  • Jr. Member
  • **
  • Posts: 48
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #26 on: September 08, 2020, 05:39:21 PM »
Any news on this issue yet Avast? Is anyone looking into this problem?

Offline jaroslav.nix

  • Avast team
  • Jr. Member
  • *
  • Posts: 67
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #27 on: September 08, 2020, 05:56:12 PM »
We have localized one issue which might be related to this, but for confirmation we would need output from poolmon tool from some of the affected machine. The fix is going to release soon.

Offline [ ]

  • Newbie
  • *
  • Posts: 1
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #28 on: September 09, 2020, 04:06:44 AM »
Memory leak on CM44 and CMpb on poolmon.exe
Windows 10 pro 19041.508
Avast Premium Security v20.7.2425

On BDOS screen said: "ASWNETHub.sys" (On drivers folder)

log of poolmon.exe (with poolmon.exe -u -n poolmon-log.txt)
https://puu.sh/GqHdr/1020f956c1.txt

Offline dale5351

  • Jr. Member
  • **
  • Posts: 39
Re: RAM usage problem after upgra NEW Avast Version 20.7.2425
« Reply #29 on: September 20, 2020, 11:49:53 PM »
I have been having the memory leak problem for several weeks, and have just today tracked it down to an AVAST routine.
I did not have poolmon.exe on my system, but did find a program called poolmonx.exe which I have installed.  It gives me a GUI look at what is going on.  I sort on memory size and have four tags (fwLP, fwRN, fwRC and KLbp) that quickly rise to the top.  All have non-paged memory steadily rising.  In order to keep the computer from freezing, I have entered a task in the task scheduler to restart every 12 hours.  In those 12 hours, the memory usage slowly climbs from 2.0 Gbyte to 5 or 6 Gbyte, with the growth being in the non-paged memory and with those four tags adding up to most of that.
I will try the uninstall and reinstall to see if that cures the problem.
I do not seem to be able to copy the output of poolmonx and so cannot post that here.
At the moment there are 1.6 Gbyte of non-paged pool memory.   The amount of Kbytes for those four tags is 616021, 358138, 238754, and 70907 respectively.  That adds up to 1,283,830 Kbytes or 1.22 Gbytes.  Hence those four tags, all associated with aswNETHUB.sys, account for a large portion of the excess non-paged pool memory.